aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gdialog/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-06-23 19:24:46 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-06-23 19:24:46 +0000
commit3298bc2da1070540b1efefcd90dd64d429255cad (patch)
tree3766a8327b21599b18fa8f0bd014d96ce481528c /multimedia/gdialog/Makefile
parenteda32ea66ff77829eefff1140a253641c06a1d52 (diff)
downloadports-3298bc2da1070540b1efefcd90dd64d429255cad.tar.gz
ports-3298bc2da1070540b1efefcd90dd64d429255cad.zip
Notes
Diffstat (limited to 'multimedia/gdialog/Makefile')
-rw-r--r--multimedia/gdialog/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/multimedia/gdialog/Makefile b/multimedia/gdialog/Makefile
new file mode 100644
index 000000000000..f1f50e481036
--- /dev/null
+++ b/multimedia/gdialog/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: gdialog
+# Date created: Sun Apr 19 21:30:26 CEST 2009
+# Whom: Heiner Eichmann <h.eichmann@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdialog
+PORTVERSION= 2.5
+CATEGORIES= multimedia java
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= ${PORTNAME}-x
+DISTNAME= GDialog-090400-25
+
+MAINTAINER= h.eichmann@gmx.de
+COMMENT= A Project X addon to read Siemens Gigaset M740AV video recordings
+
+BUILD_DEPENDS= projectx>=0.90.4.00:${PORTSDIR}/multimedia/projectx
+RUN_DEPENDS= projectx>=0.90.4.00:${PORTSDIR}/multimedia/projectx
+
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
+USE_JIKES= no
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+SUB_FILES= gdialog
+DATADIR= ${JAVASHAREDIR}/projectx
+
+do-install:
+ ${MKDIR} ${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/GDialog.jar ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/ReleaseNotes.txt ${DATADIR}/GDialog-ReleaseNotes.txt
+ ${INSTALL_DATA} ${WRKSRC}/Copying ${DATADIR}/GDialog-Copying
+ ${INSTALL_SCRIPT} ${WRKDIR}/gdialog ${PREFIX}/bin/gdialog
+
+.include <bsd.port.mk>