aboutsummaryrefslogtreecommitdiff
path: root/multimedia/get_iplayer
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-04 08:40:27 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-04 08:40:27 +0000
commit792aa584a36efbe4df425564faea313131b198d3 (patch)
tree00ea4e913124370455f139c5a1bf971ffca14d56 /multimedia/get_iplayer
parent24ddbc27404c25a13f93eb1bb2e2dc2240f07758 (diff)
downloadports-792aa584a36efbe4df425564faea313131b198d3.tar.gz
ports-792aa584a36efbe4df425564faea313131b198d3.zip
Update to 3.26
PR: 247750 Submitted by: Jamie Landeg-Jones <jamie@catflap.org> (maintainer)
Notes
Notes: svn path=/head/; revision=541176
Diffstat (limited to 'multimedia/get_iplayer')
-rw-r--r--multimedia/get_iplayer/Makefile3
-rw-r--r--multimedia/get_iplayer/distinfo6
-rw-r--r--multimedia/get_iplayer/files/get_iplayer.in29
-rw-r--r--multimedia/get_iplayer/pkg-message12
4 files changed, 35 insertions, 15 deletions
diff --git a/multimedia/get_iplayer/Makefile b/multimedia/get_iplayer/Makefile
index 0bb7f7794a9e..5b17d1627e50 100644
--- a/multimedia/get_iplayer/Makefile
+++ b/multimedia/get_iplayer/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= get_iplayer
-PORTVERSION= 3.25
+PORTVERSION= 3.26
DISTVERSIONPREFIX= v
CATEGORIES= multimedia net
@@ -37,6 +37,7 @@ DATADIR= ${WWWDIR}
PORTDOCS= CHANGELOG.md README.md
OPTIONS_DEFINE= DOCS FFMPEG ATOMICPARSLEY
+OPTIONS_DEFAULT= FFMPEG ATOMICPARSLEY
FFMPEG_DESC= Enable file conversion using FFmpeg
FFMPEG_RUN_DEPENDS= ffmpeg>=0:multimedia/ffmpeg
ATOMICPARSLEY_DESC= Enable tagging of media files
diff --git a/multimedia/get_iplayer/distinfo b/multimedia/get_iplayer/distinfo
index 59d9df1cdf13..31631fb5fc11 100644
--- a/multimedia/get_iplayer/distinfo
+++ b/multimedia/get_iplayer/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1589850320
-SHA256 (get-iplayer-get_iplayer-v3.25_GH0.tar.gz) = 2ae278a812494d6289224e6d347c8761ec815ad84f4daf41fd0a4f62832b7d63
-SIZE (get-iplayer-get_iplayer-v3.25_GH0.tar.gz) = 146625
+TIMESTAMP = 1593606427
+SHA256 (get-iplayer-get_iplayer-v3.26_GH0.tar.gz) = 2ec105ccb47910d7f3ff7124ecaa839a8778837c12881358e627a132ba027b06
+SIZE (get-iplayer-get_iplayer-v3.26_GH0.tar.gz) = 148415
diff --git a/multimedia/get_iplayer/files/get_iplayer.in b/multimedia/get_iplayer/files/get_iplayer.in
index 51a9a046f6c0..a43a7548b775 100644
--- a/multimedia/get_iplayer/files/get_iplayer.in
+++ b/multimedia/get_iplayer/files/get_iplayer.in
@@ -9,12 +9,17 @@
# Add the following lines to /etc/rc.conf or /etc/rc.conf.local to
# enable get_iplayer:
# get_iplayer_enable (bool): Set to "NO" by default.
-# get_iplayer_chdir (string): Set to "/tmp" by default; this is where
-# downloaded files are stored. Should be writable
-# by get_iplayer user.
# get_iplayer_flags (string): Set to "" by default.
-# get_iplayer_bind_port (number): Set to 9370 by default.
-# get_iplayer_listen_address (IP address): Set to 127.0.0.1 by default.
+# get_iplayer_logfile (string): Server info messages logfile. Set to ""
+# (no logging) by default.
+# get_iplayer_chdir (string): Set to the "get_iplayer" home directory
+# by default; this is where downloaded
+# files are stored. It should be
+# writeable by the get_iplayer user.
+# get_iplayer_listen_address
+# (IP address): Set to 127.0.0.1 by default.
+# get_iplayer_bind_port
+# (number): Set to 9370 by default.
#
##########################################################
## WARNING:
@@ -34,13 +39,19 @@ desc="Server for fetching programs from iplayer and PVR functionality"
load_rc_config $name
: ${get_iplayer_enable:=NO}
-: ${get_iplayer_bind_port=9370}
+: ${get_iplayer_flags=""}
+: ${get_iplayer_chdir="$(pw usershow get_iplayer | awk -F: '{print $9}')"}
: ${get_iplayer_listen_address=127.0.0.1}
-: ${get_iplayer_chdir=/tmp}
+: ${get_iplayer_bind_port=9370}
+
+get_iplayer_logfile="${get_iplayer_logfile:+"-o $get_iplayer_logfile"}"
command=/usr/sbin/daemon
-command_args="-f -u ${name} -p /var/run/${name}/${name}.pid %%WWWDIR%%/${name}.cgi -p ${get_iplayer_bind_port} -l ${get_iplayer_listen_address} --getiplayer %%WWWDIR%%/${name}"
-procname=/usr/bin/perl
+export HOME="$get_iplayer_chdir"
+cd "$HOME" || exit 1
+command_args="-f ${get_iplayer_logfile} -u ${name} -p /var/run/${name}/${name}.pid %%WWWDIR%%/${name}.cgi -p ${get_iplayer_bind_port} -l ${get_iplayer_listen_address} --getiplayer %%WWWDIR%%/${name} ${get_iplayer_flags}"
+get_iplayer_flags="" # This is needed to stop the flags being applied to the 'daemon' program.
+procname=/usr/local/bin/perl
pidfile=/var/run/${name}/${name}.pid
start_precmd="install -d -o ${name} -m755 /var/run/${name}"
diff --git a/multimedia/get_iplayer/pkg-message b/multimedia/get_iplayer/pkg-message
index 4de1c521f914..26cb793cdea6 100644
--- a/multimedia/get_iplayer/pkg-message
+++ b/multimedia/get_iplayer/pkg-message
@@ -1,8 +1,16 @@
[
{ type: install
message: <<EOM
-You must be in the UK, or use a UK proxy, to gain
-access to most iPlayer content.
+You must be in the UK, or use a UK proxy, to gain access to most iPlayer content.
+
+To use the web server cgi script, you must set "get_iplayer_enable="YES" in
+"/etc/rc.conf", and set "get_iplayer_chdir" to a valid directory to store
+configuration files and downloads. If "get_iplayer_chdir" is unset, the
+"get_uplayer" home directory is used.
+
+In the latter case you can set the home directory to (eg) '/home/get_iplayer", with:
+
+pw usermod get_iplayer -m -M 750 -k /var/empty -d /home/get_iplayer
EOM
}
]