aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gmtk
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-10-25 16:38:26 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-10-25 16:38:26 +0000
commitbfd59e81015ab882832c53baf29db5b004b4f5c2 (patch)
tree2cbd0bf618a122942e7335734e6d90f86b1d329e /multimedia/gmtk
parentc21b48765d6cd9ccd407a364094d980b07b1c672 (diff)
downloadports-bfd59e81015ab882832c53baf29db5b004b4f5c2.tar.gz
ports-bfd59e81015ab882832c53baf29db5b004b4f5c2.zip
- Update to version 1.0.9 [1]
- Simplify Makefiles [1] - Fix build problem in gecko-mediaplayer with xulrunner>=30 [2] PR: 194498 Submitted by: tkato432@yahoo.com [1] Reviewed by: riggs [2]
Notes
Notes: svn path=/head/; revision=371488
Diffstat (limited to 'multimedia/gmtk')
-rw-r--r--multimedia/gmtk/Makefile79
-rw-r--r--multimedia/gmtk/distinfo4
-rw-r--r--multimedia/gmtk/pkg-plist95
3 files changed, 73 insertions, 105 deletions
diff --git a/multimedia/gmtk/Makefile b/multimedia/gmtk/Makefile
index f0e54cbc9883..ed4c58be5d63 100644
--- a/multimedia/gmtk/Makefile
+++ b/multimedia/gmtk/Makefile
@@ -1,83 +1,50 @@
# $FreeBSD$
PORTNAME= gmtk
-PORTVERSION= 1.0.8
-PORTREVISION= 1
+PORTVERSION= 1.0.9
CATEGORIES= multimedia gnome devel
-MASTER_SITES= GOOGLE_CODE
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE:S,/files/,/svn/packages/,}
MAINTAINER= ports@FreeBSD.org
COMMENT= Library for gnome-mplayer and gecko-mediaplayer
LICENSE= GPLv2
-BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
+BUILD_DEPENDS= p5-XML-Parser>0:${PORTSDIR}/textproc/p5-XML-Parser
+USES= gettext gmake libtool pathfix perl5 pkgconfig
+USE_XORG= x11
+USE_GNOME= glib20
+USE_PERL5= build
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-silent-rules \
+ --disable-gconf
INSTALL_TARGET= install-strip
-USES= gmake libtool pathfix perl5 pkgconfig
-USE_GNOME= glib20
USE_LDCONFIG= yes
-USE_PERL5= build
-USE_XORG= x11
CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README
+OPTIONS_DEFINE= ALSA DOCS GIO GTK3 PULSEAUDIO
-OPTIONS_DEFINE= ALSA DOCS GCONF GIO GTK3 NLS PULSEAUDIO
-GIO_DESC= Use GIO for file I/O
+ALSA_LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
+ALSA_CONFIGURE_WITH= alsa
+GIO_DESC= Use GIO for file I/O
+GIO_CONFIGURE_WITH= gio
+GTK3_USE= gnome=gtk30
+GTK3_CONFIGURE_ENABLE= gtk3
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
+PULSEAUDIO_CONFIGURE_WITH= pulseaudio
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MALSA}
-LIB_DEPENDS+= libasound.so:${PORTSDIR}/audio/alsa-lib
-CONFIGURE_ARGS+= --with-alsa
-.else
-CONFIGURE_ARGS+= --without-alsa
-.endif
-
-.if ${PORT_OPTIONS:MGCONF}
-USE_GNOME+= gconf2
-CONFIGURE_ARGS+= --enable-gconf --enable-gsettings
-.else
-CONFIGURE_ARGS+= --disable-gconf --enable-keystore
-.endif
-
-.if ${PORT_OPTIONS:MGIO}
-CONFIGURE_ARGS+= --with-gio
-.else
-CONFIGURE_ARGS+= --without-gio
-.endif
-
-.if ${PORT_OPTIONS:MGTK3}
-USE_GNOME+= gtk30
-CONFIGURE_ARGS+= --enable-gtk3
-.else
+.if !${PORT_OPTIONS:MGTK3}
USE_GNOME+= gtk20
-CONFIGURE_ARGS+= --disable-gtk3
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+= --enable-nls
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPULSEAUDIO}
-CONFIGURE_ARGS+= --with-pulseaudio
-.else
-CONFIGURE_ARGS+= --without-pulseaudio
.endif
-.if empty(PORT_OPTIONS:MDOCS)
post-patch:
- @${REINPLACE_CMD} \
- -e 's/install-data-am: install-gmtkdocDATA/install-data-am:/' \
- ${WRKSRC}/Makefile.in
-.endif
+ @${REINPLACE_CMD} -e \
+ '/COPYING\\/d ; \
+ /INSTALL\\/d' ${WRKSRC}/Makefile.in
.include <bsd.port.mk>
diff --git a/multimedia/gmtk/distinfo b/multimedia/gmtk/distinfo
index 6dc55594e10e..69c3edde0d08 100644
--- a/multimedia/gmtk/distinfo
+++ b/multimedia/gmtk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gmtk-1.0.8.tar.gz) = 007fba85f4ba6af6b3fd9d5162e18a7e4059c848e112eb03b84b2c7aad008b0c
-SIZE (gmtk-1.0.8.tar.gz) = 407790
+SHA256 (gmtk-1.0.9.tar.gz) = d633832ab3b223f9a669934d168c74574ab47a6a21f76d942c05ad78c56bf87a
+SIZE (gmtk-1.0.9.tar.gz) = 411609
diff --git a/multimedia/gmtk/pkg-plist b/multimedia/gmtk/pkg-plist
index 36c68672340d..8381a870d4b5 100644
--- a/multimedia/gmtk/pkg-plist
+++ b/multimedia/gmtk/pkg-plist
@@ -15,55 +15,56 @@ include/gmtk/gmtk_output_combo_box.h
lib/libgmlib.a
lib/libgmlib.so
lib/libgmlib.so.1
-lib/libgmlib.so.1.0.8
+lib/libgmlib.so.1.0.9
lib/libgmtk.a
lib/libgmtk.so
lib/libgmtk.so.1
-lib/libgmtk.so.1.0.8
+lib/libgmtk.so.1.0.9
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
libdata/pkgconfig/gmlib.pc
libdata/pkgconfig/gmtk.pc
-%%NLS%%share/locale/ar/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/bg/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/ca/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/cs/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/da/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/de/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/el/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/en_GB/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/es/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/et/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/eu/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/fi/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/fo/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/fy/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/gl/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/he/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/hr/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/hu/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/id/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/it/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/ko/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/lt/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/pt/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/ro/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/si/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/sr/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/sr@latin/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/th/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/tr/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/ug/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/uk/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/vi/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/zh_HK/LC_MESSAGES/gmtk.mo
-%%NLS%%share/locale/zh_TW/LC_MESSAGES/gmtk.mo
-%%NLS%%@dirrmtry share/locale/fy/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/fy
-@dirrm include/gmtk
+share/locale/ar/LC_MESSAGES/gmtk.mo
+share/locale/bg/LC_MESSAGES/gmtk.mo
+share/locale/ca/LC_MESSAGES/gmtk.mo
+share/locale/cs/LC_MESSAGES/gmtk.mo
+share/locale/da/LC_MESSAGES/gmtk.mo
+share/locale/de/LC_MESSAGES/gmtk.mo
+share/locale/el/LC_MESSAGES/gmtk.mo
+share/locale/en_GB/LC_MESSAGES/gmtk.mo
+share/locale/es/LC_MESSAGES/gmtk.mo
+share/locale/et/LC_MESSAGES/gmtk.mo
+share/locale/eu/LC_MESSAGES/gmtk.mo
+share/locale/fi/LC_MESSAGES/gmtk.mo
+share/locale/fo/LC_MESSAGES/gmtk.mo
+share/locale/fr/LC_MESSAGES/gmtk.mo
+share/locale/fy/LC_MESSAGES/gmtk.mo
+share/locale/gl/LC_MESSAGES/gmtk.mo
+share/locale/he/LC_MESSAGES/gmtk.mo
+share/locale/hr/LC_MESSAGES/gmtk.mo
+share/locale/hu/LC_MESSAGES/gmtk.mo
+share/locale/id/LC_MESSAGES/gmtk.mo
+share/locale/it/LC_MESSAGES/gmtk.mo
+share/locale/ja/LC_MESSAGES/gmtk.mo
+share/locale/ko/LC_MESSAGES/gmtk.mo
+share/locale/lt/LC_MESSAGES/gmtk.mo
+share/locale/nl/LC_MESSAGES/gmtk.mo
+share/locale/pl/LC_MESSAGES/gmtk.mo
+share/locale/pt/LC_MESSAGES/gmtk.mo
+share/locale/pt_BR/LC_MESSAGES/gmtk.mo
+share/locale/ro/LC_MESSAGES/gmtk.mo
+share/locale/ru/LC_MESSAGES/gmtk.mo
+share/locale/si/LC_MESSAGES/gmtk.mo
+share/locale/sr/LC_MESSAGES/gmtk.mo
+share/locale/sr@latin/LC_MESSAGES/gmtk.mo
+share/locale/sv/LC_MESSAGES/gmtk.mo
+share/locale/th/LC_MESSAGES/gmtk.mo
+share/locale/tr/LC_MESSAGES/gmtk.mo
+share/locale/ug/LC_MESSAGES/gmtk.mo
+share/locale/uk/LC_MESSAGES/gmtk.mo
+share/locale/vi/LC_MESSAGES/gmtk.mo
+share/locale/zh_CN/LC_MESSAGES/gmtk.mo
+share/locale/zh_HK/LC_MESSAGES/gmtk.mo
+share/locale/zh_TW/LC_MESSAGES/gmtk.mo