aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gpac-libgpac
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-04 11:15:57 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-04 11:15:57 +0000
commit8bb3bbe809c3682190fc36431bfe30b82c97eb5f (patch)
treea7916980f75ce038fcd834ab84c0c5161be6635b /multimedia/gpac-libgpac
parent4536770310e62911c6105e4c5eac3a78c19b603c (diff)
downloadports-8bb3bbe809c3682190fc36431bfe30b82c97eb5f.tar.gz
ports-8bb3bbe809c3682190fc36431bfe30b82c97eb5f.zip
- Fixes for FreeBSD 4.X:
* fix unusable header (DOS line feeds) * fix build of authoring module (DOS line feeds) * fix build of Tools module (missing header) This makes multimedia/x264 compile.
Notes
Notes: svn path=/head/; revision=134588
Diffstat (limited to 'multimedia/gpac-libgpac')
-rw-r--r--multimedia/gpac-libgpac/Makefile5
-rw-r--r--multimedia/gpac-libgpac/files/patch-M4Systems-Tools-linux-os_net.c12
2 files changed, 17 insertions, 0 deletions
diff --git a/multimedia/gpac-libgpac/Makefile b/multimedia/gpac-libgpac/Makefile
index c31472c8a593..c8949a6da4e3 100644
--- a/multimedia/gpac-libgpac/Makefile
+++ b/multimedia/gpac-libgpac/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gpac-libm4systems
DISTVERSION= 0.2.4-rc4
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gpac
@@ -36,6 +37,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|' \
${WRKSRC}/include/gpac/m4_config.h
@${RM} -f ${WRKSRC}/include/gpac/m4_config.h.bak
+ @${REINPLACE_CMD} -e 's| ||' \
+ ${WRKSRC}/include/gpac/m4_descriptors.h \
+ ${WRKSRC}/M4Systems/authoring/TextImport.c
+ @${RM} -f ${WRKSRC}/include/gpac/m4_descriptors.h.bak
.endif
do-install:
diff --git a/multimedia/gpac-libgpac/files/patch-M4Systems-Tools-linux-os_net.c b/multimedia/gpac-libgpac/files/patch-M4Systems-Tools-linux-os_net.c
new file mode 100644
index 000000000000..50270eee4c10
--- /dev/null
+++ b/multimedia/gpac-libgpac/files/patch-M4Systems-Tools-linux-os_net.c
@@ -0,0 +1,12 @@
+--- M4Systems/Tools/linux/os_net.c.orig Tue Feb 1 13:50:56 2005
++++ M4Systems/Tools/linux/os_net.c Wed May 4 13:09:09 2005
+@@ -41,6 +41,9 @@
+ #include <netinet/tcp.h>
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
++#if __FreeBSD_osversion < 500000
++#include <sys/time.h>
++#endif
+
+
+ #define INVALID_SOCKET -1