aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gpac-libgpac
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-10-31 21:33:48 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-10-31 21:33:48 +0000
commitfd854dda7208bac2f4e0a711dbf7c1f01fa19ed7 (patch)
treed664e315d15bed65917811893c3e9987c9d2f87a /multimedia/gpac-libgpac
parent50824ddb07bf45ce41e7f0f65ee4906420cef4bb (diff)
downloadports-fd854dda7208bac2f4e0a711dbf7c1f01fa19ed7.tar.gz
ports-fd854dda7208bac2f4e0a711dbf7c1f01fa19ed7.zip
multimedia/gpac-libgpac: update to 0.5
- Update to 0.5 - Export symbols required by x264 - Bump revision of dependent ports PR: ports/180906 Submitted by: Vladimir Kondratiev <wulf mail.mipt.ru>
Notes
Notes: svn path=/head/; revision=332289
Diffstat (limited to 'multimedia/gpac-libgpac')
-rw-r--r--multimedia/gpac-libgpac/Makefile33
-rw-r--r--multimedia/gpac-libgpac/distinfo4
-rw-r--r--multimedia/gpac-libgpac/files/patch-configure75
-rw-r--r--multimedia/gpac-libgpac/files/patch-export-x264-symbols28
-rw-r--r--multimedia/gpac-libgpac/files/patch-src-media_tools-img.c37
-rw-r--r--multimedia/gpac-libgpac/files/patch-src-utils-os_config_init.c39
-rw-r--r--multimedia/gpac-libgpac/files/patch-src-utils-os_divers.c126
-rw-r--r--multimedia/gpac-libgpac/pkg-plist131
8 files changed, 283 insertions, 190 deletions
diff --git a/multimedia/gpac-libgpac/Makefile b/multimedia/gpac-libgpac/Makefile
index 0ebd29a85b78..4dd30576d763 100644
--- a/multimedia/gpac-libgpac/Makefile
+++ b/multimedia/gpac-libgpac/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gpac
-PORTVERSION= 0.4.5
-PORTREVISION= 7
+PORTVERSION= 0.5.0
PORTEPOCH= 1
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/GPAC/GPAC%20${PORTVERSION}
@@ -12,20 +11,20 @@ PKGNAMESUFFIX= -libgpac
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Gpac MPEG-4 Systems library and headers
+LICENSE= LGPL21
+
WRKSRC= ${WRKDIR}/gpac
ALL_TARGET= lib
+INSTALL_TARGET= install-lib
USES= gmake
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
-
-BUILD_WRKSRC= ${WRKSRC}/src
-INSTALL_WRKSRC= ${WRKSRC}/bin/gcc
-LIBVER= 1
+USE_DOS2UNIX= src/utils/os_config_init.c
OPTIONS_DEFINE= IPV6 JPEG OPENGL SSL PNG XVIDEO
OPTIONS_DEFAULT= IPV6 JPEG SSL PNG
-CFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${WRKSRC}/include -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --cc="${CC}" --X11-path="${LOCALBASE}" \
@@ -33,15 +32,13 @@ CONFIGURE_ARGS= --cc="${CC}" --X11-path="${LOCALBASE}" \
--enable-pic \
--disable-wx \
--use-js=no --use-a52=no --use-faad=no --use-ffmpeg=no \
- --use-ft=no --use-mad=no --use-ogg=no \
- --use-openjpeg=no --use-theora=no --usr-vorbis=no
-
-CONFIGURE_ENV+= LIBVER="${LIBVER}" PTHREAD_LIBS="${PTHREAD_LIBS}"
+ --use-ft=no --use-mad=no --use-ogg=no --use-xvid=no \
+ --use-openjpeg=no --use-theora=no --use-vorbis=no
SSL_USE= OPENSSL=yes
SSL_CONFIGURE_ENABLE= ssl
OPENGL_USE= GL=gl GL=glu
-OPENGL_CONFIGURE_ENABLE= opengl
+OPENGL_CONFIGURE_ENABLE=3d
XVIDEO_LIB_DEPENDS= libXv.so:${PORTSDIR}/x11/libXv
XVIDEO_CONFIGURE_OFF= --disable-x11-xv --disable-x11-shm
IPV6_CONFIGURE_ENABLE= ipv6
@@ -54,14 +51,10 @@ PNG_CONFIGURE_OFF= --use-png=no
PNG_CFLAGS= -I${LOCALBASE}/include/libpng15
post-patch:
- ${CHMOD} +x ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|s/\.\*\\(\[0-9\]\\)\\+\$$/\\1/|s/^[^0-9]*//| ;\
+ /CFLAGS=/s/-O3//' ${WRKSRC}/configure
-do-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/include/gpac
- cd ${WRKSRC}/include/gpac && ${FIND} . | \
- ${CPIO} -vpdm -L -R ${LIBOWN}:${LIBGRP} ${STAGEDIR}${PREFIX}/include/gpac
- ${INSTALL_LIB} ${INSTALL_WRKSRC}/libgpac.so.${LIBVER} ${STAGEDIR}${PREFIX}/lib
- ${LN} -sf libgpac.so.${LIBVER} ${STAGEDIR}${PREFIX}/lib/libgpac.so
- ${INSTALL_DATA} ${INSTALL_WRKSRC}/libgpac_static.a ${STAGEDIR}${PREFIX}/lib
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/gpac.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig
.include <bsd.port.mk>
diff --git a/multimedia/gpac-libgpac/distinfo b/multimedia/gpac-libgpac/distinfo
index 6629fa5b6d72..699d7aba38d2 100644
--- a/multimedia/gpac-libgpac/distinfo
+++ b/multimedia/gpac-libgpac/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gpac-0.4.5.tar.gz) = f4039763ebec6630dc38e5e030c6573b47ced28fd009770c2e0e18b087753671
-SIZE (gpac-0.4.5.tar.gz) = 4269054
+SHA256 (gpac-0.5.0.tar.gz) = 42971ac39511a1b6d1db39af664ce887b38c8657328c88cd200d87a02de81c24
+SIZE (gpac-0.5.0.tar.gz) = 7861057
diff --git a/multimedia/gpac-libgpac/files/patch-configure b/multimedia/gpac-libgpac/files/patch-configure
deleted file mode 100644
index 36fc80127851..000000000000
--- a/multimedia/gpac-libgpac/files/patch-configure
+++ /dev/null
@@ -1,75 +0,0 @@
---- configure.orig 2008-12-02 19:04:42.000000000 +0100
-+++ configure 2012-05-19 17:09:20.000000000 +0200
-@@ -33,6 +33,7 @@
- make="make"
- strip="strip"
- cpu=`uname -m`
-+targetos=`uname -s`
- debuginfo="no"
- sdl_path=""
- sdl_local="no"
-@@ -102,7 +103,7 @@
- bigendian="no"
- SHFLAGS=-shared
- need_inet_aton="no"
--LDFLAGS="$LDFLAGS -Wl --warn-common"
-+LDFLAGS="$LDFLAGS -Wl,--warn-common"
- CFLAGS=""
- CPPFLAGS=""
- GPAC_SH_FLAGS=-lpthread
-@@ -222,7 +223,9 @@
- if [ x"$canon_arch" = x"x86_64" -o x"$canon_arch" = x"amd64" ]; then
- if [ -z "`echo $CFLAGS | grep -- -m32`" ]; then
- cpu="x86_64"
-- libdir="lib64"
-+ if [ x"$targetos" != x"FreeBSD" ]; then
-+ libdir="lib64"
-+ fi
- #that's a bit crude...
- PIC_CFLAGS="-fPIC -DPIC"
- want_pic="yes"
-@@ -280,7 +283,6 @@
- source_path="`cd \"$source_path\"; pwd`"
- fi
- # OS specific
--targetos=`uname -s`
- case $targetos in
- BeOS)
- js_flags=-DXP_BEOS
-@@ -317,8 +319,8 @@
- FreeBSD)
- make="gmake"
- LDFLAGS="$LDFLAGS -export-dynamic"
--CFLAGS="$CFLAGS -pthread"
--GPAC_SH_FLAGS=-pthread
-+DYN_LIB_SUFFIX="so.$LIBVER"
-+GPAC_SH_FLAGS="$PTHREAD_LIBS"
- freebsd="yes"
- js_flags="-DXP_UNIX -I/usr/include/js"
- ;;
-@@ -1111,6 +1113,8 @@
- LINK3D="-lopengl32 -lglu32"
- elif test "$darwin" = "yes" ; then
- LINK3D="-lgl -lglu"
-+ elif test "$freebsd" = "yes" ; then
-+ LINK3D="-lGL -lGLU"
- else
- LINK3D="-lGL -lglut"
- fi
-@@ -1673,7 +1677,7 @@
- echo "USE_X11_XV=$has_x11_xv" >> config.mak
- fi
-
--if test "$is_64" = "yes"; then
-+if test "$is_64" = "yes" -a "$freebsd" = "no" ; then
- echo "X11_LIB_PATH=$X11_PATH/lib64" >> config.mak
- else
- echo "X11_LIB_PATH=$X11_PATH/lib" >> config.mak
-@@ -1805,6 +1809,6 @@
- fi
-
- echo '%.opic : %.c' >> config.mak
--echo ' $(CC) $(CFLAGS) $(PIC_CFLAGS) -c $< -o $@' >> config.mak
-+echo " \$(CC) \$(CFLAGS) \$(PIC_CFLAGS) $INCL3D -c \$< -o \$@" >> config.mak
-
- echo "Done - type 'make help' for make info, 'make' to build"
diff --git a/multimedia/gpac-libgpac/files/patch-export-x264-symbols b/multimedia/gpac-libgpac/files/patch-export-x264-symbols
new file mode 100644
index 000000000000..cbed8dab042f
--- /dev/null
+++ b/multimedia/gpac-libgpac/files/patch-export-x264-symbols
@@ -0,0 +1,28 @@
+--- src/isomedia/avc_ext.c.orig 2012-03-27 13:48:05.000000000 +0400
++++ src/isomedia/avc_ext.c 2013-03-12 01:00:39.595690860 +0400
+@@ -170,6 +170,7 @@
+
+
+ #ifndef GPAC_DISABLE_ISOM_WRITE
++GF_EXPORT
+ GF_Err gf_isom_avc_config_new(GF_ISOFile *the_file, u32 trackNumber, GF_AVCConfig *cfg, char *URLname, char *URNname, u32 *outDescriptionIndex)
+ {
+ GF_TrackBox *trak;
+--- src/isomedia/isom_write.c.orig 2012-03-29 16:36:23.000000000 +0400
++++ src/isomedia/isom_write.c 2013-03-12 01:00:39.605699394 +0400
+@@ -1140,6 +1140,7 @@
+ return Track_SetStreamDescriptor(trak, StreamDescriptionIndex, entry->dataReferenceIndex, esd, NULL);
+ }
+
++GF_EXPORT
+ GF_Err gf_isom_set_visual_info(GF_ISOFile *movie, u32 trackNumber, u32 StreamDescriptionIndex, u32 Width, u32 Height)
+ {
+ GF_Err e;
+@@ -1187,6 +1188,7 @@
+ }
+ }
+
++GF_EXPORT
+ GF_Err gf_isom_set_pixel_aspect_ratio(GF_ISOFile *movie, u32 trackNumber, u32 StreamDescriptionIndex, u32 hSpacing, u32 vSpacing)
+ {
+ GF_Err e;
diff --git a/multimedia/gpac-libgpac/files/patch-src-media_tools-img.c b/multimedia/gpac-libgpac/files/patch-src-media_tools-img.c
deleted file mode 100644
index 1d8a614bb5e4..000000000000
--- a/multimedia/gpac-libgpac/files/patch-src-media_tools-img.c
+++ /dev/null
@@ -1,37 +0,0 @@
---- src/media_tools/img.c.orig 2008-12-01 18:39:36.000000000 +0100
-+++ src/media_tools/img.c 2012-04-24 23:00:42.000000000 +0200
-@@ -33,6 +33,7 @@
-
- /*include png.h before setjmp.h, otherwise we get compilation errors*/
- #include <png.h>
-+#include <pngpriv.h>
-
- #endif /*GPAC_HAS_PNG*/
-
-@@ -399,7 +400,7 @@
- }
- static void user_error_fn(png_structp png_ptr,png_const_charp error_msg)
- {
-- longjmp(png_ptr->jmpbuf, 1);
-+ longjmp(png_jmpbuf(png_ptr), 1);
- }
-
- GF_EXPORT
-@@ -424,7 +425,7 @@
- png_destroy_read_struct(&png_ptr, (png_infopp)NULL, (png_infopp)NULL);
- return GF_IO_ERR;
- }
-- if (setjmp(png_ptr->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png_ptr))) {
- png_destroy_info_struct(png_ptr,(png_infopp) & info_ptr);
- png_destroy_read_struct(&png_ptr, (png_infopp)NULL, (png_infopp)NULL);
- return GF_IO_ERR;
-@@ -551,7 +552,7 @@
- /* Allocate/initialize the image information data. REQUIRED */
- info_ptr = png_create_info_struct(png_ptr);
- if (info_ptr == NULL) {
-- png_destroy_write_struct(&png_ptr, png_infopp_NULL);
-+ png_destroy_write_struct(&png_ptr, (png_infopp)NULL);
- return GF_IO_ERR;
- }
-
diff --git a/multimedia/gpac-libgpac/files/patch-src-utils-os_config_init.c b/multimedia/gpac-libgpac/files/patch-src-utils-os_config_init.c
new file mode 100644
index 000000000000..d8ec969552ac
--- /dev/null
+++ b/multimedia/gpac-libgpac/files/patch-src-utils-os_config_init.c
@@ -0,0 +1,39 @@
+--- src/utils/os_config_init.c.orig 2012-03-27 13:48:05.000000000 +0400
++++ src/utils/os_config_init.c 2013-10-12 14:29:52.214068862 +0400
+@@ -51,6 +51,9 @@
+ #else
+ #ifdef GPAC_CONFIG_LINUX
+ #include <unistd.h>
++#elif defined GPAC_CONFIG_FREEBSD
++#include <sys/types.h>
++#include <sys/sysctl.h>
+ #endif
+ #define CFG_FILE_NAME ".gpacrc"
+ #define TEST_MODULE "gm_dummy_in.so"
+@@ -225,7 +228,11 @@
+ {
+ char app_path[GF_MAX_PATH];
+ char *sep;
++#ifdef GPAC_CONFIG_FREEBSD
++ size_t size = GF_MAX_PATH;
++#else
+ u32 size = GF_MAX_PATH;
++#endif
+
+ /*on OSX, Linux & co, user home is where we store the cfg file*/
+ if (path_type==GF_PATH_CFG) {
+@@ -252,6 +259,14 @@
+ if (sep) sep[0] = 0;
+ return 1;
+ }
++#elif defined(GPAC_CONFIG_FREEBSD)
++ int mib[] = { CTL_KERN, KERN_PROC, KERN_PROC_PATHNAME, -1 };
++ sysctl(mib, 4, file_path, &size, NULL, 0);
++ if (size>0) {
++ char *sep = strrchr(file_path, '/');
++ if (sep) sep[0] = 0;
++ return 1;
++ }
+ #endif
+ return 0;
+ }
diff --git a/multimedia/gpac-libgpac/files/patch-src-utils-os_divers.c b/multimedia/gpac-libgpac/files/patch-src-utils-os_divers.c
new file mode 100644
index 000000000000..3f87ed19c792
--- /dev/null
+++ b/multimedia/gpac-libgpac/files/patch-src-utils-os_divers.c
@@ -0,0 +1,126 @@
+--- src/utils/os_divers.c.orig 2012-04-04 18:47:33.000000000 +0400
++++ src/utils/os_divers.c 2013-10-12 14:25:42.047109095 +0400
+@@ -1533,6 +1533,123 @@
+ return 1;
+ }
+
++#elif defined GPAC_CONFIG_FREEBSD
++
++#include <sys/types.h>
++#include <sys/sysctl.h>
++#include <sys/time.h>
++#include <sys/user.h>
++
++#define GETSYSCTL(name, var) getsysctl(name, &(var), sizeof(var))
++int getsysctl(const char *name, void *ptr, size_t len) {
++ size_t nlen = len;
++ if (sysctlbyname(name, ptr, &nlen, NULL, 0) == -1) {
++ GF_LOG(GF_LOG_ERROR, GF_LOG_CORE, ("[RTI] sysctl(%s...) failed: %s\n", name, strerror(errno)));
++ return -1;
++ }
++ if (nlen != len) {
++ GF_LOG(GF_LOG_ERROR, GF_LOG_CORE, ("[RTI] sysctl(%s...) expected %lu, got %lu\n",
++ name, (unsigned long)len, (unsigned long)nlen));
++ return -1;
++ }
++ return 0;
++}
++
++static int stathz = 128;
++
++Bool gf_sys_get_rti_os(u32 refresh_time_ms, GF_SystemRTInfo *rti, u32 flags)
++{
++ size_t length;
++ u32 entry_time;
++ struct kinfo_proc kinfo;
++ unsigned long result;
++ u32 u_k_time = 0, idle_time = 0;
++ u64 process_u_k_time = 0;
++ long cp_time[CPUSTATES];
++ struct clockinfo clockinfo;
++
++ entry_time = gf_sys_clock();
++ if (last_update_time && (entry_time - last_update_time < refresh_time_ms)) {
++ memcpy(rti, &the_rti, sizeof(GF_SystemRTInfo));
++ return 0;
++ }
++
++ int mib[] = { CTL_KERN, KERN_PROC, KERN_PROC_PID, the_rti.pid };
++ length = sizeof(kinfo);
++
++ if (sysctl(mib, 4, &kinfo, &length, NULL, 0) == 0) {
++ process_u_k_time = (u64)(kinfo.ki_rusage.ru_utime.tv_usec + kinfo.ki_rusage.ru_stime.tv_usec) +
++ (u64)(kinfo.ki_rusage.ru_utime.tv_sec + kinfo.ki_rusage.ru_stime.tv_sec) * (u64)1000000;
++ }
++
++ if (GETSYSCTL("kern.cp_time", cp_time) == 0) {
++ u_k_time = cp_time[CP_USER] + cp_time[CP_NICE] + cp_time[CP_SYS] + cp_time[CP_INTR];
++ idle_time = cp_time[CP_IDLE];
++ }
++
++ the_rti.physical_memory = the_rti.physical_memory_avail = 0;
++ if (GETSYSCTL("hw.physmem", result) == 0) {
++ the_rti.physical_memory = result;
++ }
++
++ if (GETSYSCTL("hw.usermem", result) == 0) {
++ the_rti.physical_memory_avail = result;
++ }
++
++ the_rti.sampling_instant = last_update_time;
++
++ if (last_update_time) {
++ the_rti.sampling_period_duration = (entry_time - last_update_time);
++ the_rti.process_cpu_time_diff = (process_u_k_time - last_process_k_u_time) / 1000;
++
++ /*oops, we have no choice but to assume 100% cpu usage during this period*/
++ if (!u_k_time) {
++ the_rti.total_cpu_time_diff = the_rti.sampling_period_duration;
++ u_k_time = last_cpu_u_k_time + the_rti.sampling_period_duration;
++ the_rti.cpu_idle_time = 0;
++ the_rti.total_cpu_usage = 100;
++ if (!the_rti.process_cpu_time_diff) the_rti.process_cpu_time_diff = the_rti.total_cpu_time_diff;
++ the_rti.process_cpu_usage = (u32) ( 100 * the_rti.process_cpu_time_diff / the_rti.sampling_period_duration);
++ } else {
++ u64 samp_sys_time, cpu_idle_time;
++ /*move to ms (kern.cp_time gives times in 1/stathz unit*/
++ the_rti.total_cpu_time_diff = (u_k_time - last_cpu_u_k_time) * 1000 / stathz;
++
++ /*we're not that accurate....*/
++ if (the_rti.total_cpu_time_diff > the_rti.sampling_period_duration)
++ the_rti.sampling_period_duration = the_rti.total_cpu_time_diff;
++
++ if (!idle_time) idle_time = (the_rti.sampling_period_duration - the_rti.total_cpu_time_diff) * stathz / 1000;
++ samp_sys_time = u_k_time - last_cpu_u_k_time;
++ cpu_idle_time = idle_time - last_cpu_idle_time;
++ the_rti.total_cpu_usage = (u32) ( 100 * samp_sys_time / (cpu_idle_time + samp_sys_time ) );
++ /*move to ms (kern.cp_time gives times in 1/stathz unit*/
++ the_rti.cpu_idle_time = cpu_idle_time * 1000 / stathz;
++ if (!the_rti.process_cpu_time_diff) the_rti.process_cpu_time_diff = the_rti.total_cpu_time_diff;
++ the_rti.process_cpu_usage = (u32) ( stathz * the_rti.process_cpu_time_diff / (cpu_idle_time + samp_sys_time) / 10 );
++ }
++ } else {
++ mem_at_startup = the_rti.physical_memory_avail;
++ if (GETSYSCTL("kern.clockrate", clockinfo) == 0) {
++ if (clockinfo.stathz > 0) {
++ stathz = clockinfo.stathz;
++ }
++ }
++ }
++ the_rti.process_memory = mem_at_startup - the_rti.physical_memory_avail;
++
++#ifdef GPAC_MEMORY_TRACKING
++ the_rti.gpac_memory = gpac_allocated_memory;
++#endif
++
++ last_process_k_u_time = process_u_k_time;
++ last_cpu_idle_time = idle_time;
++ last_cpu_u_k_time = u_k_time;
++ last_update_time = entry_time;
++ memcpy(rti, &the_rti, sizeof(GF_SystemRTInfo));
++ return 1;
++}
++
+ //linux
+ #else
+
diff --git a/multimedia/gpac-libgpac/pkg-plist b/multimedia/gpac-libgpac/pkg-plist
index e4c0bf232081..90a5fa9cbebc 100644
--- a/multimedia/gpac-libgpac/pkg-plist
+++ b/multimedia/gpac-libgpac/pkg-plist
@@ -1,35 +1,46 @@
-include/gpac/avparse.h
-include/gpac/base_coding.h
-include/gpac/bifs.h
-include/gpac/bifsengine.h
-include/gpac/bitstream.h
-include/gpac/color.h
-include/gpac/compositor.h
-include/gpac/config_file.h
-include/gpac/constants.h
-include/gpac/crypt.h
-include/gpac/download.h
-include/gpac/esi.h
-include/gpac/events.h
-include/gpac/ietf.h
-include/gpac/internal/avilib.h
-include/gpac/internal/bifs_dev.h
-include/gpac/internal/bifs_tables.h
-include/gpac/internal/camera.h
-include/gpac/internal/compositor_dev.h
-include/gpac/internal/config_static.h
-include/gpac/internal/crypt_dev.h
-include/gpac/internal/ietf_dev.h
-include/gpac/internal/isomedia_dev.h
-include/gpac/internal/laser_dev.h
-include/gpac/internal/media_dev.h
-include/gpac/internal/mesh.h
-include/gpac/internal/odf_dev.h
-include/gpac/internal/ogg.h
-include/gpac/internal/scenegraph_dev.h
-include/gpac/internal/swf_dev.h
-include/gpac/internal/terminal_dev.h
-include/gpac/internal/vobsub.h
+include/gpac/ait.h
+include/gpac/avparse.h
+include/gpac/base_coding.h
+include/gpac/bifs.h
+include/gpac/bitstream.h
+include/gpac/cache.h
+include/gpac/color.h
+include/gpac/compositor.h
+include/gpac/config_file.h
+include/gpac/configuration.h
+include/gpac/constants.h
+include/gpac/crypt.h
+include/gpac/download.h
+include/gpac/dsmcc.h
+include/gpac/dvb_mpe.h
+include/gpac/esi.h
+include/gpac/events.h
+include/gpac/events_constants.h
+include/gpac/filestreamer.h
+include/gpac/ietf.h
+include/gpac/internal/avilib.h
+include/gpac/internal/bifs_dev.h
+include/gpac/internal/bifs_tables.h
+include/gpac/internal/camera.h
+include/gpac/internal/compositor_dev.h
+include/gpac/internal/crypt_dev.h
+include/gpac/internal/dvb_mpe_dev.h
+include/gpac/internal/ietf_dev.h
+include/gpac/internal/isomedia_dev.h
+include/gpac/internal/laser_dev.h
+include/gpac/internal/m3u8.h
+include/gpac/internal/media_dev.h
+include/gpac/internal/mesh.h
+include/gpac/internal/mpd.h
+include/gpac/internal/odf_dev.h
+include/gpac/internal/odf_parse_common.h
+include/gpac/internal/ogg.h
+include/gpac/internal/reedsolomon.h
+include/gpac/internal/scenegraph_dev.h
+include/gpac/internal/smjs_api.h
+include/gpac/internal/swf_dev.h
+include/gpac/internal/terminal_dev.h
+include/gpac/internal/vobsub.h
include/gpac/ismacryp.h
include/gpac/iso639.h
include/gpac/isomedia.h
@@ -39,12 +50,13 @@ include/gpac/math.h
include/gpac/media_tools.h
include/gpac/mediaobject.h
include/gpac/module.h
-include/gpac/modules/audio_out.h
-include/gpac/modules/codec.h
-include/gpac/modules/font.h
-include/gpac/modules/ipmp.h
-include/gpac/modules/js_usr.h
-include/gpac/modules/raster2d.h
+include/gpac/modules/audio_out.h
+include/gpac/modules/codec.h
+include/gpac/modules/font.h
+include/gpac/modules/hardcoded_proto.h
+include/gpac/modules/ipmp.h
+include/gpac/modules/js_usr.h
+include/gpac/modules/raster2d.h
include/gpac/modules/service.h
include/gpac/modules/term_ext.h
include/gpac/modules/video_out.h
@@ -54,27 +66,34 @@ include/gpac/network.h
include/gpac/nodes_mpeg4.h
include/gpac/nodes_svg.h
include/gpac/nodes_x3d.h
-include/gpac/nodes_xbl.h
-include/gpac/options.h
-include/gpac/path2d.h
-include/gpac/scene_manager.h
-include/gpac/scenegraph.h
-include/gpac/scenegraph_svg.h
+include/gpac/nodes_xbl.h
+include/gpac/options.h
+include/gpac/path2d.h
+include/gpac/ringbuffer.h
+include/gpac/rtp_streamer.h
+include/gpac/scene_engine.h
+include/gpac/scene_manager.h
+include/gpac/scenegraph.h
+include/gpac/scenegraph_svg.h
include/gpac/scenegraph_vrml.h
include/gpac/setup.h
include/gpac/svg_types.h
include/gpac/sync_layer.h
include/gpac/term_info.h
include/gpac/terminal.h
-include/gpac/thread.h
-include/gpac/token.h
-include/gpac/tools.h
-include/gpac/user.h
-include/gpac/utf.h
-include/gpac/xml.h
-lib/libgpac.so
-lib/libgpac.so.1
-lib/libgpac_static.a
-@dirrm include/gpac/modules
-@dirrm include/gpac/internal
-@dirrm include/gpac
+include/gpac/thread.h
+include/gpac/token.h
+include/gpac/tools.h
+include/gpac/unicode.h
+include/gpac/user.h
+include/gpac/utf.h
+include/gpac/version.h
+include/gpac/xml.h
+lib/libgpac.so
+lib/libgpac.so.2
+lib/libgpac.so.2.0.0
+lib/libgpac_static.a
+libdata/pkgconfig/gpac.pc
+@dirrm include/gpac/modules
+@dirrm include/gpac/internal
+@dirrm include/gpac