aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins-all
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2012-06-04 20:57:31 +0000
committerKoop Mast <kwm@FreeBSD.org>2012-06-04 20:57:31 +0000
commit07fa6516da771b722c2952d7bc2de0dfff18a989 (patch)
treebbf2f9246fc5094456fa69bb6c18333842221a9d /multimedia/gstreamer-plugins-all
parentb954cef30febe837cc9285e1a45fc95c8cb4eda7 (diff)
downloadports-07fa6516da771b722c2952d7bc2de0dfff18a989.tar.gz
ports-07fa6516da771b722c2952d7bc2de0dfff18a989.zip
Notes
Diffstat (limited to 'multimedia/gstreamer-plugins-all')
-rw-r--r--multimedia/gstreamer-plugins-all/Makefile36
1 files changed, 18 insertions, 18 deletions
diff --git a/multimedia/gstreamer-plugins-all/Makefile b/multimedia/gstreamer-plugins-all/Makefile
index ed92641a221b..9f171f37b7af 100644
--- a/multimedia/gstreamer-plugins-all/Makefile
+++ b/multimedia/gstreamer-plugins-all/Makefile
@@ -19,32 +19,32 @@ COMMENT= Meta-port of all gstreamer plugins with options
NO_BUILD= yes
USE_GSTREAMER= yes
-OPTIONS= # Hacky.. but it works the way it is set up...
+.include "${.CURDIR}/../../Mk/bsd.gstreamer.mk"
+
+.for all in ${_USE_GSTREAMER10_ALL}
+OPTIONS_DEFINE+= ${all:U}
+${all:U}_DESC= ${all} plugin
+OPTIONS_DEFAULT+= ${all:U}
+.endfor
.include <bsd.port.pre.mk>
# Weed out gst-plugins that can not be packaged. or are broken.
.if defined(PACKAGE_BUILDING)
-WITHOUT_FAAC= yes # Mp4 Dolby license , no package
-WITHOUT_LAME= yes # MP3 License , no package
-WITHOUT_MPEG2ENC= yes # Broken
-WITHOUT_VDPAU= yes # Needs to be build agains running kernel
-.endif
-.if ${ARCH}!="i386"
-WITHOUT_SPC= yes # i386 only
+PORT_OPTIONS:= ${PORT_OPTIONS:NFAAC} # Mp4 Dolby license , no package
+PORT_OPTIONS:= ${PORT_OPTIONS:NLAME} # MP3 License , no package
+PORT_OPTIONS:= ${PORT_OPTIONS:NPEG2ENC} # Broken
+PORT_OPTIONS:= ${PORT_OPTIONS:NVDPAU} # Needs to be build agains running kernel
.endif
-WITHOUT_FLITE= yes # broken
-# Remove core, yes
-PLUGS= ${_USE_GSTREAMER10_ALL}
-
-.for all in ${PLUGS}
-OPTIONS+= ${all:U} "${all} plugin " on
-.endfor
+.if ${ARCH} != "i386"
+PORT_OPTIONS:= ${PORT_OPTIONS:NSPC} # i386 only
+.endif
+PORT_OPTIONS:= ${PORT_OPTIONS:NFLITE} # broken
-.for f in ${PLUGS}
-.if !defined(WITHOUT_${f:U})
-USE_GSTREAMER+= ${f}
+.for f in ${OPTIONS_DEFINE}
+.if ${PORT_OPTIONS:M${f:U}}
+USE_GSTREAMER+= ${f:L}
.endif
.endfor