aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-plugins-bad
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2017-07-22 11:35:44 +0000
committerKoop Mast <kwm@FreeBSD.org>2017-07-22 11:35:44 +0000
commitd566d54fa6c982cb4bed8330d51cb11bfe3674ed (patch)
treedb8ae1482499741d4dbb123637dac45579f28eb5 /multimedia/gstreamer1-plugins-bad
parent190ced69a285efe9780eea205067282568a3063f (diff)
downloadports-d566d54fa6c982cb4bed8330d51cb11bfe3674ed.tar.gz
ports-d566d54fa6c982cb4bed8330d51cb11bfe3674ed.zip
Update GStreamer1 ports to 1.12.2.
Rework the adding of dependancies in Mk/bsd.gstreamer.mk. Previous when using USE_GSTREAMER[1] it would just add the request modules to BUILD/RUN_DEPENDS. This caused the qa script to complain because the old code didn't implicit depend on the gstreamer1 and gstreamer1-plugins[-bad] ports for the libraries they carried, even if they where present via the plugins! The new code adds implicit depends on these ports so USE_GSTREAMER[1] using ports have all the libraries included. * The mad mp3 plugin was removed, mpg123 plugin also provides mp3 decoding. Switch over ports that used the gstreamer1 mad plugin. * gtksink plugin renamed -> gtk * Hook up the sndio plugin into the framework * Add some indirect dependacies where needed * Reorder the plugin list in bsd.gstreamer.mk so only one plugin per line. When changing plugins it doesn't result in multiple lines being changed. * Remove mentions in bsd.gstreamer.mk of plugins mentions that where removed. * Depend on libunwind on i386/amd64, GStreamer links to it if it is present. PR: 220753 Exp-run by: antoine@
Notes
Notes: svn path=/head/; revision=446388
Diffstat (limited to 'multimedia/gstreamer1-plugins-bad')
-rw-r--r--multimedia/gstreamer1-plugins-bad/Makefile4
-rw-r--r--multimedia/gstreamer1-plugins-bad/files/patch-3aee20355
-rw-r--r--multimedia/gstreamer1-plugins-bad/pkg-plist21
3 files changed, 21 insertions, 59 deletions
diff --git a/multimedia/gstreamer1-plugins-bad/Makefile b/multimedia/gstreamer1-plugins-bad/Makefile
index b73a0e8b3c57..98328bcd48f0 100644
--- a/multimedia/gstreamer1-plugins-bad/Makefile
+++ b/multimedia/gstreamer1-plugins-bad/Makefile
@@ -1,7 +1,7 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= multimedia
COMMENT= GStreamer-plugins that need more quality, testing or documentation
@@ -17,6 +17,8 @@ RUN_DEPENDS+= gstreamer1-plugins>=${GST1_VERSION}${GST1_MININAL_VERSION}:multime
DIST= bad
BAD_GST_DIRS= gst-libs sys gst po pkgconfig
+# "extra" plugins enabled by default in Makefile.common
+BAD_GST_DIRS+= ext/bz2
NO_GSTREAMER_COMMON= yes
PLIST= ${.CURDIR}/pkg-plist
diff --git a/multimedia/gstreamer1-plugins-bad/files/patch-3aee203 b/multimedia/gstreamer1-plugins-bad/files/patch-3aee203
deleted file mode 100644
index 5b6024ea363f..000000000000
--- a/multimedia/gstreamer1-plugins-bad/files/patch-3aee203
+++ /dev/null
@@ -1,55 +0,0 @@
-From 3aee2039591421f4cc8757353034daf0e011a9ce Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Sebastian=20Dr=C3=B6ge?= <sebastian@centricular.com>
-Date: Thu, 31 Mar 2016 12:20:30 +0300
-Subject: adaptivedemux: Handle find_stream_for_pad() without
- g_assert_not_reached() if no pad is found
-
-Happens e.g. if a RECONFIGURE event is sent from downstream while we're
-switching pads at this very moment. The old pad is gone and the stream has a
-new pad.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=764404
-
-diff --git a/gst-libs/gst/adaptivedemux/gstadaptivedemux.c b/gst-libs/gst/adaptivedemux/gstadaptivedemux.c
-index dfe7ba7..ba29214 100644
---- gst-libs/gst/adaptivedemux/gstadaptivedemux.c
-+++ gst-libs/gst/adaptivedemux/gstadaptivedemux.c
-@@ -1092,7 +1092,6 @@ gst_adaptive_demux_find_stream_for_pad (GstAdaptiveDemux * demux, GstPad * pad)
- return stream;
- }
- }
-- g_assert_not_reached ();
- return NULL;
- }
-
-@@ -1241,6 +1240,7 @@ gst_adaptive_demux_src_event (GstPad * pad, GstObject * parent,
- gboolean update;
- gboolean ret = TRUE;
- GstSegment oldsegment;
-+ GstAdaptiveDemuxStream *stream = NULL;
-
- GST_INFO_OBJECT (demux, "Received seek event");
-
-@@ -1318,9 +1318,8 @@ gst_adaptive_demux_src_event (GstPad * pad, GstObject * parent,
- * use the one that received the event as the 'leading'
- * one to do the snap seek.
- */
-- if (IS_SNAP_SEEK (flags) && demux_class->stream_seek) {
-- GstAdaptiveDemuxStream *stream =
-- gst_adaptive_demux_find_stream_for_pad (demux, pad);
-+ if (IS_SNAP_SEEK (flags) && demux_class->stream_seek && (stream =
-+ gst_adaptive_demux_find_stream_for_pad (demux, pad))) {
- GstClockTime ts;
- GstSeekFlags stream_seek_flags = flags;
-
-@@ -1359,6 +1358,7 @@ gst_adaptive_demux_src_event (GstPad * pad, GstObject * parent,
- GST_DEBUG_OBJECT (demux, "Adapted snap seek to %" GST_PTR_FORMAT,
- event);
- }
-+ stream = NULL;
-
- gst_segment_do_seek (&demux->segment, rate, format, flags, start_type,
- start, stop_type, stop, &update);
---
-cgit v0.10.2
-
diff --git a/multimedia/gstreamer1-plugins-bad/pkg-plist b/multimedia/gstreamer1-plugins-bad/pkg-plist
index 3cfe35498fdc..262d2d53efa6 100644
--- a/multimedia/gstreamer1-plugins-bad/pkg-plist
+++ b/multimedia/gstreamer1-plugins-bad/pkg-plist
@@ -1,3 +1,5 @@
+include/gstreamer-%%VERSION%%/gst/allocators/badallocators.h
+include/gstreamer-%%VERSION%%/gst/allocators/gstphysmemory.h
include/gstreamer-%%VERSION%%/gst/audio/gstaudioaggregator.h
include/gstreamer-%%VERSION%%/gst/base/gstaggregator.h
include/gstreamer-%%VERSION%%/gst/basecamerabinsrc/gstbasecamerasrc.h
@@ -5,6 +7,7 @@ include/gstreamer-%%VERSION%%/gst/basecamerabinsrc/gstcamerabin-enum.h
include/gstreamer-%%VERSION%%/gst/basecamerabinsrc/gstcamerabinpreview.h
include/gstreamer-%%VERSION%%/gst/codecparsers/gsth264parser.h
include/gstreamer-%%VERSION%%/gst/codecparsers/gsth265parser.h
+include/gstreamer-%%VERSION%%/gst/codecparsers/gstjpeg2000sampling.h
include/gstreamer-%%VERSION%%/gst/codecparsers/gstjpegparser.h
include/gstreamer-%%VERSION%%/gst/codecparsers/gstmpeg4parser.h
include/gstreamer-%%VERSION%%/gst/codecparsers/gstmpegvideometa.h
@@ -38,6 +41,7 @@ include/gstreamer-%%VERSION%%/gst/uridownloader/gsturidownloader.h
include/gstreamer-%%VERSION%%/gst/uridownloader/gsturidownloader_debug.h
include/gstreamer-%%VERSION%%/gst/video/gstvideoaggregator.h
include/gstreamer-%%VERSION%%/gst/video/gstvideoaggregatorpad.h
+lib/girepository-1.0/GstBadAllocators-%%VERSION%%.typelib
lib/girepository-1.0/GstInsertBin-%%VERSION%%.typelib
lib/girepository-1.0/GstMpegts-%%VERSION%%.typelib
lib/girepository-1.0/GstPlayer-%%VERSION%%.typelib
@@ -46,19 +50,22 @@ lib/gstreamer-%%VERSION%%/libgstadpcmdec.so
lib/gstreamer-%%VERSION%%/libgstadpcmenc.so
lib/gstreamer-%%VERSION%%/libgstaiff.so
lib/gstreamer-%%VERSION%%/libgstasfmux.so
+lib/gstreamer-%%VERSION%%/libgstaudiobuffersplit.so
lib/gstreamer-%%VERSION%%/libgstaudiofxbad.so
lib/gstreamer-%%VERSION%%/libgstaudiomixer.so
+lib/gstreamer-%%VERSION%%/libgstaudiomixmatrix.so
lib/gstreamer-%%VERSION%%/libgstaudiovisualizers.so
lib/gstreamer-%%VERSION%%/libgstautoconvert.so
lib/gstreamer-%%VERSION%%/libgstbayer.so
-lib/gstreamer-%%VERSION%%/libgstcamerabin2.so
+lib/gstreamer-%%VERSION%%/libgstbz2.so
+lib/gstreamer-%%VERSION%%/libgstcamerabin.so
lib/gstreamer-%%VERSION%%/libgstcoloreffects.so
lib/gstreamer-%%VERSION%%/libgstcompositor.so
-lib/gstreamer-%%VERSION%%/libgstdataurisrc.so
lib/gstreamer-%%VERSION%%/libgstdebugutilsbad.so
lib/gstreamer-%%VERSION%%/libgstdvb.so
lib/gstreamer-%%VERSION%%/libgstdvbsuboverlay.so
lib/gstreamer-%%VERSION%%/libgstdvdspu.so
+lib/gstreamer-%%VERSION%%/libgstfaceoverlay.so
lib/gstreamer-%%VERSION%%/libgstfestival.so
lib/gstreamer-%%VERSION%%/libgstfieldanalysis.so
lib/gstreamer-%%VERSION%%/libgstfreeverb.so
@@ -73,6 +80,7 @@ lib/gstreamer-%%VERSION%%/libgstivfparse.so
lib/gstreamer-%%VERSION%%/libgstivtc.so
lib/gstreamer-%%VERSION%%/libgstjp2kdecimator.so
lib/gstreamer-%%VERSION%%/libgstjpegformat.so
+lib/gstreamer-%%VERSION%%/libgstlegacyrawparse.so
lib/gstreamer-%%VERSION%%/libgstmidi.so
lib/gstreamer-%%VERSION%%/libgstmpegpsdemux.so
lib/gstreamer-%%VERSION%%/libgstmpegpsmux.so
@@ -82,8 +90,8 @@ lib/gstreamer-%%VERSION%%/libgstmxf.so
lib/gstreamer-%%VERSION%%/libgstnetsim.so
lib/gstreamer-%%VERSION%%/libgstpcapparse.so
lib/gstreamer-%%VERSION%%/libgstpnm.so
-lib/gstreamer-%%VERSION%%/libgstrawparse.so
lib/gstreamer-%%VERSION%%/libgstremovesilence.so
+lib/gstreamer-%%VERSION%%/libgstrfbsrc.so
lib/gstreamer-%%VERSION%%/libgstrtponvif.so
lib/gstreamer-%%VERSION%%/libgstsdpelem.so
lib/gstreamer-%%VERSION%%/libgstsegmentclip.so
@@ -93,6 +101,7 @@ lib/gstreamer-%%VERSION%%/libgstsmooth.so
lib/gstreamer-%%VERSION%%/libgstspeed.so
lib/gstreamer-%%VERSION%%/libgststereo.so
lib/gstreamer-%%VERSION%%/libgstsubenc.so
+lib/gstreamer-%%VERSION%%/libgsttimecode.so
lib/gstreamer-%%VERSION%%/libgstvideofiltersbad.so
lib/gstreamer-%%VERSION%%/libgstvideoframe_audiolevel.so
lib/gstreamer-%%VERSION%%/libgstvideoparsersbad.so
@@ -103,6 +112,9 @@ lib/gstreamer-%%VERSION%%/libgstyadif.so
lib/libgstadaptivedemux-%%VERSION%%.so
lib/libgstadaptivedemux-%%VERSION%%.so.0
lib/libgstadaptivedemux-%%VERSION%%.so.%%SOVERSION%%
+lib/libgstbadallocators-%%VERSION%%.so
+lib/libgstbadallocators-%%VERSION%%.so.0
+lib/libgstbadallocators-%%VERSION%%.so.%%SOVERSION%%
lib/libgstbadaudio-%%VERSION%%.so
lib/libgstbadaudio-%%VERSION%%.so.0
lib/libgstbadaudio-%%VERSION%%.so.%%SOVERSION%%
@@ -133,6 +145,7 @@ lib/libgstplayer-%%VERSION%%.so.%%SOVERSION%%
lib/libgsturidownloader-%%VERSION%%.so
lib/libgsturidownloader-%%VERSION%%.so.0
lib/libgsturidownloader-%%VERSION%%.so.%%SOVERSION%%
+libdata/pkgconfig/gstreamer-bad-allocators-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-bad-audio-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-bad-base-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-bad-video-%%VERSION%%.pc
@@ -141,6 +154,7 @@ libdata/pkgconfig/gstreamer-insertbin-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-mpegts-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-player-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-plugins-bad-%%VERSION%%.pc
+share/gir-1.0/GstBadAllocators-%%VERSION%%.gir
share/gir-1.0/GstInsertBin-%%VERSION%%.gir
share/gir-1.0/GstMpegts-%%VERSION%%.gir
share/gir-1.0/GstPlayer-%%VERSION%%.gir
@@ -159,6 +173,7 @@ share/locale/es/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/eu/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/fi/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/fr/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
+share/locale/fur/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/gl/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/hr/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/hu/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo