aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-plugins-good
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-04-27 20:56:38 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-04-27 20:56:38 +0000
commit05d2886d27cb71e18dd917003926e7a165f40fa1 (patch)
treef41470c54496d3f979b6727ed30042270de45c74 /multimedia/gstreamer1-plugins-good
parentf52d0a56a81ecf2c86d06a719ee9cb91b7d5d005 (diff)
downloadports-05d2886d27cb71e18dd917003926e7a165f40fa1.tar.gz
ports-05d2886d27cb71e18dd917003926e7a165f40fa1.zip
Add Gstreamer 1.0.7. This is the new stable version of the
Gstreamer multimedia framework. Use the USE_GSTREAMER1 macro to select Gstreamer 1.0 plugins. A new chapter for the porters handbook about gstreamer is a work in progress. X related plugins are now stand alone. The gio plugin is now part of the gstreamer1-plugins port and the oss plugins are now part of the gstreamer1-plugins-good port. Note that the pulseaudio plugin is missing because it needs a newer version of pulseaudio. Also there are still a number of plugins from -bad which haven't been ported to the 1.0 API yet.
Notes
Notes: svn path=/head/; revision=316693
Diffstat (limited to 'multimedia/gstreamer1-plugins-good')
-rw-r--r--multimedia/gstreamer1-plugins-good/Makefile39
-rw-r--r--multimedia/gstreamer1-plugins-good/files/patch-configure11
-rw-r--r--multimedia/gstreamer1-plugins-good/files/patch-sys_oss_gstosshelper.c20
-rw-r--r--multimedia/gstreamer1-plugins-good/pkg-plist139
4 files changed, 209 insertions, 0 deletions
diff --git a/multimedia/gstreamer1-plugins-good/Makefile b/multimedia/gstreamer1-plugins-good/Makefile
new file mode 100644
index 000000000000..fb00a9188416
--- /dev/null
+++ b/multimedia/gstreamer1-plugins-good/Makefile
@@ -0,0 +1,39 @@
+# Created by: Michael Johnson <ahze@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/multimedia/gstreamer1-plugins-good/Makefile,v 1.4 2013/01/15 21:43:45 kwm Exp $
+
+PORTREVISION= 0
+CATEGORIES= multimedia
+
+COMMENT= Good gstreamer-plugins
+
+GST_PLUGIN= good
+GST_PLUGIN_SUFFIX= -good
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+
+CONFIGURE_ARGS+=--enable-monoscope
+
+BUILD_DEPENDS+= gstreamer1-plugins>=${GST1_VERSION}${GST1_MINIMAL_VERSION}:${PORTSDIR}/multimedia/gstreamer1-plugins
+RUN_DEPENDS+= gstreamer1-plugins>=${GST1_VERSION}${GST1_MINIMAL_VERSION}:${PORTSDIR}/multimedia/gstreamer1-plugins
+
+DIST= good
+GOOD_GST_DIRS= gst sys po
+
+PLIST= ${.CURDIR}/pkg-plist
+FILESDIR= ${.CURDIR}/files
+PATCHDIR= ${.CURDIR}/files
+NO_GSTREAMER_COMMON= yes
+
+do-build:
+.for dir in ${GOOD_GST_DIRS}
+ @(cd ${BUILD_WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+.endfor
+
+do-install:
+.for dir in ${GOOD_GST_DIRS}
+ @(cd ${INSTALL_WRKSRC}/${dir} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
+
+.endfor
+
+.include "${MASTERDIR}/Makefile"
diff --git a/multimedia/gstreamer1-plugins-good/files/patch-configure b/multimedia/gstreamer1-plugins-good/files/patch-configure
new file mode 100644
index 000000000000..64669fdab733
--- /dev/null
+++ b/multimedia/gstreamer1-plugins-good/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2010-12-01 19:16:00.000000000 +0100
++++ configure 2010-12-02 15:39:17.000000000 +0100
+@@ -24955,7 +24955,7 @@ if test "${with_default_audiosink+set}"
+
+ else
+
+- DEFAULT_AUDIOSINK="$DEFAULT_AUDIOSINK"
++ DEFAULT_VISUALIZER="$DEFAULT_VISUALIZER"
+
+ fi
+
diff --git a/multimedia/gstreamer1-plugins-good/files/patch-sys_oss_gstosshelper.c b/multimedia/gstreamer1-plugins-good/files/patch-sys_oss_gstosshelper.c
new file mode 100644
index 000000000000..34fdd31191a2
--- /dev/null
+++ b/multimedia/gstreamer1-plugins-good/files/patch-sys_oss_gstosshelper.c
@@ -0,0 +1,20 @@
+--- sys/oss/gstosshelper.c.orig Sun Apr 2 03:23:53 2006
++++ sys/oss/gstosshelper.c Sun Apr 2 03:25:44 2006
+@@ -343,13 +344,17 @@ gst_oss_helper_rate_check_rate (GstOssPr
+ int format;
+ int n_channels;
+ int ret;
++ int rst;
+
+ rate = irate;
+ format = probe->format;
+ n_channels = probe->n_channels;
++ rst = 4000; /* XXX Lowest supported rate for FreeBSD. */
+
+ GST_LOG ("checking format %d, channels %d, rate %d",
+ format, n_channels, rate);
++ /* Reset rate to lowest supported rate. */
++ ioctl (probe->fd, SNDCTL_DSP_SPEED, &rst);
+ ret = ioctl (probe->fd, SNDCTL_DSP_SETFMT, &format);
+ if (ret < 0)
+ return -1;
diff --git a/multimedia/gstreamer1-plugins-good/pkg-plist b/multimedia/gstreamer1-plugins-good/pkg-plist
new file mode 100644
index 000000000000..504cad934a5e
--- /dev/null
+++ b/multimedia/gstreamer1-plugins-good/pkg-plist
@@ -0,0 +1,139 @@
+lib/gstreamer-%%VERSION%%/libgstalaw.la
+lib/gstreamer-%%VERSION%%/libgstalaw.so
+lib/gstreamer-%%VERSION%%/libgstalpha.la
+lib/gstreamer-%%VERSION%%/libgstalpha.so
+lib/gstreamer-%%VERSION%%/libgstalphacolor.la
+lib/gstreamer-%%VERSION%%/libgstalphacolor.so
+lib/gstreamer-%%VERSION%%/libgstapetag.la
+lib/gstreamer-%%VERSION%%/libgstapetag.so
+lib/gstreamer-%%VERSION%%/libgstaudiofx.la
+lib/gstreamer-%%VERSION%%/libgstaudiofx.so
+lib/gstreamer-%%VERSION%%/libgstaudioparsers.la
+lib/gstreamer-%%VERSION%%/libgstaudioparsers.so
+lib/gstreamer-%%VERSION%%/libgstauparse.la
+lib/gstreamer-%%VERSION%%/libgstauparse.so
+lib/gstreamer-%%VERSION%%/libgstautodetect.la
+lib/gstreamer-%%VERSION%%/libgstautodetect.so
+lib/gstreamer-%%VERSION%%/libgstavi.la
+lib/gstreamer-%%VERSION%%/libgstavi.so
+lib/gstreamer-%%VERSION%%/libgstcutter.la
+lib/gstreamer-%%VERSION%%/libgstcutter.so
+lib/gstreamer-%%VERSION%%/libgstdebug.la
+lib/gstreamer-%%VERSION%%/libgstdebug.so
+lib/gstreamer-%%VERSION%%/libgstdeinterlace.la
+lib/gstreamer-%%VERSION%%/libgstdeinterlace.so
+lib/gstreamer-%%VERSION%%/libgsteffectv.la
+lib/gstreamer-%%VERSION%%/libgsteffectv.so
+lib/gstreamer-%%VERSION%%/libgstequalizer.la
+lib/gstreamer-%%VERSION%%/libgstequalizer.so
+lib/gstreamer-%%VERSION%%/libgstflv.la
+lib/gstreamer-%%VERSION%%/libgstflv.so
+lib/gstreamer-%%VERSION%%/libgstflxdec.la
+lib/gstreamer-%%VERSION%%/libgstflxdec.so
+lib/gstreamer-%%VERSION%%/libgstgoom.la
+lib/gstreamer-%%VERSION%%/libgstgoom.so
+lib/gstreamer-%%VERSION%%/libgstgoom2k1.la
+lib/gstreamer-%%VERSION%%/libgstgoom2k1.so
+lib/gstreamer-%%VERSION%%/libgsticydemux.la
+lib/gstreamer-%%VERSION%%/libgsticydemux.so
+lib/gstreamer-%%VERSION%%/libgstid3demux.la
+lib/gstreamer-%%VERSION%%/libgstid3demux.so
+lib/gstreamer-%%VERSION%%/libgstimagefreeze.la
+lib/gstreamer-%%VERSION%%/libgstimagefreeze.so
+lib/gstreamer-%%VERSION%%/libgstinterleave.la
+lib/gstreamer-%%VERSION%%/libgstinterleave.so
+lib/gstreamer-%%VERSION%%/libgstlevel.la
+lib/gstreamer-%%VERSION%%/libgstlevel.so
+lib/gstreamer-%%VERSION%%/libgstmatroska.la
+lib/gstreamer-%%VERSION%%/libgstmatroska.so
+lib/gstreamer-%%VERSION%%/libgstmulaw.la
+lib/gstreamer-%%VERSION%%/libgstmulaw.so
+lib/gstreamer-%%VERSION%%/libgstmultifile.la
+lib/gstreamer-%%VERSION%%/libgstmultifile.so
+lib/gstreamer-%%VERSION%%/libgstmultipart.la
+lib/gstreamer-%%VERSION%%/libgstmultipart.so
+lib/gstreamer-%%VERSION%%/libgstnavigationtest.la
+lib/gstreamer-%%VERSION%%/libgstnavigationtest.so
+lib/gstreamer-%%VERSION%%/libgstoss4audio.la
+lib/gstreamer-%%VERSION%%/libgstoss4audio.so
+lib/gstreamer-%%VERSION%%/libgstossaudio.la
+lib/gstreamer-%%VERSION%%/libgstossaudio.so
+lib/gstreamer-%%VERSION%%/libgstisomp4.la
+lib/gstreamer-%%VERSION%%/libgstisomp4.so
+lib/gstreamer-%%VERSION%%/libgstreplaygain.la
+lib/gstreamer-%%VERSION%%/libgstreplaygain.so
+lib/gstreamer-%%VERSION%%/libgstrtp.la
+lib/gstreamer-%%VERSION%%/libgstrtp.so
+lib/gstreamer-%%VERSION%%/libgstrtpmanager.la
+lib/gstreamer-%%VERSION%%/libgstrtpmanager.so
+lib/gstreamer-%%VERSION%%/libgstrtsp.la
+lib/gstreamer-%%VERSION%%/libgstrtsp.so
+lib/gstreamer-%%VERSION%%/libgstshapewipe.la
+lib/gstreamer-%%VERSION%%/libgstshapewipe.so
+lib/gstreamer-%%VERSION%%/libgstsmpte.la
+lib/gstreamer-%%VERSION%%/libgstsmpte.so
+lib/gstreamer-%%VERSION%%/libgstspectrum.la
+lib/gstreamer-%%VERSION%%/libgstspectrum.so
+lib/gstreamer-%%VERSION%%/libgstudp.la
+lib/gstreamer-%%VERSION%%/libgstudp.so
+lib/gstreamer-%%VERSION%%/libgstvideobox.la
+lib/gstreamer-%%VERSION%%/libgstvideobox.so
+lib/gstreamer-%%VERSION%%/libgstvideocrop.la
+lib/gstreamer-%%VERSION%%/libgstvideocrop.so
+lib/gstreamer-%%VERSION%%/libgstvideofilter.la
+lib/gstreamer-%%VERSION%%/libgstvideofilter.so
+lib/gstreamer-%%VERSION%%/libgstvideomixer.la
+lib/gstreamer-%%VERSION%%/libgstvideomixer.so
+lib/gstreamer-%%VERSION%%/libgstwavenc.la
+lib/gstreamer-%%VERSION%%/libgstwavenc.so
+lib/gstreamer-%%VERSION%%/libgstwavparse.la
+lib/gstreamer-%%VERSION%%/libgstwavparse.so
+lib/gstreamer-%%VERSION%%/libgsty4menc.la
+lib/gstreamer-%%VERSION%%/libgsty4menc.so
+share/gstreamer-%%VERSION%%/presets/GstIirEqualizer10Bands.prs
+share/gstreamer-%%VERSION%%/presets/GstIirEqualizer3Bands.prs
+share/locale/af/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/az/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/bg/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/ca/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/cs/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/da/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/de/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/el/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/en_GB/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/eo/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/es/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/eu/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/fi/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/fr/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/gl/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/hr/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/hu/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/id/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/it/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/ja/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/lt/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/lv/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/mt/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/nb/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/nl/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/or/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/pl/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/pt_BR/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/ro/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/ru/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/sk/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/sl/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/sq/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/sr/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/sv/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/tr/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/uk/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/vi/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/zh_CN/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/zh_HK/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+share/locale/zh_TW/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/gstreamer-%%VERSION%%/presets
+@dirrmtry share/gstreamer-%%VERSION%%