aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-plugins-svt-hevc
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-05-12 06:36:01 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-05-12 06:36:01 +0000
commitd4c68d5eb2d15c13173917ff0aae0775cee3f64d (patch)
tree227156f0c08383a24ac15fa9d635e6b29d32b6d0 /multimedia/gstreamer1-plugins-svt-hevc
parentccad449cddc7a5b1a98c4e36118e0e15dcce062d (diff)
downloadports-d4c68d5eb2d15c13173917ff0aae0775cee3f64d.tar.gz
ports-d4c68d5eb2d15c13173917ff0aae0775cee3f64d.zip
multimedia/svt-*: hook GStreamer plugins
Notes
Notes: svn path=/head/; revision=501363
Diffstat (limited to 'multimedia/gstreamer1-plugins-svt-hevc')
-rw-r--r--multimedia/gstreamer1-plugins-svt-hevc/Makefile30
-rw-r--r--multimedia/gstreamer1-plugins-svt-hevc/distinfo3
-rw-r--r--multimedia/gstreamer1-plugins-svt-hevc/files/patch-gstsvthevcenc.c19
-rw-r--r--multimedia/gstreamer1-plugins-svt-hevc/pkg-descr4
4 files changed, 56 insertions, 0 deletions
diff --git a/multimedia/gstreamer1-plugins-svt-hevc/Makefile b/multimedia/gstreamer1-plugins-svt-hevc/Makefile
new file mode 100644
index 000000000000..70c154d18d75
--- /dev/null
+++ b/multimedia/gstreamer1-plugins-svt-hevc/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= svt-hevc
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.3.0-32
+DISTVERSIONSUFFIX= -ga0dcd77
+CATEGORIES= multimedia
+PKGNAMEPREFIX= gstreamer1-plugins-
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= GStreamer (svt-hevc) plugin
+
+LICENSE= LGPL21+ # based on SPDX header
+LICENSE_FILE= ${_LICENSE_STORE}/LGPL21
+
+LIB_DEPENDS= libSvtHevcEnc.so:multimedia/svt-hevc
+
+USES= meson pkgconfig
+USE_GITHUB= yes
+USE_GNOME= glib20
+USE_GSTREAMER1= yes
+GH_ACCOUNT= OpenVisualCloud
+GH_PROJECT= SVT-HEVC
+WRKSRC_SUBDIR= gstreamer-plugin
+PLIST_FILES= lib/gstreamer-1.0/libgstsvthevcenc.so
+
+post-patch:
+ @${REINPLACE_CMD} '/-O2/d' ${WRKSRC}/meson.build
+
+.include <bsd.port.mk>
diff --git a/multimedia/gstreamer1-plugins-svt-hevc/distinfo b/multimedia/gstreamer1-plugins-svt-hevc/distinfo
new file mode 100644
index 000000000000..f78a1e5bf2ab
--- /dev/null
+++ b/multimedia/gstreamer1-plugins-svt-hevc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1557301098
+SHA256 (OpenVisualCloud-SVT-HEVC-v1.3.0-32-ga0dcd77_GH0.tar.gz) = cfff9280afd366bea73d093bdfa0a82b700345f09ce486ef7edc0399ab1fab13
+SIZE (OpenVisualCloud-SVT-HEVC-v1.3.0-32-ga0dcd77_GH0.tar.gz) = 1165629
diff --git a/multimedia/gstreamer1-plugins-svt-hevc/files/patch-gstsvthevcenc.c b/multimedia/gstreamer1-plugins-svt-hevc/files/patch-gstsvthevcenc.c
new file mode 100644
index 000000000000..746dad76afd3
--- /dev/null
+++ b/multimedia/gstreamer1-plugins-svt-hevc/files/patch-gstsvthevcenc.c
@@ -0,0 +1,19 @@
+encoderColorFormat was added after 1.3.0, so omit it for now.
+
+../gstsvthevcenc.c:732:15: error: no member named 'encoderColorFormat' in 'struct EB_H265_ENC_CONFIGURATION'
+ svt_config->encoderColorFormat = EB_YUV420;
+ ~~~~~~~~~~ ^
+../gstsvthevcenc.c:732:36: error: use of undeclared identifier 'EB_YUV420'
+ svt_config->encoderColorFormat = EB_YUV420;
+ ^
+
+--- gstsvthevcenc.c.orig 2019-03-27 13:22:12 UTC
++++ gstsvthevcenc.c
+@@ -729,7 +729,6 @@ set_default_svt_configuration (EB_H265_ENC_CONFIGURATI
+ svt_config->recoveryPointSeiFlag = FALSE;
+ svt_config->enableTemporalId = 1;
+ svt_config->encoderBitDepth = 8;
+- svt_config->encoderColorFormat = EB_YUV420;
+ svt_config->compressedTenBitFormat = FALSE;
+ svt_config->profile = 1;
+ svt_config->tier = 0;
diff --git a/multimedia/gstreamer1-plugins-svt-hevc/pkg-descr b/multimedia/gstreamer1-plugins-svt-hevc/pkg-descr
new file mode 100644
index 000000000000..958e23d14859
--- /dev/null
+++ b/multimedia/gstreamer1-plugins-svt-hevc/pkg-descr
@@ -0,0 +1,4 @@
+This plugin provides svtav1enc element to GStreamer in order to use
+the Scalable Video Technology for HEVC Encoder.
+
+WWW: https://01.org/svt