aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-plugins/Makefile.common
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2018-12-25 19:43:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2018-12-25 19:43:19 +0000
commit0e8c2fb42a13577be1316b01877f62f5cc6b8955 (patch)
tree1054ded0a119a36a1ef7a3f860390e930cf6ebf0 /multimedia/gstreamer1-plugins/Makefile.common
parentf0e01a79c2c18d9c47d7f295652e175aa2b319e9 (diff)
downloadports-0e8c2fb42a13577be1316b01877f62f5cc6b8955.tar.gz
ports-0e8c2fb42a13577be1316b01877f62f5cc6b8955.zip
* Add the gstreamer1 lv2 plugin.
This plugins is a wrapper that exposes lv2 plugins to gstreamer applications. * Correct the handling of webrtcdsp in bsd.gstreamer.mk so it can be used in the USE_GSTREAMER1 macro. multimedia/gstreamer1-plugins/Makefile.common: * Remove configure disable switches for sunadio and wgl, these plugins where removed in 1.14. * Move gtk3 from the "bad" plugins to the "good" plugins. This removes a warning from the configure stage of "bad" plugins about unknown configure arguments.
Notes
Notes: svn path=/head/; revision=488337
Diffstat (limited to 'multimedia/gstreamer1-plugins/Makefile.common')
-rw-r--r--multimedia/gstreamer1-plugins/Makefile.common11
1 files changed, 8 insertions, 3 deletions
diff --git a/multimedia/gstreamer1-plugins/Makefile.common b/multimedia/gstreamer1-plugins/Makefile.common
index e082b0954ac7..0a0c9564dfbf 100644
--- a/multimedia/gstreamer1-plugins/Makefile.common
+++ b/multimedia/gstreamer1-plugins/Makefile.common
@@ -34,13 +34,13 @@ BAD_GST_ALL_PLUGINS+= \
flite \
gme \
gsm \
- gtk3 \
hls \
kate \
kms \
ladspa \
libde265 \
libmms \
+ lv2 \
modplug \
mpeg2enc \
mplex \
@@ -91,7 +91,6 @@ BAD_GST_NON_PLUGINS= \
--disable-uvch264 \
--disable-vcd \
--disable-wasapi \
- --disable-wgl \
--disable-winks \
--disable-winscreencap
@@ -101,6 +100,7 @@ GOOD_GST_ALL_PLUGINS+= \
flac \
gdk_pixbuf \
gst_v4l2 \
+ gtk3 \
jack \
jpeg \
lame \
@@ -123,7 +123,6 @@ GOOD_GST_NON_PLUGINS= \
--disable-directsound \
--disable-osx_audio \
--disable-osx_video \
- --disable-sunaudio \
--disable-waveform \
--enable-bz2 \
--enable-oss \
@@ -331,6 +330,12 @@ gst_libmms_PLIST_FILES= ${GST_LIB_DIR}/libgstmms.so
# librfb
gst_librfb_USE_XORG= x11
+# liblv2
+gst_lv2_LIB_DEPENDS= libsord-0.so:devel/sord \
+ libserd-0.so:devel/serd \
+ libsratom-0.so:audio/sratom \
+ liblilv-0.so:audio/lilv
+
# png
gst_libpng_LIB_DEPENDS= libpng.so:graphics/png
gst_libpng_PLIST_FILES= ${GST_LIB_DIR}/libgstpng.so