aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-plugins
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2020-01-26 17:42:36 +0000
committerKoop Mast <kwm@FreeBSD.org>2020-01-26 17:42:36 +0000
commitaa49f23a6db2870118f1c18cdef7eefa026c6693 (patch)
treeac5da30061e167c8d7d0a673f2f595d1fdad88f1 /multimedia/gstreamer1-plugins
parent4b291cffdfc075b11c0aa0c6587d944e9826bd33 (diff)
downloadports-aa49f23a6db2870118f1c18cdef7eefa026c6693.tar.gz
ports-aa49f23a6db2870118f1c18cdef7eefa026c6693.zip
Update gstreamer1 to 1.16.2.
- The spc plugin was removed inflavor for the gsm plugin. - Added in tree qt plugin. Changelog: https://gstreamer.freedesktop.org/releases/1.16/#1.16.2 Update net-im/fractal to 4.2.2 to support GStreamer 1.16 (approved by maintainer) Thanks to antoine@ for the exp-run. PR: 239386
Notes
Notes: svn path=/head/; revision=524224
Diffstat (limited to 'multimedia/gstreamer1-plugins')
-rw-r--r--multimedia/gstreamer1-plugins/Makefile22
-rw-r--r--multimedia/gstreamer1-plugins/Makefile.common21
-rw-r--r--multimedia/gstreamer1-plugins/distinfo18
-rw-r--r--multimedia/gstreamer1-plugins/files/patch-configure109
-rw-r--r--multimedia/gstreamer1-plugins/pkg-plist6
5 files changed, 155 insertions, 21 deletions
diff --git a/multimedia/gstreamer1-plugins/Makefile b/multimedia/gstreamer1-plugins/Makefile
index ed69d0844557..91e7bdbfb7f6 100644
--- a/multimedia/gstreamer1-plugins/Makefile
+++ b/multimedia/gstreamer1-plugins/Makefile
@@ -5,9 +5,11 @@ PORTNAME= gstreamer
PORTVERSION?= ${BASE_PORTVERSION}
# When chasing a shared library for a plug-in bump the PORTREVISION in the
# plug-in port instead, like ${category}/gstreamer1-plugin-${PLUGIN}.
-PORTREVISION?= 2
+PORTREVISION?= 0
CATEGORIES?= multimedia audio
-MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-plugins-base/:base \
+MASTER_SITES= GNOME/sources/gst-plugins-base/${PORTVERSION:R}:base \
+ GNOME/sources/gst-plugins-good/${PORTVERSION:R}:good \
+ http://gstreamer.freedesktop.org/src/gst-plugins-base/:base \
http://gstreamer.freedesktop.org/src/gst-plugins-bad/:bad \
http://gstreamer.freedesktop.org/src/gst-plugins-good/:good \
http://gstreamer.freedesktop.org/src/gst-plugins-ugly/:ugly
@@ -16,6 +18,8 @@ PKGNAMESUFFIX?= 1-plugins${GST_PLUGIN_SUFFIX}
MAINTAINER= multimedia@FreeBSD.org
COMMENT?= GStreamer written collection of plugins handling several media types
+LICENSE= LGPL20
+
BUILD_DEPENDS+= gstreamer1>=${GST1_VERSION}${GST1_MINIMAL_VERSION}:multimedia/gstreamer1 \
iso-codes>=0:misc/iso-codes \
orc>=0.4.16:devel/orc
@@ -26,16 +30,16 @@ RUN_DEPENDS+= iso-codes>=0:misc/iso-codes
PORTSCOUT= limitw:1,even
-BASE_PORTVERSION= 1.14.4
+BASE_PORTVERSION= 1.16.2
BASE_DISTNAME= gst-plugins-base-${BASE_PORTVERSION}
BASE_DISTFILE= ${BASE_DISTNAME}${EXTRACT_SUFX}
-BAD_PORTVERSION= 1.14.4
+BAD_PORTVERSION= 1.16.2
BAD_DISTNAME= gst-plugins-bad-${BAD_PORTVERSION}
BAD_DISTFILE= ${BAD_DISTNAME}${EXTRACT_SUFX}
-GOOD_PORTVERSION= 1.14.4
+GOOD_PORTVERSION= 1.16.2
GOOD_DISTNAME= gst-plugins-good-${GOOD_PORTVERSION}
GOOD_DISTFILE= ${GOOD_DISTNAME}${EXTRACT_SUFX}
-UGLY_PORTVERSION= 1.14.4
+UGLY_PORTVERSION= 1.16.2
UGLY_DISTNAME= gst-plugins-ugly-${UGLY_PORTVERSION}
UGLY_DISTFILE= ${UGLY_DISTNAME}${EXTRACT_SUFX}
DIST?= base
@@ -52,6 +56,8 @@ CFLAGS+= -Wno-format
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -lpthread -L${LOCALBASE}/lib ${EXTRA_LIBS}
+CONFIGURE_ARGS+= --disable-fatal-warnings
+
DEFAULT_AUDIOSINK?= osssink
DEFAULT_AUDIOSRC?= osssrc
@@ -60,7 +66,7 @@ IGNORE= DIST not specified
.endif
VERSION= 1.0
-SOVERSION= 0.1404.0
+SOVERSION= 0.1602.0
PLIST_SUB+= VERSION="${VERSION}" \
SOVERSION="${SOVERSION}"
@@ -150,6 +156,7 @@ post-patch:
s|$$(top_builddir)/gst-libs/gst/adaptivedemux/libgstadaptivedemux-@GST_API_VERSION@.la|-lgstadaptivedemux-${VERSION}|; \
s|$$(top_builddir)/gst-libs/gst/codecparsers/libgstcodecparsers-@GST_API_VERSION@.la|-lgstcodecparsers-${VERSION}|; \
s|$$(top_builddir)/gst-libs/gst/allocators/libgstbadallocators-@GST_API_VERSION@.la|-lgstbadallocators-${VERSION}|; \
+ s|$$(top_builddir)/gst-libs/gst/audio/libgstbadaudio-@GST_API_VERSION@.la|-lgstbadaudio-${VERSION}|; \
s|$$(top_builddir)/gst-libs/gst/video/libgstbadvideo-@GST_API_VERSION@.la|-lgstbadvideo-${VERSION}|'
@${FIND} ${WRKSRC}/ext ${WRKSRC}/sys -name Makefile.in | \
@@ -167,6 +174,7 @@ post-patch:
s|$$(top_builddir)/gst-libs/gst/adaptivedemux/libgstadaptivedemux-@GST_API_VERSION@.la|-lgstadaptivedemux-${VERSION}|; \
s|$$(top_builddir)/gst-libs/gst/codecparsers/libgstcodecparsers-$$(GST_API_VERSION).la|-lgstcodecparsers-${VERSION}|; \
s|$$(top_builddir)/gst-libs/gst/allocators/libgstbadallocators-$$(GST_API_VERSION).la|-lgstbadallocators-${VERSION}|; \
+ s|$$(top_builddir)/gst-libs/gst/audio/libgstbadaudio-$$(GST_API_VERSION).la|-lgstbadaudio-${VERSION}|; \
s|$$(top_builddir)/gst-libs/gst/video/libgstbadvideo-$$(GST_API_VERSION).la|-lgstbadvideo-${VERSION}|'
.endif
diff --git a/multimedia/gstreamer1-plugins/Makefile.common b/multimedia/gstreamer1-plugins/Makefile.common
index bf2053376550..e261842021b9 100644
--- a/multimedia/gstreamer1-plugins/Makefile.common
+++ b/multimedia/gstreamer1-plugins/Makefile.common
@@ -61,7 +61,6 @@ BAD_GST_ALL_PLUGINS+= \
sndfile \
soundtouch \
spandsp \
- spc \
srtp \
ttml \
vdpau \
@@ -87,6 +86,7 @@ BAD_GST_NON_PLUGINS= \
--disable-nvenc \
--disable-nvdec \
--disable-sbc \
+ --disable-spc \
--disable-tinyalsa \
--disable-uvch264 \
--disable-vcd \
@@ -109,6 +109,7 @@ GOOD_GST_ALL_PLUGINS+= \
libpng \
mpg123 \
pulse \
+ qt \
shout2 \
soup \
speex \
@@ -407,6 +408,12 @@ gst_pango_USE_GNOME= cairo pango
gst_pulse_LIB_DEPENDS= libpulse.so:audio/pulseaudio
gst_pulse_PLIST_FILES= ${GST_LIB_DIR}/libgstpulseaudio.so
+# qt
+gst_qt_USES= qt:5
+gst_qt_USE_QT= core gui declarative buildtools_build network x11extras
+gst_qt_USE_GSTREAMER1= gl
+gst_qt_PLIST_FILES= ${GST_LIB_DIR}/libgstqmlgl.so
+
# resindvd
gst_resindvd_BUILD_DEPENDS= libdvdnav>=4.1.2:multimedia/libdvdnav
gst_resindvd_LIB_DEPENDS= libdvdread.so:multimedia/libdvdread
@@ -440,9 +447,6 @@ gst_soup_LIB_DEPENDS= libsoup-2.4.so:devel/libsoup
# spandsp
gst_spandsp_LIB_DEPENDS= libspandsp.so:comms/spandsp
-# spc
-gst_spc_LIB_DEPENDS= libopenspc.so:audio/libopenspc
-
# speex
gst_speex_LIB_DEPENDS= libspeex.so:audio/speex
@@ -484,7 +488,10 @@ gst_vdpau_LIB_DEPENDS= libvdpau.so:multimedia/libvdpau
gst_vdpau_GST_PLUGIN_DIR= sys/vdpau
# vulkan
-gst_vulkan_BUILD_DEPENDS= ${LOCALBASE}/include/vulkan/vulkan.h:devel/vulkan-headers
+gst_vulkan_USE_GSTREAMER1= gl
+gst_vulkan_BUILD_DEPENDS= ${LOCALBASE}/include/vulkan/vulkan.h:devel/vulkan-headers \
+ ${LOCALBASE}/include/linux/input.h:devel/evdev-proto \
+ wayland-protocols>=0:graphics/wayland-protocols
gst_vulkan_LIB_DEPENDS= libvulkan.so:graphics/vulkan-loader \
libwayland-client.so:graphics/wayland
gst_vulkan_CONFIGURE_ARGS= --enable-wayland
@@ -538,6 +545,7 @@ gst_${GST_PLUGIN}_BUILD_DEPENDS?=
gst_${GST_PLUGIN}_LIB_DEPENDS?=
gst_${GST_PLUGIN}_RUN_DEPENDS?=
gst_${GST_PLUGIN}_USES?=
+gst_${GST_PLUGIN}_USE_QT?=
gst_${GST_PLUGIN}_USE_XORG?=
gst_${GST_PLUGIN}_PLIST_FILES?= \
${GST_LIB_DIR}/libgst${GST_PLUGIN}${GST_PLIST_SUFFIX}.so
@@ -566,6 +574,9 @@ USE_XORG+= ${gst_${GST_PLUGIN}_USE_XORG}
.if ${gst_${GST_PLUGIN}_USE_GNOME}!=""
USE_GNOME+= ${gst_${GST_PLUGIN}_USE_GNOME}
.endif
+.if ${gst_${GST_PLUGIN}_USE_QT}!=""
+USE_QT+= ${gst_${GST_PLUGIN}_USE_QT}
+.endif
CONFIGURE_ENV+= ${gst_${GST_PLUGIN}_CONFIGURE_ENV}
.if ${gst_${GST_PLUGIN}_USE_GL}!=""
USE_GL+= ${gst_${GST_PLUGIN}_USE_GL}
diff --git a/multimedia/gstreamer1-plugins/distinfo b/multimedia/gstreamer1-plugins/distinfo
index d37352e73cca..ab0d6d3e0536 100644
--- a/multimedia/gstreamer1-plugins/distinfo
+++ b/multimedia/gstreamer1-plugins/distinfo
@@ -1,9 +1,9 @@
-TIMESTAMP = 1539380228
-SHA256 (gst-plugins-base-1.14.4.tar.xz) = ca6139490e48863e7706d870ff4e8ac9f417b56f3b9e4b3ce490c13b09a77461
-SIZE (gst-plugins-base-1.14.4.tar.xz) = 3703232
-SHA256 (gst-plugins-bad-1.14.4.tar.xz) = 910b4e0e2e897e8b6d06767af1779d70057c309f67292f485ff988d087aa0de5
-SIZE (gst-plugins-bad-1.14.4.tar.xz) = 4678032
-SHA256 (gst-plugins-ugly-1.14.4.tar.xz) = ac02d837f166c35ff6ce0738e281680d0b90052cfb1f0255dcf6aaca5f0f6d23
-SIZE (gst-plugins-ugly-1.14.4.tar.xz) = 889632
-SHA256 (gst-plugins-good-1.14.4.tar.xz) = 5f8b553260cb0aac56890053d8511db1528d53cae10f0287cfce2cb2acc70979
-SIZE (gst-plugins-good-1.14.4.tar.xz) = 3792524
+TIMESTAMP = 1575818122
+SHA256 (gst-plugins-base-1.16.2.tar.xz) = b13e73e2fe74a4166552f9577c3dcb24bed077021b9c7fa600d910ec6987816a
+SIZE (gst-plugins-base-1.16.2.tar.xz) = 3939868
+SHA256 (gst-plugins-bad-1.16.2.tar.xz) = f1cb7aa2389569a5343661aae473f0a940a90b872001824bc47fa8072a041e74
+SIZE (gst-plugins-bad-1.16.2.tar.xz) = 4887812
+SHA256 (gst-plugins-ugly-1.16.2.tar.xz) = 5500415b865e8b62775d4742cbb9f37146a50caecfc0e7a6fc0160d3c560fbca
+SIZE (gst-plugins-ugly-1.16.2.tar.xz) = 893964
+SHA256 (gst-plugins-good-1.16.2.tar.xz) = 40bb3bafda25c0b739c8fc36e48380fccf61c4d3f83747e97ac3f9b0171b1319
+SIZE (gst-plugins-good-1.16.2.tar.xz) = 3897172
diff --git a/multimedia/gstreamer1-plugins/files/patch-configure b/multimedia/gstreamer1-plugins/files/patch-configure
new file mode 100644
index 000000000000..7250970c26b6
--- /dev/null
+++ b/multimedia/gstreamer1-plugins/files/patch-configure
@@ -0,0 +1,109 @@
+--- configure.orig 2019-03-02 18:59:35.242374000 +0100
++++ configure 2019-03-02 19:00:32.651461000 +0100
+@@ -33987,54 +33987,9 @@
+ _ACEOF
+
+ fi
+- if test "x$FOUND_CDPARANOIA" = "xyes";
+- then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for paranoia_cachemodel_size in -lcdda_paranoia" >&5
+-$as_echo_n "checking for paranoia_cachemodel_size in -lcdda_paranoia... " >&6; }
+-if ${ac_cv_lib_cdda_paranoia_paranoia_cachemodel_size+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lcdda_paranoia -lcdda_interface $LIBS"
+-cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+-/* end confdefs.h. */
+
+-/* Override any GCC internal prototype to avoid an error.
+- Use char because int might match the return type of a GCC
+- builtin and then its argument prototype would still apply. */
+-#ifdef __cplusplus
+-extern "C"
+-#endif
+-char paranoia_cachemodel_size ();
+-int
+-main ()
+-{
+-return paranoia_cachemodel_size ();
+- ;
+- return 0;
+-}
+-_ACEOF
+-if ac_fn_c_try_link "$LINENO"; then :
+- ac_cv_lib_cdda_paranoia_paranoia_cachemodel_size=yes
+-else
+- ac_cv_lib_cdda_paranoia_paranoia_cachemodel_size=no
+-fi
+-rm -f core conftest.err conftest.$ac_objext \
+- conftest$ac_exeext conftest.$ac_ext
+-LIBS=$ac_check_lib_save_LIBS
+-fi
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_cdda_paranoia_paranoia_cachemodel_size" >&5
+-$as_echo "$ac_cv_lib_cdda_paranoia_paranoia_cachemodel_size" >&6; }
+-if test "x$ac_cv_lib_cdda_paranoia_paranoia_cachemodel_size" = xyes; then :
+- :
+-else
+- HAVE_CDPARANOIA=no
+-fi
+
+- fi
+
+-
+-
+ elif test $pkg_failed = untried; then
+
+
+@@ -34176,51 +34131,6 @@
+ cat >>confdefs.h <<_ACEOF
+ #define CDPARANOIA_HEADERS_IN_DIR /**/
+ _ACEOF
+-
+- fi
+- if test "x$FOUND_CDPARANOIA" = "xyes";
+- then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for paranoia_cachemodel_size in -lcdda_paranoia" >&5
+-$as_echo_n "checking for paranoia_cachemodel_size in -lcdda_paranoia... " >&6; }
+-if ${ac_cv_lib_cdda_paranoia_paranoia_cachemodel_size+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lcdda_paranoia -lcdda_interface $LIBS"
+-cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+-/* end confdefs.h. */
+-
+-/* Override any GCC internal prototype to avoid an error.
+- Use char because int might match the return type of a GCC
+- builtin and then its argument prototype would still apply. */
+-#ifdef __cplusplus
+-extern "C"
+-#endif
+-char paranoia_cachemodel_size ();
+-int
+-main ()
+-{
+-return paranoia_cachemodel_size ();
+- ;
+- return 0;
+-}
+-_ACEOF
+-if ac_fn_c_try_link "$LINENO"; then :
+- ac_cv_lib_cdda_paranoia_paranoia_cachemodel_size=yes
+-else
+- ac_cv_lib_cdda_paranoia_paranoia_cachemodel_size=no
+-fi
+-rm -f core conftest.err conftest.$ac_objext \
+- conftest$ac_exeext conftest.$ac_ext
+-LIBS=$ac_check_lib_save_LIBS
+-fi
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_cdda_paranoia_paranoia_cachemodel_size" >&5
+-$as_echo "$ac_cv_lib_cdda_paranoia_paranoia_cachemodel_size" >&6; }
+-if test "x$ac_cv_lib_cdda_paranoia_paranoia_cachemodel_size" = xyes; then :
+- :
+-else
+- HAVE_CDPARANOIA=no
+-fi
+
+ fi
+
diff --git a/multimedia/gstreamer1-plugins/pkg-plist b/multimedia/gstreamer1-plugins/pkg-plist
index ce4eae9cbdaf..adc1c77c5f39 100644
--- a/multimedia/gstreamer1-plugins/pkg-plist
+++ b/multimedia/gstreamer1-plugins/pkg-plist
@@ -11,6 +11,7 @@ include/gstreamer-%%VERSION%%/gst/app/app-prelude.h
include/gstreamer-%%VERSION%%/gst/app/app.h
include/gstreamer-%%VERSION%%/gst/app/gstappsink.h
include/gstreamer-%%VERSION%%/gst/app/gstappsrc.h
+include/gstreamer-%%VERSION%%/gst/audio/audio-buffer.h
include/gstreamer-%%VERSION%%/gst/audio/audio-channel-mixer.h
include/gstreamer-%%VERSION%%/gst/audio/audio-channels.h
include/gstreamer-%%VERSION%%/gst/audio/audio-converter.h
@@ -68,6 +69,7 @@ include/gstreamer-%%VERSION%%/gst/rtp/gstrtpbasepayload.h
include/gstreamer-%%VERSION%%/gst/rtp/gstrtpbuffer.h
include/gstreamer-%%VERSION%%/gst/rtp/gstrtpdefs.h
include/gstreamer-%%VERSION%%/gst/rtp/gstrtphdrext.h
+include/gstreamer-%%VERSION%%/gst/rtp/gstrtpmeta.h
include/gstreamer-%%VERSION%%/gst/rtp/gstrtppayloads.h
include/gstreamer-%%VERSION%%/gst/rtp/rtp-prelude.h
include/gstreamer-%%VERSION%%/gst/rtp/rtp.h
@@ -96,6 +98,7 @@ include/gstreamer-%%VERSION%%/gst/tag/xmpwriter.h
include/gstreamer-%%VERSION%%/gst/video/colorbalance.h
include/gstreamer-%%VERSION%%/gst/video/colorbalancechannel.h
include/gstreamer-%%VERSION%%/gst/video/gstvideoaffinetransformationmeta.h
+include/gstreamer-%%VERSION%%/gst/video/gstvideoaggregator.h
include/gstreamer-%%VERSION%%/gst/video/gstvideodecoder.h
include/gstreamer-%%VERSION%%/gst/video/gstvideoencoder.h
include/gstreamer-%%VERSION%%/gst/video/gstvideofilter.h
@@ -105,6 +108,7 @@ include/gstreamer-%%VERSION%%/gst/video/gstvideosink.h
include/gstreamer-%%VERSION%%/gst/video/gstvideotimecode.h
include/gstreamer-%%VERSION%%/gst/video/gstvideoutils.h
include/gstreamer-%%VERSION%%/gst/video/navigation.h
+include/gstreamer-%%VERSION%%/gst/video/video-anc.h
include/gstreamer-%%VERSION%%/gst/video/video-blend.h
include/gstreamer-%%VERSION%%/gst/video/video-chroma.h
include/gstreamer-%%VERSION%%/gst/video/video-color.h
@@ -141,8 +145,10 @@ lib/gstreamer-%%VERSION%%/libgstaudiomixer.so
lib/gstreamer-%%VERSION%%/libgstaudiorate.so
lib/gstreamer-%%VERSION%%/libgstaudioresample.so
lib/gstreamer-%%VERSION%%/libgstaudiotestsrc.so
+lib/gstreamer-%%VERSION%%/libgstcompositor.so
lib/gstreamer-%%VERSION%%/libgstencoding.so
lib/gstreamer-%%VERSION%%/libgstgio.so
+lib/gstreamer-%%VERSION%%/libgstoverlaycomposition.so
lib/gstreamer-%%VERSION%%/libgstpbtypes.so
lib/gstreamer-%%VERSION%%/libgstplayback.so
lib/gstreamer-%%VERSION%%/libgstrawparse.so