aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-qt
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-12-16 16:49:17 +0000
committerRene Ladan <rene@FreeBSD.org>2018-12-16 16:49:17 +0000
commit7cbe341ae63754f2ad63dd52f20d9d1b9b312aa5 (patch)
tree892baa84cc0c67b08795b6576e985d83e5a8f6d1 /multimedia/gstreamer1-qt
parent278e6c95a6bbd77f475d8bd167ba51814bb09fc0 (diff)
downloadports-7cbe341ae63754f2ad63dd52f20d9d1b9b312aa5.tar.gz
ports-7cbe341ae63754f2ad63dd52f20d9d1b9b312aa5.zip
Use regular DEPRECATED and EXPIRATION_DATE variables in an "if FLAVOR" block
instead of flavoring the variables themselves. This caused too much hassle for Tools/scripts/rmport. Discussed with: tcberner
Notes
Notes: svn path=/head/; revision=487601
Diffstat (limited to 'multimedia/gstreamer1-qt')
-rw-r--r--multimedia/gstreamer1-qt/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/multimedia/gstreamer1-qt/Makefile b/multimedia/gstreamer1-qt/Makefile
index bced1289990a..71f266e48435 100644
--- a/multimedia/gstreamer1-qt/Makefile
+++ b/multimedia/gstreamer1-qt/Makefile
@@ -17,9 +17,6 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
FLAVORS= qt5 qt4
FLAVOR?= ${FLAVORS:[1]}
-qt4_DEPRECATED= Qt4 has been EOL since december 2015
-qt4_EXPIRATION_DATE= 2019-03-15
-
CONFLICTS_INSTALL= gstreamer${PKGNAMESUFFIX}-*
USES= bison cmake:outsource gl gnome pathfix pkgconfig tar:xz
@@ -33,6 +30,8 @@ CMAKE_OFF= USE_GST_PLUGIN_DIR USE_QT_PLUGIN_DIR
CMAKE_ARGS= -DQT_VERSION=${FLAVOR:C/qt//}
. if ${FLAVOR} == qt4
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE=2019-03-15
USES+= qt:4
USE_QT= corelib gui opengl declarative script \
qmake_build moc_build rcc_build uic_build qtestlib_build