aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-qt
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-14 14:02:49 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-14 14:02:49 +0000
commit976792c819d34d74b18a720774f1e87981c39803 (patch)
tree49864b395b5f716c52722252a97eaf67cd649744 /multimedia/gstreamer1-qt
parent0c47b518053fdb82f380f68da7f4295a0de75ba8 (diff)
downloadports-976792c819d34d74b18a720774f1e87981c39803.tar.gz
ports-976792c819d34d74b18a720774f1e87981c39803.zip
multimedia/gstreamer1-qt4, multimedia/gstreamer1-qt5: create flavors
Approved by: portmgr (mat) Differential Revision: https://reviews.freebsd.org/D14641
Notes
Notes: svn path=/head/; revision=467319
Diffstat (limited to 'multimedia/gstreamer1-qt')
-rw-r--r--multimedia/gstreamer1-qt/Makefile46
-rw-r--r--multimedia/gstreamer1-qt/distinfo2
-rw-r--r--multimedia/gstreamer1-qt/files/patch-git_1d2edcc935
-rw-r--r--multimedia/gstreamer1-qt/files/patch-git_fc159e5c463
-rw-r--r--multimedia/gstreamer1-qt/pkg-descr5
-rw-r--r--multimedia/gstreamer1-qt/pkg-plist148
6 files changed, 299 insertions, 0 deletions
diff --git a/multimedia/gstreamer1-qt/Makefile b/multimedia/gstreamer1-qt/Makefile
new file mode 100644
index 000000000000..28e3cd005cc3
--- /dev/null
+++ b/multimedia/gstreamer1-qt/Makefile
@@ -0,0 +1,46 @@
+# $FreeBSD$
+
+PORTNAME= gstreamer1
+PORTVERSION= 1.2.0
+PORTREVISION= 10
+CATEGORIES= multimedia
+MASTER_SITES= http://gstreamer.freedesktop.org/src/qt-gstreamer/
+PKGNAMESUFFIX= -${FLAVOR}
+DISTNAME= qt-gstreamer-${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt ${FLAVOR:C/qt//} bindings for GStreamer 1.x multimedia library
+
+LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
+ libgstreamer-1.0.so:multimedia/gstreamer1
+
+FLAVORS= qt4 qt5
+FLAVOR?= ${FLAVORS:[1]}
+
+CONFLICTS_INSTALL= gstreamer${PKGNAMESUFFIX}-*
+
+USES= bison cmake:outsource pathfix pkgconfig tar:xz
+USE_GSTREAMER1= yes
+
+USE_GL= gl
+USE_GNOME= glib20
+
+USE_LDCONFIG= yes
+CMAKE_OFF= USE_GST_PLUGIN_DIR USE_QT_PLUGIN_DIR
+CMAKE_ARGS= -DQT_VERSION=${FLAVOR:C/qt//}
+
+. if ${FLAVOR} == qt4
+USE_QT4= corelib gui opengl declarative script \
+ qmake_build moc_build rcc_build uic_build qtestlib_build
+PLIST_SUB= QT4_ONLY="" QT5_ONLY="@comment "
+. else
+USE_QT5= buildtools_build qmake_build core gui network opengl \
+ qml quick testlib widgets
+QTVER_SUFFIX= 5
+PLIST_SUB= QT4_ONLY="@comment " QT5_ONLY=""
+. endif
+
+PLIST_SUB+= SHLIB_VER="${PORTVERSION}" \
+ QTVER_SUFFIX="${QTVER_SUFFIX}"
+
+.include <bsd.port.mk>
diff --git a/multimedia/gstreamer1-qt/distinfo b/multimedia/gstreamer1-qt/distinfo
new file mode 100644
index 000000000000..46f8570742a2
--- /dev/null
+++ b/multimedia/gstreamer1-qt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (qt-gstreamer-1.2.0.tar.xz) = 9f3b492b74cad9be918e4c4db96df48dab9c012f2ae5667f438b64a4d92e8fd4
+SIZE (qt-gstreamer-1.2.0.tar.xz) = 313632
diff --git a/multimedia/gstreamer1-qt/files/patch-git_1d2edcc9 b/multimedia/gstreamer1-qt/files/patch-git_1d2edcc9
new file mode 100644
index 000000000000..079d20e770a3
--- /dev/null
+++ b/multimedia/gstreamer1-qt/files/patch-git_1d2edcc9
@@ -0,0 +1,35 @@
+From e2ca8094aa8d0eac1c3a98df66fe94ce0c754088 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jos=C3=A9=20Manuel=20Santamar=C3=ADa?= <panfaust@gmail.com>
+Date: Fri, 2 Oct 2015 15:00:29 +0300
+Subject: Fix compilation with GStreamer >= 1.5.1
+
+apply gstreamer pkg-config definitions To ensure gstreamer builds correctly,
+pick up its cflags in FindGstreamer and apply them to the build as definitions
+
+https://lists.ubuntu.com/archives/kubuntu-devel/2015-August/009819.html
+
+https://bugzilla.gnome.org/show_bug.cgi?id=751382
+
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -106,6 +106,7 @@ find_package(GObject)
+ macro_log_feature(GOBJECT_FOUND "GObject" "Required to build QtGLib" "http://www.gtk.org/" TRUE)
+
+ set(CMAKE_REQUIRED_INCLUDES ${QTGSTREAMER_INCLUDES})
++add_definitions(${GSTREAMER_DEFINITIONS})
+ include(CheckCXXSourceCompiles)
+ check_cxx_source_compiles("
+ #include <QtCore/QtGlobal>
+--- cmake/modules/FindGStreamer.cmake
++++ cmake/modules/FindGStreamer.cmake
+@@ -36,6 +36,7 @@ if (PKG_CONFIG_FOUND)
+ exec_program(${PKG_CONFIG_EXECUTABLE}
+ ARGS --variable pluginsdir gstreamer-${GSTREAMER_ABI_VERSION}
+ OUTPUT_VARIABLE PKG_GSTREAMER_PLUGIN_DIR)
++ set(GSTREAMER_DEFINITIONS ${PKG_GSTREAMER_CFLAGS})
+ endif()
+
+ find_library(GSTREAMER_LIBRARY
+--
+cgit v0.10.2
+
diff --git a/multimedia/gstreamer1-qt/files/patch-git_fc159e5c4 b/multimedia/gstreamer1-qt/files/patch-git_fc159e5c4
new file mode 100644
index 000000000000..a1f6b9a60fdb
--- /dev/null
+++ b/multimedia/gstreamer1-qt/files/patch-git_fc159e5c4
@@ -0,0 +1,63 @@
+From fc159e5c4c8ffeabdc7319514c6bb19c9c9e1d3b Mon Sep 17 00:00:00 2001
+From: Aleix Pol <aleixpol@kde.org>
+Date: Mon, 13 Jun 2016 10:36:34 +0200
+Subject: Fix build with Clang 3.8
+
+error: invalid suffix on literal; C++11 requires a space between literal and identifier
+
+https://bugzilla.gnome.org/show_bug.cgi?id=767578
+
+diff --git elements/gstqtvideosink/delegates/basedelegate.cpp elements/gstqtvideosink/delegates/basedelegate.cpp
+index 7dde59c..65f364c 100644
+--- elements/gstqtvideosink/delegates/basedelegate.cpp
++++ elements/gstqtvideosink/delegates/basedelegate.cpp
+@@ -155,7 +155,7 @@ bool BaseDelegate::event(QEvent *event)
+ BufferEvent *bufEvent = dynamic_cast<BufferEvent*>(event);
+ Q_ASSERT(bufEvent);
+
+- GST_TRACE_OBJECT(m_sink, "Received buffer %"GST_PTR_FORMAT, bufEvent->buffer);
++ GST_TRACE_OBJECT(m_sink, "Received buffer %" GST_PTR_FORMAT, bufEvent->buffer);
+
+ if (isActive()) {
+ gst_buffer_replace (&m_buffer, bufEvent->buffer);
+diff --git elements/gstqtvideosink/delegates/qwidgetvideosinkdelegate.cpp elements/gstqtvideosink/delegates/qwidgetvideosinkdelegate.cpp
+index 8f23dc2..c42513f 100644
+--- elements/gstqtvideosink/delegates/qwidgetvideosinkdelegate.cpp
++++ elements/gstqtvideosink/delegates/qwidgetvideosinkdelegate.cpp
+@@ -36,7 +36,7 @@ QWidget *QWidgetVideoSinkDelegate::widget() const
+
+ void QWidgetVideoSinkDelegate::setWidget(QWidget *widget)
+ {
+- GST_LOG_OBJECT(m_sink, "Setting \"widget\" property to %"GST_PTR_FORMAT, widget);
++ GST_LOG_OBJECT(m_sink, "Setting \"widget\" property to %" GST_PTR_FORMAT, widget);
+
+ if (m_widget) {
+ m_widget.data()->removeEventFilter(this);
+diff --git elements/gstqtvideosink/gstqtquick2videosink.cpp elements/gstqtvideosink/gstqtquick2videosink.cpp
+index 7889fbf..bedc074 100644
+--- elements/gstqtvideosink/gstqtquick2videosink.cpp
++++ elements/gstqtvideosink/gstqtquick2videosink.cpp
+@@ -248,7 +248,7 @@ gst_qt_quick2_video_sink_show_frame(GstVideoSink *sink, GstBuffer *buffer)
+ {
+ GstQtQuick2VideoSink *self = GST_QT_QUICK2_VIDEO_SINK (sink);
+
+- GST_TRACE_OBJECT(self, "Posting new buffer (%"GST_PTR_FORMAT") for rendering.", buffer);
++ GST_TRACE_OBJECT(self, "Posting new buffer (%" GST_PTR_FORMAT ") for rendering.", buffer);
+
+ QCoreApplication::postEvent(self->priv->delegate, new BaseDelegate::BufferEvent(buffer));
+
+diff --git elements/gstqtvideosink/gstqtvideosinkbase.cpp elements/gstqtvideosink/gstqtvideosinkbase.cpp
+index 118d0a2..a707e02 100644
+--- elements/gstqtvideosink/gstqtvideosinkbase.cpp
++++ elements/gstqtvideosink/gstqtvideosinkbase.cpp
+@@ -207,7 +207,7 @@ GstFlowReturn GstQtVideoSinkBase::show_frame(GstVideoSink *video_sink, GstBuffer
+ {
+ GstQtVideoSinkBase *sink = GST_QT_VIDEO_SINK_BASE(video_sink);
+
+- GST_TRACE_OBJECT(sink, "Posting new buffer (%"GST_PTR_FORMAT") for rendering.", buffer);
++ GST_TRACE_OBJECT(sink, "Posting new buffer (%" GST_PTR_FORMAT ") for rendering.", buffer);
+
+ QCoreApplication::postEvent(sink->delegate, new BaseDelegate::BufferEvent(buffer));
+
+--
+cgit v0.10.2
diff --git a/multimedia/gstreamer1-qt/pkg-descr b/multimedia/gstreamer1-qt/pkg-descr
new file mode 100644
index 000000000000..915674259660
--- /dev/null
+++ b/multimedia/gstreamer1-qt/pkg-descr
@@ -0,0 +1,5 @@
+QtGStreamer is a set of libraries providing C++ bindings for GStreamer
+with a Qt-style API, plus some helper classes and elements for
+integrating GStreamer better in Qt applications.
+
+WWW: http://gstreamer.freedesktop.org/
diff --git a/multimedia/gstreamer1-qt/pkg-plist b/multimedia/gstreamer1-qt/pkg-plist
new file mode 100644
index 000000000000..358422e485e6
--- /dev/null
+++ b/multimedia/gstreamer1-qt/pkg-plist
@@ -0,0 +1,148 @@
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/Connect
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/Error
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/Global
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/Init
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/Object
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/ParamSpec
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/Quark
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/RefPointer
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/Signal
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/Type
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/Value
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/connect.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/connectimpl.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/emitimpl.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/error.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/global.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/init.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/object.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/paramspec.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/qglib_signal.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/quark.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/refpointer.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/type.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/value.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/wrap.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Allocator
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Bin
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Buffer
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/BufferList
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Bus
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Caps
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/ChildProxy
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Clock
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/ClockTime
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/ColorBalance
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Discoverer
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/DoubleRange
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Element
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/ElementFactory
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Event
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Fourcc
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Fraction
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/FractionRange
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/GhostPad
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Global
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Init
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Int64Range
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/IntRange
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Memory
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Message
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/MiniObject
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Object
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Pad
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Parse
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Pipeline
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/PluginFeature
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Query
+%%QT5_ONLY%%include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Quick/VideoItem
+%%QT5_ONLY%%include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Quick/VideoSurface
+%%QT5_ONLY%%include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Quick/global.h
+%%QT5_ONLY%%include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Quick/videoitem.h
+%%QT5_ONLY%%include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Quick/videosurface.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Sample
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Segment
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/StreamVolume
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Structure
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/TagList
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Ui/GraphicsVideoSurface
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Ui/GraphicsVideoWidget
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Ui/VideoWidget
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Ui/global.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Ui/graphicsvideosurface.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Ui/graphicsvideowidget.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Ui/videowidget.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/UriHandler
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Utils/ApplicationSink
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Utils/ApplicationSource
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Utils/applicationsink.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Utils/applicationsource.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Utils/global.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/VideoOrientation
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/VideoOverlay
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/allocator.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/bin.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/buffer.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/bufferlist.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/bus.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/caps.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/childproxy.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/clock.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/clocktime.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/colorbalance.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/discoverer.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/element.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/elementfactory.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/enums.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/event.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/ghostpad.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/global.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/init.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/memory.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/message.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/miniobject.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/object.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/pad.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/parse.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/pipeline.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/pluginfeature.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/query.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/sample.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/segment.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/streamvolume.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/structs.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/structure.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/taglist.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/urihandler.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/videoorientation.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/videooverlay.h
+lib/cmake/Qt%%QTVER_SUFFIX%%GStreamer/Qt%%QTVER_SUFFIX%%GStreamerConfig.cmake
+lib/cmake/Qt%%QTVER_SUFFIX%%GStreamer/QtGStreamerConfigCommon.cmake
+lib/cmake/Qt%%QTVER_SUFFIX%%GStreamer/Qt%%QTVER_SUFFIX%%GStreamerConfigVersion.cmake
+lib/cmake/Qt%%QTVER_SUFFIX%%GStreamer/Qt%%QTVER_SUFFIX%%GStreamerTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Qt%%QTVER_SUFFIX%%GStreamer/Qt%%QTVER_SUFFIX%%GStreamerTargets.cmake
+lib/gstreamer-1.0/libgstqt%%QTVER_SUFFIX%%videosink.so
+lib/libQt%%QTVER_SUFFIX%%GLib-2.0.so
+lib/libQt%%QTVER_SUFFIX%%GLib-2.0.so.0
+lib/libQt%%QTVER_SUFFIX%%GLib-2.0.so.%%SHLIB_VER%%
+lib/libQt%%QTVER_SUFFIX%%GStreamer-1.0.so
+lib/libQt%%QTVER_SUFFIX%%GStreamer-1.0.so.0
+lib/libQt%%QTVER_SUFFIX%%GStreamer-1.0.so.%%SHLIB_VER%%
+lib/libQt%%QTVER_SUFFIX%%GStreamerUi-1.0.so
+lib/libQt%%QTVER_SUFFIX%%GStreamerUi-1.0.so.0
+lib/libQt%%QTVER_SUFFIX%%GStreamerUi-1.0.so.%%SHLIB_VER%%
+lib/libQt%%QTVER_SUFFIX%%GStreamerUtils-1.0.so
+lib/libQt%%QTVER_SUFFIX%%GStreamerUtils-1.0.so.0
+lib/libQt%%QTVER_SUFFIX%%GStreamerUtils-1.0.so.%%SHLIB_VER%%
+%%QT5_ONLY%%lib/libQt%%QTVER_SUFFIX%%GStreamerQuick-1.0.so
+%%QT5_ONLY%%lib/libQt%%QTVER_SUFFIX%%GStreamerQuick-1.0.so.0
+%%QT5_ONLY%%lib/libQt%%QTVER_SUFFIX%%GStreamerQuick-1.0.so.%%SHLIB_VER%%
+%%QT4_ONLY%%%%QT_IMPORTDIR%%/Qt%%QTVER_SUFFIX%%GStreamer/libQtGStreamerQuick1.so
+%%QT4_ONLY%%%%QT_IMPORTDIR%%/Qt%%QTVER_SUFFIX%%GStreamer/qmldir
+%%QT5_ONLY%%%%QT_QMLDIR%%/QtGStreamer/libQtGStreamerQuick2.so
+%%QT5_ONLY%%%%QT_QMLDIR%%/QtGStreamer/qmldir
+libdata/pkgconfig/Qt%%QTVER_SUFFIX%%GLib-2.0.pc
+libdata/pkgconfig/Qt%%QTVER_SUFFIX%%GStreamer-1.0.pc
+libdata/pkgconfig/Qt%%QTVER_SUFFIX%%GStreamerUi-1.0.pc
+libdata/pkgconfig/Qt%%QTVER_SUFFIX%%GStreamerUtils-1.0.pc
+%%QT5_ONLY%%libdata/pkgconfig/Qt%%QTVER_SUFFIX%%GStreamerQuick-1.0.pc