aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-qt
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2020-01-26 17:42:36 +0000
committerKoop Mast <kwm@FreeBSD.org>2020-01-26 17:42:36 +0000
commitaa49f23a6db2870118f1c18cdef7eefa026c6693 (patch)
treeac5da30061e167c8d7d0a673f2f595d1fdad88f1 /multimedia/gstreamer1-qt
parent4b291cffdfc075b11c0aa0c6587d944e9826bd33 (diff)
downloadports-aa49f23a6db2870118f1c18cdef7eefa026c6693.tar.gz
ports-aa49f23a6db2870118f1c18cdef7eefa026c6693.zip
Update gstreamer1 to 1.16.2.
- The spc plugin was removed inflavor for the gsm plugin. - Added in tree qt plugin. Changelog: https://gstreamer.freedesktop.org/releases/1.16/#1.16.2 Update net-im/fractal to 4.2.2 to support GStreamer 1.16 (approved by maintainer) Thanks to antoine@ for the exp-run. PR: 239386
Notes
Notes: svn path=/head/; revision=524224
Diffstat (limited to 'multimedia/gstreamer1-qt')
-rw-r--r--multimedia/gstreamer1-qt/Makefile2
-rw-r--r--multimedia/gstreamer1-qt/files/patch-src_QGst_caps.cpp19
2 files changed, 20 insertions, 1 deletions
diff --git a/multimedia/gstreamer1-qt/Makefile b/multimedia/gstreamer1-qt/Makefile
index 950ecbab27c4..34a4bf13fb0f 100644
--- a/multimedia/gstreamer1-qt/Makefile
+++ b/multimedia/gstreamer1-qt/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gstreamer1
PORTVERSION= 1.2.0
-PORTREVISION= 23
+PORTREVISION= 24
CATEGORIES= multimedia
MASTER_SITES= http://gstreamer.freedesktop.org/src/qt-gstreamer/
PKGNAMESUFFIX= -qt5
diff --git a/multimedia/gstreamer1-qt/files/patch-src_QGst_caps.cpp b/multimedia/gstreamer1-qt/files/patch-src_QGst_caps.cpp
new file mode 100644
index 000000000000..ba20366a9b4a
--- /dev/null
+++ b/multimedia/gstreamer1-qt/files/patch-src_QGst_caps.cpp
@@ -0,0 +1,19 @@
+The GStreamer headers #define a version of gst_caps_copy() with the
+internal implementation. This prevents the normal C++ type conversion
+that would happen when the gst_caps_copy() function is called normally.
+Explicitly get the inner pointer (*caps2 doesn't work) to match
+the implementation API that is now exposed by the #define.
+
+This patch is needed for GStreamer 1.16+
+
+--- src/QGst/caps.cpp.orig 2014-07-08 18:38:36 UTC
++++ src/QGst/caps.cpp
+@@ -54,7 +54,7 @@ QString Caps::toString() const
+
+ void Caps::append(const CapsPtr & caps2)
+ {
+- gst_caps_append(object<GstCaps>(), gst_caps_copy(caps2));
++ gst_caps_append(object<GstCaps>(), gst_caps_copy(caps2.operator->()));
+ }
+
+ CapsPtr Caps::merge(CapsPtr & caps2)