aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-vaapi
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2017-07-22 11:35:44 +0000
committerKoop Mast <kwm@FreeBSD.org>2017-07-22 11:35:44 +0000
commitd566d54fa6c982cb4bed8330d51cb11bfe3674ed (patch)
treedb8ae1482499741d4dbb123637dac45579f28eb5 /multimedia/gstreamer1-vaapi
parent190ced69a285efe9780eea205067282568a3063f (diff)
downloadports-d566d54fa6c982cb4bed8330d51cb11bfe3674ed.tar.gz
ports-d566d54fa6c982cb4bed8330d51cb11bfe3674ed.zip
Update GStreamer1 ports to 1.12.2.
Rework the adding of dependancies in Mk/bsd.gstreamer.mk. Previous when using USE_GSTREAMER[1] it would just add the request modules to BUILD/RUN_DEPENDS. This caused the qa script to complain because the old code didn't implicit depend on the gstreamer1 and gstreamer1-plugins[-bad] ports for the libraries they carried, even if they where present via the plugins! The new code adds implicit depends on these ports so USE_GSTREAMER[1] using ports have all the libraries included. * The mad mp3 plugin was removed, mpg123 plugin also provides mp3 decoding. Switch over ports that used the gstreamer1 mad plugin. * gtksink plugin renamed -> gtk * Hook up the sndio plugin into the framework * Add some indirect dependacies where needed * Reorder the plugin list in bsd.gstreamer.mk so only one plugin per line. When changing plugins it doesn't result in multiple lines being changed. * Remove mentions in bsd.gstreamer.mk of plugins mentions that where removed. * Depend on libunwind on i386/amd64, GStreamer links to it if it is present. PR: 220753 Exp-run by: antoine@
Notes
Notes: svn path=/head/; revision=446388
Diffstat (limited to 'multimedia/gstreamer1-vaapi')
-rw-r--r--multimedia/gstreamer1-vaapi/Makefile7
-rw-r--r--multimedia/gstreamer1-vaapi/distinfo5
-rw-r--r--multimedia/gstreamer1-vaapi/pkg-plist13
3 files changed, 19 insertions, 6 deletions
diff --git a/multimedia/gstreamer1-vaapi/Makefile b/multimedia/gstreamer1-vaapi/Makefile
index a9ae6492ff20..c08f6a5827a5 100644
--- a/multimedia/gstreamer1-vaapi/Makefile
+++ b/multimedia/gstreamer1-vaapi/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gstreamer1-vaapi
-PORTVERSION= 1.8.0
-PORTREVISION= 3
+PORTVERSION= 1.12.2
CATEGORIES= multimedia
MASTER_SITES= https://gstreamer.freedesktop.org/src/gstreamer-vaapi/
DISTNAME= gstreamer-vaapi-${PORTVERSION}
@@ -18,8 +17,10 @@ LIB_DEPENDS= libva.so:multimedia/libva
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-wayland
INSTALL_TARGET= install-strip
-USES= compiler:c11 gmake libtool pkgconfig tar:xz
+USES= compiler:c11 gettext-runtime gmake gnome libtool \
+ pkgconfig tar:xz
USE_LDCONFIG= yes
+USE_GNOME= glib20
USE_GSTREAMER1= bad gl
USE_GL= gl
USE_XORG= x11 xrandr xrender xproto:build
diff --git a/multimedia/gstreamer1-vaapi/distinfo b/multimedia/gstreamer1-vaapi/distinfo
index 31bc554436c2..87fcd923e0dc 100644
--- a/multimedia/gstreamer1-vaapi/distinfo
+++ b/multimedia/gstreamer1-vaapi/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gstreamer-vaapi-1.8.0.tar.xz) = 3b83d405f4423ab0bdc8fbe25e72c4c37b59b7776da21f1d49b0444957595ac1
-SIZE (gstreamer-vaapi-1.8.0.tar.xz) = 944056
+TIMESTAMP = 1500051743
+SHA256 (gstreamer-vaapi-1.12.2.tar.xz) = 23c714e0474b3c7ae6ff8884aebf8503a1bc3ded335fa2d2b2ac31788466163a
+SIZE (gstreamer-vaapi-1.12.2.tar.xz) = 994508
diff --git a/multimedia/gstreamer1-vaapi/pkg-plist b/multimedia/gstreamer1-vaapi/pkg-plist
index 5bb820369560..7eef5458a3c1 100644
--- a/multimedia/gstreamer1-vaapi/pkg-plist
+++ b/multimedia/gstreamer1-vaapi/pkg-plist
@@ -2,17 +2,28 @@ lib/gstreamer-1.0/libgstvaapi.so
share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/api-index-full.html
share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/ch01.html
share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/ch02.html
+share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/ch03.html
share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-1.0.devhelp2
share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-plugin-vaapi.html
-share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapidecode.html
share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapidecodebin.html
+share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapih263dec.html
+share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapih264dec.html
share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapih264enc.html
+share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapih265dec.html
share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapih265enc.html
+share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapijpegdec.html
share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapijpegenc.html
+share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapimpeg2dec.html
share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapimpeg2enc.html
+share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapimpeg4dec.html
share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapipostproc.html
share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapisink.html
+share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapivc1dec.html
+share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapivp8dec.html
share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapivp8enc.html
+share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapivp9dec.html
+share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-plugins-vaapivp9enc.html
+share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/gstreamer-vaapi-running.html
share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/home.png
share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/index.html
share/gtk-doc/html/gstreamer-vaapi-plugins-1.0/left-insensitive.png