aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-validate
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2017-07-22 11:35:44 +0000
committerKoop Mast <kwm@FreeBSD.org>2017-07-22 11:35:44 +0000
commitd566d54fa6c982cb4bed8330d51cb11bfe3674ed (patch)
treedb8ae1482499741d4dbb123637dac45579f28eb5 /multimedia/gstreamer1-validate
parent190ced69a285efe9780eea205067282568a3063f (diff)
downloadports-d566d54fa6c982cb4bed8330d51cb11bfe3674ed.tar.gz
ports-d566d54fa6c982cb4bed8330d51cb11bfe3674ed.zip
Update GStreamer1 ports to 1.12.2.
Rework the adding of dependancies in Mk/bsd.gstreamer.mk. Previous when using USE_GSTREAMER[1] it would just add the request modules to BUILD/RUN_DEPENDS. This caused the qa script to complain because the old code didn't implicit depend on the gstreamer1 and gstreamer1-plugins[-bad] ports for the libraries they carried, even if they where present via the plugins! The new code adds implicit depends on these ports so USE_GSTREAMER[1] using ports have all the libraries included. * The mad mp3 plugin was removed, mpg123 plugin also provides mp3 decoding. Switch over ports that used the gstreamer1 mad plugin. * gtksink plugin renamed -> gtk * Hook up the sndio plugin into the framework * Add some indirect dependacies where needed * Reorder the plugin list in bsd.gstreamer.mk so only one plugin per line. When changing plugins it doesn't result in multiple lines being changed. * Remove mentions in bsd.gstreamer.mk of plugins mentions that where removed. * Depend on libunwind on i386/amd64, GStreamer links to it if it is present. PR: 220753 Exp-run by: antoine@
Notes
Notes: svn path=/head/; revision=446388
Diffstat (limited to 'multimedia/gstreamer1-validate')
-rw-r--r--multimedia/gstreamer1-validate/Makefile11
-rw-r--r--multimedia/gstreamer1-validate/distinfo5
-rw-r--r--multimedia/gstreamer1-validate/pkg-plist36
3 files changed, 31 insertions, 21 deletions
diff --git a/multimedia/gstreamer1-validate/Makefile b/multimedia/gstreamer1-validate/Makefile
index 8f8fa6b9ce26..b01e57da9858 100644
--- a/multimedia/gstreamer1-validate/Makefile
+++ b/multimedia/gstreamer1-validate/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gstreamer1-validate
-PORTVERSION= 1.8.0
+PORTVERSION= 1.12.2
CATEGORIES= multimedia
MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-validate/
DISTNAME= gst-validate-${PORTVERSION}
@@ -10,13 +10,16 @@ DISTNAME= gst-validate-${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Gstreamer element validation suite
-USES= gmake libtool pathfix pkgconfig python:2 tar:xz
+LIB_DEPENDS= libjson-glib-1.0.so:devel/json-glib
+
+USES= gettext-runtime gmake gnome libtool pathfix \
+ pkgconfig python:2 tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_GNOME= gtk30 introspection:build
+USE_GNOME= cairo gdkpixbuf2 gtk30 introspection:build
USE_GSTREAMER1= yes
INSTALL_TARGET= install-strip
-PLIST_SUB= VERSION=1.0 SOVERSION=0.800.0
+PLIST_SUB= VERSION=1.0 SOVERSION=0.1202.0
.include <bsd.port.mk>
diff --git a/multimedia/gstreamer1-validate/distinfo b/multimedia/gstreamer1-validate/distinfo
index eb066576c94d..f46e1d5e83b3 100644
--- a/multimedia/gstreamer1-validate/distinfo
+++ b/multimedia/gstreamer1-validate/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gst-validate-1.8.0.tar.xz) = 7666b777bd4b05efe4520ef92669169d8879f69a68606578ec667ae7dc4d9edd
-SIZE (gst-validate-1.8.0.tar.xz) = 644088
+TIMESTAMP = 1500051668
+SHA256 (gst-validate-1.12.2.tar.xz) = 6b7a25d1fd2a08ffe08e4809587f16b4c4e01dfd9e77cfa222b7f2558666fedd
+SIZE (gst-validate-1.12.2.tar.xz) = 673404
diff --git a/multimedia/gstreamer1-validate/pkg-plist b/multimedia/gstreamer1-validate/pkg-plist
index 803e6ecb7098..f1d2b50aa95c 100644
--- a/multimedia/gstreamer1-validate/pkg-plist
+++ b/multimedia/gstreamer1-validate/pkg-plist
@@ -28,43 +28,47 @@ include/gstreamer-%%VERSION%%/lib/validate/video/gstvalidatessim.h
lib/girepository-%%VERSION%%/GstValidate-%%VERSION%%.typelib
lib/gst-validate-launcher/python/launcher/RangeHTTPServer.py
lib/gst-validate-launcher/python/launcher/RangeHTTPServer.pyc
-lib/gst-validate-launcher/python/launcher/RangeHTTPServer.pyo
+lib/gst-validate-launcher/python/launcher/RangeHTTPServer.%%PYTHON_PYOEXTENSION%%
lib/gst-validate-launcher/python/launcher/__init__.py
lib/gst-validate-launcher/python/launcher/__init__.pyc
-lib/gst-validate-launcher/python/launcher/__init__.pyo
+lib/gst-validate-launcher/python/launcher/__init__.%%PYTHON_PYOEXTENSION%%
lib/gst-validate-launcher/python/launcher/apps/__init__.py
lib/gst-validate-launcher/python/launcher/apps/__init__.pyc
-lib/gst-validate-launcher/python/launcher/apps/__init__.pyo
+lib/gst-validate-launcher/python/launcher/apps/__init__.%%PYTHON_PYOEXTENSION%%
+lib/gst-validate-launcher/python/launcher/apps/gstcheck.py
+lib/gst-validate-launcher/python/launcher/apps/gstcheck.pyc
+lib/gst-validate-launcher/python/launcher/apps/gstcheck.%%PYTHON_PYOEXTENSION%%
lib/gst-validate-launcher/python/launcher/apps/gstvalidate.py
lib/gst-validate-launcher/python/launcher/apps/gstvalidate.pyc
-lib/gst-validate-launcher/python/launcher/apps/gstvalidate.pyo
+lib/gst-validate-launcher/python/launcher/apps/gstvalidate.%%PYTHON_PYOEXTENSION%%
lib/gst-validate-launcher/python/launcher/baseclasses.py
lib/gst-validate-launcher/python/launcher/baseclasses.pyc
-lib/gst-validate-launcher/python/launcher/baseclasses.pyo
+lib/gst-validate-launcher/python/launcher/baseclasses.%%PYTHON_PYOEXTENSION%%
lib/gst-validate-launcher/python/launcher/config.py
lib/gst-validate-launcher/python/launcher/config.pyc
-lib/gst-validate-launcher/python/launcher/config.pyo
+lib/gst-validate-launcher/python/launcher/config.%%PYTHON_PYOEXTENSION%%
lib/gst-validate-launcher/python/launcher/httpserver.py
lib/gst-validate-launcher/python/launcher/httpserver.pyc
-lib/gst-validate-launcher/python/launcher/httpserver.pyo
+lib/gst-validate-launcher/python/launcher/httpserver.%%PYTHON_PYOEXTENSION%%
lib/gst-validate-launcher/python/launcher/loggable.py
lib/gst-validate-launcher/python/launcher/loggable.pyc
-lib/gst-validate-launcher/python/launcher/loggable.pyo
+lib/gst-validate-launcher/python/launcher/loggable.%%PYTHON_PYOEXTENSION%%
lib/gst-validate-launcher/python/launcher/main.py
lib/gst-validate-launcher/python/launcher/main.pyc
-lib/gst-validate-launcher/python/launcher/main.pyo
+lib/gst-validate-launcher/python/launcher/main.%%PYTHON_PYOEXTENSION%%
lib/gst-validate-launcher/python/launcher/reporters.py
lib/gst-validate-launcher/python/launcher/reporters.pyc
-lib/gst-validate-launcher/python/launcher/reporters.pyo
+lib/gst-validate-launcher/python/launcher/reporters.%%PYTHON_PYOEXTENSION%%
+lib/gst-validate-launcher/python/launcher/testsuites/check.py
+lib/gst-validate-launcher/python/launcher/testsuites/check.pyc
+lib/gst-validate-launcher/python/launcher/testsuites/check.%%PYTHON_PYOEXTENSION%%
lib/gst-validate-launcher/python/launcher/utils.py
lib/gst-validate-launcher/python/launcher/utils.pyc
-lib/gst-validate-launcher/python/launcher/utils.pyo
+lib/gst-validate-launcher/python/launcher/utils.%%PYTHON_PYOEXTENSION%%
lib/gst-validate-launcher/python/launcher/vfb_server.py
lib/gst-validate-launcher/python/launcher/vfb_server.pyc
-lib/gst-validate-launcher/python/launcher/vfb_server.pyo
-lib/gstreamer-%%VERSION%%/libgstvalidateplugin-%%VERSION%%.so
-lib/gstreamer-%%VERSION%%/libgstvalidateplugin-%%VERSION%%.so.0
-lib/gstreamer-%%VERSION%%/libgstvalidateplugin-%%VERSION%%.so.%%SOVERSION%%
+lib/gst-validate-launcher/python/launcher/vfb_server.%%PYTHON_PYOEXTENSION%%
+lib/gstreamer-%%VERSION%%/libgstvalidatetracer.so
lib/gstreamer-%%VERSION%%/validate/libgstvalidatefaultinjection.so
lib/gstreamer-%%VERSION%%/validate/libgstvalidategapplication.so
lib/gstreamer-%%VERSION%%/validate/libgstvalidategtk.so
@@ -102,9 +106,11 @@ share/gstreamer-%%VERSION%%/validate/scenarios/seek_backward.scenario
share/gstreamer-%%VERSION%%/validate/scenarios/seek_forward.scenario
share/gstreamer-%%VERSION%%/validate/scenarios/seek_forward_backward.scenario
share/gstreamer-%%VERSION%%/validate/scenarios/seek_with_stop.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/setup_sink_props_max_lateness.scenario
share/gstreamer-%%VERSION%%/validate/scenarios/simple_seeks.scenario
share/gstreamer-%%VERSION%%/validate/scenarios/switch_audio_track.scenario
share/gstreamer-%%VERSION%%/validate/scenarios/switch_audio_track_while_paused.scenario
share/gstreamer-%%VERSION%%/validate/scenarios/switch_subtitle_track.scenario
share/gstreamer-%%VERSION%%/validate/scenarios/switch_subtitle_track_while_paused.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/trick_mode_seeks.scenario
share/gstreamer-%%VERSION%%/validate/valgrind.config