aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gxine
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-04-23 13:25:16 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-04-23 13:25:16 +0000
commitaad09bc5e23eb75a7a865a8b0002fbc6e13d4659 (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /multimedia/gxine
parent5c818b158c5b9479669f8322b4da8c48f5c30ef9 (diff)
downloadports-aad09bc5e23eb75a7a865a8b0002fbc6e13d4659.tar.gz
ports-aad09bc5e23eb75a7a865a8b0002fbc6e13d4659.zip
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs field) to the linker command line and store them in the dependency_libs field of libA.la. So everything that subsequently links with libA will also link to these extra libraries. This causes too much overlinking. This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs field in .la libraries during staging. However, because .la libraries have very limited use when dependency_libs is empty it makes sense to completely remove them during staging. So with this commit USES=libtool is modified to remove .la libraries and a new form (USES=libtool:keepla) is introduced in case they need to be kept (dependency_libs is still emptied). PORTREVISION is bumped on all ports with USES=libtool that install .la libraries. Most ports are also changed to add :keepla because .la libraries have to be kept around as long as there are dependent ports with .la libraries that refer to them in their dependency_libs field. In most cases :keepla can be removed again as soon as all dependent ports that install .la libraries have some form of USES=libtool added to their Makefile. PR: ports/188759 Exp-run: bdrewery Approved by: portmgr (bdrewery)
Notes
Notes: svn path=/head/; revision=351936
Diffstat (limited to 'multimedia/gxine')
-rw-r--r--multimedia/gxine/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/multimedia/gxine/Makefile b/multimedia/gxine/Makefile
index 6c13cbd78875..a11d86fb1410 100644
--- a/multimedia/gxine/Makefile
+++ b/multimedia/gxine/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gxine
PORTVERSION= 0.5.907
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= multimedia
MASTER_SITES= SF/xine/${PORTNAME}/${PORTVERSION}
@@ -19,10 +19,9 @@ LIB_DEPENDS= libnspr4.so:${PORTSDIR}/devel/nspr \
OPTIONS_DEFINE= MOZILLA_PLUGIN GNOME LIRC
MOZILLA_PLUGIN_DESC= Mozilla plugin
-USES= gmake libtool pathfix pkgconfig tar:xz
+USES= gmake libtool:keepla pathfix pkgconfig tar:xz
USE_GNOME= gtk20
-USE_AUTOTOOLS= libtool
-CONFIGURE_ENV= MKDIR_P="${MKDIR}"
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-hal --with-libintl-prefix=${LOCALBASE}
INSTALLS_ICONS= yes