aboutsummaryrefslogtreecommitdiff
path: root/multimedia/handbrake
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-12-03 15:43:54 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-12-03 15:43:54 +0000
commitbc5b6f4d978a294b73f523246f33d07760597c90 (patch)
tree74559cda1d3ddedec0a42aeea02047371f9cb46b /multimedia/handbrake
parent7cc0af24f2052be94ce03674396024f2cfa173e2 (diff)
downloadports-bc5b6f4d978a294b73f523246f33d07760597c90.tar.gz
ports-bc5b6f4d978a294b73f523246f33d07760597c90.zip
multimedia/handbrake: update to 1.3.0
Here is a list of changes since 1.2.2: - fix portlint warning - USES line more earlier - change to use libvpx from Ports It is upstream's decision. - removed dependency (also upstream's decision) libramplerate - update contrib libraries fdk-aac 2.0.1 ffmpeg 4.2.1 libbluray 1.1.2 libdvdnav 6.0.1 libdvdread 6.0.2 dav1d 0.5.1 x265 3.2.1 - python3 support for building. - added build dependency of devel/meson. - pkg-decr mentions about VP8, VP9 video codecs. - pkg-plist includes new message catalogs. Remove two ppc64-specific patches (for libvpx and x265) and add one (for ffmpeg). PR: 241902 Submitted by: naito.yuichiro@gmail.com (maintainer) Approved by: mentors (implicit approval)
Notes
Notes: svn path=/head/; revision=518950
Diffstat (limited to 'multimedia/handbrake')
-rw-r--r--multimedia/handbrake/Makefile33
-rw-r--r--multimedia/handbrake/distinfo34
-rw-r--r--multimedia/handbrake/files/P02-freebsd-ppc-libswscale.patch55
-rw-r--r--multimedia/handbrake/files/patch-contrib_libvpx_P05-freebsd-ppc.patch14
-rw-r--r--multimedia/handbrake/files/patch-contrib_x265_P01-freebsd-ppc.patch53
-rw-r--r--multimedia/handbrake/files/patch-gtk_src_Makefile.am11
-rw-r--r--multimedia/handbrake/files/patch-make_variant_freebsd.defs8
-rw-r--r--multimedia/handbrake/files/version.txt10
-rw-r--r--multimedia/handbrake/pkg-descr2
-rw-r--r--multimedia/handbrake/pkg-plist16
10 files changed, 126 insertions, 110 deletions
diff --git a/multimedia/handbrake/Makefile b/multimedia/handbrake/Makefile
index 3f812f992724..6eb5173bd923 100644
--- a/multimedia/handbrake/Makefile
+++ b/multimedia/handbrake/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= handbrake
-DISTVERSION= 1.2.2
-PORTREVISION= 1
+DISTVERSION= 1.3.0
CATEGORIES= multimedia
DIST_SUBDIR= ${PORTNAME}
@@ -17,7 +16,8 @@ ONLY_FOR_ARCHS= amd64 i386 powerpc64
BUILD_DEPENDS= bash:shells/bash \
nasm:devel/nasm \
- cmake:devel/cmake
+ cmake:devel/cmake \
+ meson:devel/meson
LIB_DEPENDS= libdbus-1.so:devel/dbus \
libharfbuzz.so:print/harfbuzz \
libfontconfig.so:x11-fonts/fontconfig \
@@ -31,20 +31,24 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libvorbisenc.so:audio/libvorbis \
libtheoradec.so:multimedia/libtheora \
libtheoraenc.so:multimedia/libtheora \
- libsamplerate.so:audio/libsamplerate \
libx264.so:multimedia/libx264 \
+ libvpx.so:multimedia/libvpx \
libmp3lame.so:audio/lame \
libopus.so:audio/opus \
libjansson.so:devel/jansson
-CONTRIB_FILES= fdk-aac-0.1.5.tar.gz \
- ffmpeg-4.1.tar.bz2 \
- libbluray-1.0.2.tar.bz2 \
- libdvdnav-6.0.0.tar.bz2 \
- libdvdread-6.0.0.tar.bz2 \
- libvpx-1.7.0.tar.gz \
- x265_2.9.tar.gz
+USES= autoreconf:build compiler:c11 gmake iconv \
+ libtool:build localbase:ldflags pkgconfig python:3.6+,build
+
+CONTRIB_FILES= fdk-aac-2.0.1.tar.gz \
+ ffmpeg-4.2.1.tar.bz2 \
+ libbluray-1.1.2.tar.bz2 \
+ libdvdnav-6.0.1.tar.bz2 \
+ libdvdread-6.0.2.tar.bz2 \
+ dav1d-0.5.1.tar.bz2 \
+ x265_3.2.1.tar.gz
MASTER_SITES+= https://download.handbrake.fr/contrib/:contrib
+
DISTFILES+= ${CONTRIB_FILES:S/$/:contrib/}
.if !defined(PACKAGE_BUILDING)
@@ -53,10 +57,10 @@ LIB_DEPENDS+= libdvdcss.so:multimedia/libdvdcss
.endif
GNU_CONFIGURE= yes
-USES= autoreconf:build compiler:c11 gmake iconv \
- libtool:build localbase:ldflags pkgconfig python:2.7,build
MAKE_ENV= V=1 ACLOCAL=${LOCALBASE}/bin/aclocal
+BINARY_ALIAS= python3=${PYTHON_VERSION}
+
USE_GITHUB= yes
GH_ACCOUNT= HandBrake
GH_PROJECT= HandBrake
@@ -111,6 +115,9 @@ post-extract: .SILENT
# Following patches reduces warnings with clang.
${CP} ${FILESDIR}/P00-freebsd-libavutil-x86-asm-h.patch ${WRKSRC}/contrib/ffmpeg
${CP} ${FILESDIR}/P01-freebsd-ifo_types.h.patch ${WRKSRC}/contrib/libdvdread
+# for powerpc64.
+# picked from multimedia/ffmpeg/files/patch-libswscale_ppc_swscale__altivec.c
+ ${CP} ${FILESDIR}/P02-freebsd-ppc-libswscale.patch ${WRKSRC}/contrib/ffmpeg
post-install-X11-on:
${LN} -sf ghb ${STAGEDIR}${PREFIX}/bin/HandBrake
diff --git a/multimedia/handbrake/distinfo b/multimedia/handbrake/distinfo
index 4e88b2a45d00..71607dd9e338 100644
--- a/multimedia/handbrake/distinfo
+++ b/multimedia/handbrake/distinfo
@@ -1,17 +1,17 @@
-TIMESTAMP = 1551058103
-SHA256 (handbrake/fdk-aac-0.1.5.tar.gz) = 2164592a67b467e5b20fdcdaf5bd4c50685199067391c6fcad4fa5521c9b4dd7
-SIZE (handbrake/fdk-aac-0.1.5.tar.gz) = 2091081
-SHA256 (handbrake/ffmpeg-4.1.tar.bz2) = b684fb43244a5c4caae652af9022ed5d85ce15210835bce054a33fb26033a1a5
-SIZE (handbrake/ffmpeg-4.1.tar.bz2) = 10687291
-SHA256 (handbrake/libbluray-1.0.2.tar.bz2) = 6d9e7c4e416f664c330d9fa5a05ad79a3fb39b95adfc3fd6910cbed503b7aeff
-SIZE (handbrake/libbluray-1.0.2.tar.bz2) = 733058
-SHA256 (handbrake/libdvdnav-6.0.0.tar.bz2) = f0a2711b08a021759792f8eb14bb82ff8a3c929bf88c33b64ffcddaa27935618
-SIZE (handbrake/libdvdnav-6.0.0.tar.bz2) = 369605
-SHA256 (handbrake/libdvdread-6.0.0.tar.bz2) = b33b1953b4860545b75f6efc06e01d9849e2ea4f797652263b0b4af6dd10f935
-SIZE (handbrake/libdvdread-6.0.0.tar.bz2) = 394627
-SHA256 (handbrake/libvpx-1.7.0.tar.gz) = 1fec931eb5c94279ad219a5b6e0202358e94a93a90cfb1603578c326abfc1238
-SIZE (handbrake/libvpx-1.7.0.tar.gz) = 2679797
-SHA256 (handbrake/x265_2.9.tar.gz) = ebae687c84a39f54b995417c52a2fdde65a4e2e7ebac5730d251471304b91024
-SIZE (handbrake/x265_2.9.tar.gz) = 1385848
-SHA256 (handbrake/HandBrake-HandBrake-1.2.2_GH0.tar.gz) = 068e5117c3d4e170b49122989d240caab2ddd1e8923ff4de9ede37a30db23bec
-SIZE (handbrake/HandBrake-HandBrake-1.2.2_GH0.tar.gz) = 18635387
+TIMESTAMP = 1573434561
+SHA256 (handbrake/fdk-aac-2.0.1.tar.gz) = a4142815d8d52d0e798212a5adea54ecf42bcd4eec8092b37a8cb615ace91dc6
+SIZE (handbrake/fdk-aac-2.0.1.tar.gz) = 2488373
+SHA256 (handbrake/ffmpeg-4.2.1.tar.bz2) = 682a9fa3f6864d7f0dbf224f86b129e337bc60286e0d00dffcd710998d521624
+SIZE (handbrake/ffmpeg-4.2.1.tar.bz2) = 10953293
+SHA256 (handbrake/libbluray-1.1.2.tar.bz2) = a3dd452239b100dc9da0d01b30e1692693e2a332a7d29917bf84bb10ea7c0b42
+SIZE (handbrake/libbluray-1.1.2.tar.bz2) = 745779
+SHA256 (handbrake/libdvdnav-6.0.1.tar.bz2) = e566a396f1950017088bfd760395b0565db44234195ada5413366c9d23926733
+SIZE (handbrake/libdvdnav-6.0.1.tar.bz2) = 378491
+SHA256 (handbrake/libdvdread-6.0.2.tar.bz2) = f91401af213b219cdde24b46c50a57f29301feb7f965678f1d7ed4632cc6feb0
+SIZE (handbrake/libdvdread-6.0.2.tar.bz2) = 405298
+SHA256 (handbrake/dav1d-0.5.1.tar.bz2) = 0214d201a338e8418f805b68f9ad277e33d79c18594dee6eaf6dcd74db2674a9
+SIZE (handbrake/dav1d-0.5.1.tar.bz2) = 548584
+SHA256 (handbrake/x265_3.2.1.tar.gz) = fb9badcf92364fd3567f8b5aa0e5e952aeea7a39a2b864387cec31e3b58cbbcc
+SIZE (handbrake/x265_3.2.1.tar.gz) = 1426255
+SHA256 (handbrake/HandBrake-HandBrake-1.3.0_GH0.tar.gz) = d31c6f669da5f49b60ff2d04f5c5906e15fc5e81563331333e3f862e4e48668b
+SIZE (handbrake/HandBrake-HandBrake-1.3.0_GH0.tar.gz) = 17908235
diff --git a/multimedia/handbrake/files/P02-freebsd-ppc-libswscale.patch b/multimedia/handbrake/files/P02-freebsd-ppc-libswscale.patch
new file mode 100644
index 000000000000..ed939c894c62
--- /dev/null
+++ b/multimedia/handbrake/files/P02-freebsd-ppc-libswscale.patch
@@ -0,0 +1,55 @@
+--- a/libswscale/ppc/swscale_altivec.c.orig 2019-08-11 20:06:32 UTC
++++ b/libswscale/ppc/swscale_altivec.c
+@@ -153,13 +153,13 @@ static void yuv2plane1_float_altivec(const int32_t *sr
+ const int add = (1 << (shift - 1));
+ const int clip = (1 << 16) - 1;
+ const float fmult = 1.0f / 65535.0f;
+- const vector uint32_t vadd = (vector uint32_t) {add, add, add, add};
+- const vector uint32_t vshift = (vector uint32_t) vec_splat_u32(shift);
+- const vector uint32_t vlargest = (vector uint32_t) {clip, clip, clip, clip};
+- const vector float vmul = (vector float) {fmult, fmult, fmult, fmult};
+- const vector float vzero = (vector float) {0, 0, 0, 0};
+- vector uint32_t v;
+- vector float vd;
++ const vec_u32 vadd = (vec_u32) {add, add, add, add};
++ const vec_u32 vshift = (vec_u32) vec_splat_u32(shift);
++ const vec_u32 vlargest = (vec_u32) {clip, clip, clip, clip};
++ const vec_f vmul = (vec_f) {fmult, fmult, fmult, fmult};
++ const vec_f vzero = (vec_f) {0, 0, 0, 0};
++ vec_u32 v;
++ vec_f vd;
+ int i;
+
+ yuv2plane1_float_u(src, dest, dst_u, 0);
+@@ -186,14 +186,14 @@ static void yuv2plane1_float_bswap_altivec(const int32
+ const int add = (1 << (shift - 1));
+ const int clip = (1 << 16) - 1;
+ const float fmult = 1.0f / 65535.0f;
+- const vector uint32_t vadd = (vector uint32_t) {add, add, add, add};
+- const vector uint32_t vshift = (vector uint32_t) vec_splat_u32(shift);
+- const vector uint32_t vlargest = (vector uint32_t) {clip, clip, clip, clip};
++ const vec_u32 vadd = (vec_u32) {add, add, add, add};
++ const vec_u32 vshift = (vec_u32) vec_splat_u32(shift);
++ const vec_u32 vlargest = (vec_u32) {clip, clip, clip, clip};
+ const vector float vmul = (vector float) {fmult, fmult, fmult, fmult};
+ const vector float vzero = (vector float) {0, 0, 0, 0};
+- const vector uint32_t vswapbig = (vector uint32_t) {16, 16, 16, 16};
+- const vector uint16_t vswapsmall = vec_splat_u16(8);
+- vector uint32_t v;
++ const vec_u32 vswapbig = (vec_u32) {16, 16, 16, 16};
++ const vec_u16 vswapsmall = vec_splat_u16(8);
++ vec_u32 v;
+ vector float vd;
+ int i;
+
+@@ -208,8 +208,8 @@ static void yuv2plane1_float_bswap_altivec(const int32
+ vd = vec_ctf(v, 0);
+ vd = vec_madd(vd, vmul, vzero);
+
+- vd = (vector float) vec_rl((vector uint32_t) vd, vswapbig);
+- vd = (vector float) vec_rl((vector uint16_t) vd, vswapsmall);
++ vd = (vector float) vec_rl((vec_u32) vd, vswapbig);
++ vd = (vector float) vec_rl((vec_u16) vd, vswapsmall);
+
+ vec_st(vd, 0, (float *) &dest[i]);
+ }
diff --git a/multimedia/handbrake/files/patch-contrib_libvpx_P05-freebsd-ppc.patch b/multimedia/handbrake/files/patch-contrib_libvpx_P05-freebsd-ppc.patch
deleted file mode 100644
index 9f81fca45b55..000000000000
--- a/multimedia/handbrake/files/patch-contrib_libvpx_P05-freebsd-ppc.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- contrib/libvpx/P05-freebsd-ppc.patch.orig 2019-11-12 14:12:26 UTC
-+++ contrib/libvpx/P05-freebsd-ppc.patch
-@@ -0,0 +1,11 @@
-+--- libvpx-1.7.0/vpx_ports/ppc_cpudetect.c.orig 2019-11-12 15:11:30.139706000 +0100
-++++ libvpx-1.7.0/vpx_ports/ppc_cpudetect.c
-+@@ -11,8 +11,6 @@
-+ #include <fcntl.h>
-+ #include <unistd.h>
-+ #include <stdint.h>
-+-#include <asm/cputable.h>
-+-#include <linux/auxvec.h>
-+
-+ #include "./vpx_config.h"
-+ #include "vpx_ports/ppc.h"
diff --git a/multimedia/handbrake/files/patch-contrib_x265_P01-freebsd-ppc.patch b/multimedia/handbrake/files/patch-contrib_x265_P01-freebsd-ppc.patch
deleted file mode 100644
index e58fbc424c7b..000000000000
--- a/multimedia/handbrake/files/patch-contrib_x265_P01-freebsd-ppc.patch
+++ /dev/null
@@ -1,53 +0,0 @@
---- contrib/x265/P01-freebsd-ppc.patch.orig 2019-11-12 19:13:27 UTC
-+++ contrib/x265/P01-freebsd-ppc.patch
-@@ -0,0 +1,50 @@
-+--- x265_2.9/source/common/cpu.cpp.orig 2019-11-12 20:19:28.629150000 +0100
-++++ x265_2.9/source/common/cpu.cpp
-+@@ -127,6 +127,7 @@
-+ {
-+ return(enable512);
-+ }
-++
-+ uint32_t cpu_detect(bool benableavx512 )
-+ {
-+
-+--- x265_2.9/source/common/quant.cpp.orig 2019-11-12 20:19:34.848807000 +0100
-++++ x265_2.9/source/common/quant.cpp
-+@@ -723,6 +723,7 @@
-+ X265_CHECK(coeffNum[cgScanPos] == 0, "count of coeff failure\n");
-+ uint32_t scanPosBase = (cgScanPos << MLS_CG_SIZE);
-+ uint32_t blkPos = codeParams.scan[scanPosBase];
-++#if X265_ARCH_X86
-+ bool enable512 = detect512();
-+ if (enable512)
-+ primitives.cu[log2TrSize - 2].psyRdoQuant(m_resiDctCoeff, m_fencDctCoeff, costUncoded, &totalUncodedCost, &totalRdCost, &psyScale, blkPos);
-+@@ -731,6 +732,10 @@
-+ primitives.cu[log2TrSize - 2].psyRdoQuant_1p(m_resiDctCoeff, costUncoded, &totalUncodedCost, &totalRdCost,blkPos);
-+ primitives.cu[log2TrSize - 2].psyRdoQuant_2p(m_resiDctCoeff, m_fencDctCoeff, costUncoded, &totalUncodedCost, &totalRdCost, &psyScale, blkPos);
-+ }
-++#else
-++ primitives.cu[log2TrSize - 2].psyRdoQuant_1p(m_resiDctCoeff, costUncoded, &totalUncodedCost, &totalRdCost, blkPos);
-++ primitives.cu[log2TrSize - 2].psyRdoQuant_2p(m_resiDctCoeff, m_fencDctCoeff, costUncoded, &totalUncodedCost, &totalRdCost, &psyScale, blkPos);
-++#endif
-+ }
-+ }
-+ else
-+@@ -805,6 +810,7 @@
-+ uint32_t blkPos = codeParams.scan[scanPosBase];
-+ if (usePsyMask)
-+ {
-++#if X265_ARCH_X86
-+ bool enable512 = detect512();
-+
-+ if (enable512)
-+@@ -814,6 +820,10 @@
-+ primitives.cu[log2TrSize - 2].psyRdoQuant_1p(m_resiDctCoeff, costUncoded, &totalUncodedCost, &totalRdCost, blkPos);
-+ primitives.cu[log2TrSize - 2].psyRdoQuant_2p(m_resiDctCoeff, m_fencDctCoeff, costUncoded, &totalUncodedCost, &totalRdCost, &psyScale, blkPos);
-+ }
-++#else
-++ primitives.cu[log2TrSize - 2].psyRdoQuant_1p(m_resiDctCoeff, costUncoded, &totalUncodedCost, &totalRdCost, blkPos);
-++ primitives.cu[log2TrSize - 2].psyRdoQuant_2p(m_resiDctCoeff, m_fencDctCoeff, costUncoded, &totalUncodedCost, &totalRdCost, &psyScale, blkPos);
-++#endif
-+ blkPos = codeParams.scan[scanPosBase];
-+ for (int y = 0; y < MLS_CG_SIZE; y++)
-+ {
diff --git a/multimedia/handbrake/files/patch-gtk_src_Makefile.am b/multimedia/handbrake/files/patch-gtk_src_Makefile.am
new file mode 100644
index 000000000000..7e4520ebfdde
--- /dev/null
+++ b/multimedia/handbrake/files/patch-gtk_src_Makefile.am
@@ -0,0 +1,11 @@
+--- gtk/src/Makefile.am.orig 2019-11-09 20:44:32 UTC
++++ gtk/src/Makefile.am
+@@ -51,7 +51,7 @@ DISTCLEANFILES = \
+ $(appdata_files)
+
+ AM_CPPFLAGS = \
+- -DPACKAGE_LOCALE_DIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
++ -DPACKAGE_LOCALE_DIR=\""$(datadir)/locale"\" \
+ -DPACKAGE_SRC_DIR=\""$(srcdir)"\" \
+ -DPACKAGE_DATA_DIR=\""$(datadir)"\" \
+ $(GHB_CFLAGS)
diff --git a/multimedia/handbrake/files/patch-make_variant_freebsd.defs b/multimedia/handbrake/files/patch-make_variant_freebsd.defs
index f46dbb9e1abb..fb1e20c61db9 100644
--- a/multimedia/handbrake/files/patch-make_variant_freebsd.defs
+++ b/multimedia/handbrake/files/patch-make_variant_freebsd.defs
@@ -1,8 +1,8 @@
---- make/variant/freebsd.defs.orig 2019-02-22 17:23:51.000000000 +0100
-+++ make/variant/freebsd.defs 2019-11-17 20:08:28.821497000 +0100
-@@ -15,4 +15,4 @@
+--- make/variant/freebsd.defs.orig 2019-11-09 20:44:32 UTC
++++ make/variant/freebsd.defs
+@@ -15,4 +15,4 @@ GCC.args.g.max = -g3
GCC.MAJOR_VERSION = $(shell $(GCC.gcc) -dumpversion | cut -f 1 -d .)
GCC.LDFLAGS = -lc++ -Wl,-rpath=$(LOCALBASE)/lib/gcc$(GCC.MAJOR_VERSION)
-LDFLAGS += $(if $(findstring gcc, $(GCC.gcc)), $(GCC.LDFLAGS), )
-+LDFLAGS += $(if $(findstring gcc, $(GCC.gcc)), $(if $(findstring x86, $(GCC.archs)), $(GCC.LDFLAGS), ), )
++LDFLAGS += $(if $(findstring gcc, $(GCC.gcc)), $(if $(shell /usr/bin/clang -dumpversion 2> /dev/null), $(GCC.LDFLAGS), ), )
diff --git a/multimedia/handbrake/files/version.txt b/multimedia/handbrake/files/version.txt
index fbe0c4ac49c1..48d6a870aa37 100644
--- a/multimedia/handbrake/files/version.txt
+++ b/multimedia/handbrake/files/version.txt
@@ -1,9 +1,9 @@
URL=https://github.com/HandBrake/HandBrake.git
-HASH=4eb9f7b2f925620cc346ab186010a6e5711a5cc8
-SHORTHASH=4eb9f7b2f
-TAG=1.2.2
-TAG_HASH=4eb9f7b2f925620cc346ab186010a6e5711a5cc8
+HASH=4672248655ddd687161bacdb539c208abde15c59
+SHORTHASH=467224865
+TAG=1.3.0
+TAG_HASH=4672248655ddd687161bacdb539c208abde15c59
REV=0
BRANCH=
REMOTE=https://github.com/HandBrake/HandBrake.git
-DATE=2019-02-22 17:23:51 +0100
+DATE=2019-11-09 15:44:32 -0500
diff --git a/multimedia/handbrake/pkg-descr b/multimedia/handbrake/pkg-descr
index b0ab289d540c..fdb63d28ebc9 100644
--- a/multimedia/handbrake/pkg-descr
+++ b/multimedia/handbrake/pkg-descr
@@ -12,7 +12,7 @@ Outputs:
* File (container) format: MP4 (M4V) and MKV
* Video: H.264 (x264), H.265 (x265), MPEG-2/MPEG-4 (ffmpeg),
- or Theora (libtheora)
+ VP8, VP9 (libvpx) or Theora (libtheora)
* Audio: AAC, CoreAudio AAC/HE-AAC (OS X only), MP3, FLAC, AC3, or Vorbis;
AC-3, DTS, DTS-HD, AAC, and MP3 pass-through
diff --git a/multimedia/handbrake/pkg-plist b/multimedia/handbrake/pkg-plist
index ca78f6342d67..4102453caad9 100644
--- a/multimedia/handbrake/pkg-plist
+++ b/multimedia/handbrake/pkg-plist
@@ -4,18 +4,28 @@ bin/HandBrakeCLI
%%X11%%share/applications/fr.handbrake.ghb.desktop
%%X11%%share/icons/hicolor/scalable/apps/hb-icon.svg
%%X11%%share/icons/hicolor/scalable/apps/fr.handbrake.ghb.svg
+%%X11%%share/locale/af/LC_MESSAGES/ghb.mo
%%X11%%share/locale/cs/LC_MESSAGES/ghb.mo
%%X11%%share/locale/da/LC_MESSAGES/ghb.mo
%%X11%%share/locale/de/LC_MESSAGES/ghb.mo
%%X11%%share/locale/es/LC_MESSAGES/ghb.mo
+%%X11%%share/locale/eu/LC_MESSAGES/ghb.mo
%%X11%%share/locale/fr/LC_MESSAGES/ghb.mo
-%%X11%%share/locale/it_IT/LC_MESSAGES/ghb.mo
-%%X11%%share/locale/ja_JP/LC_MESSAGES/ghb.mo
+%%X11%%share/locale/hr/LC_MESSAGES/ghb.mo
+%%X11%%share/locale/it/LC_MESSAGES/ghb.mo
+%%X11%%share/locale/ja/LC_MESSAGES/ghb.mo
%%X11%%share/locale/ko/LC_MESSAGES/ghb.mo
+%%X11%%share/locale/nl/LC_MESSAGES/ghb.mo
%%X11%%share/locale/no/LC_MESSAGES/ghb.mo
+%%X11%%share/locale/pl/LC_MESSAGES/ghb.mo
+%%X11%%share/locale/pt/LC_MESSAGES/ghb.mo
%%X11%%share/locale/pt_BR/LC_MESSAGES/ghb.mo
-%%X11%%share/locale/ro_RO/LC_MESSAGES/ghb.mo
+%%X11%%share/locale/ro/LC_MESSAGES/ghb.mo
%%X11%%share/locale/ru/LC_MESSAGES/ghb.mo
+%%X11%%share/locale/sk/LC_MESSAGES/ghb.mo
+%%X11%%share/locale/sv/LC_MESSAGES/ghb.mo
%%X11%%share/locale/th/LC_MESSAGES/ghb.mo
+%%X11%%share/locale/tr/LC_MESSAGES/ghb.mo
+%%X11%%share/locale/uk_UA/LC_MESSAGES/ghb.mo
%%X11%%share/locale/zh_CN/LC_MESSAGES/ghb.mo
%%X11%%share/metainfo/fr.handbrake.ghb.appdata.xml