aboutsummaryrefslogtreecommitdiff
path: root/multimedia/imagination
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2014-03-14 15:20:36 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2014-03-14 15:20:36 +0000
commit03852c53e2a9fe827c21eb463d6dbdba7e861496 (patch)
tree96e3667fac1f82854fbd3d37b89750218d689cc0 /multimedia/imagination
parent7276445cfb53682494864a1d7e66d5c2c1fafb21 (diff)
downloadports-03852c53e2a9fe827c21eb463d6dbdba7e861496.tar.gz
ports-03852c53e2a9fe827c21eb463d6dbdba7e861496.zip
- Support STAGEDIR [1]
- Use options helpers [1] - Move sox dependency from BUILD_DEPENDS to LIB_DEPENDS [1] - Force Imagination to use plugins [2] - Adjust GNOME dependencies - Add patch when NLS is not set - Bump PORTREVISION PR: 186596 [1], 186644 [2] Submitted by: Zsolt Udvari [1], [2] Approved by: Jesse Smith (maintainer) [1], timeout (> 1 month) [2]
Notes
Notes: svn path=/head/; revision=348254
Diffstat (limited to 'multimedia/imagination')
-rw-r--r--multimedia/imagination/Makefile28
-rw-r--r--multimedia/imagination/files/patch-configure11
-rw-r--r--multimedia/imagination/files/patch-use-plugins.h11
-rw-r--r--multimedia/imagination/pkg-plist38
4 files changed, 39 insertions, 49 deletions
diff --git a/multimedia/imagination/Makefile b/multimedia/imagination/Makefile
index afc87da692a6..209ca82094b8 100644
--- a/multimedia/imagination/Makefile
+++ b/multimedia/imagination/Makefile
@@ -3,36 +3,24 @@
PORTNAME= imagination
PORTVERSION= 3.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
MAINTAINER= jessefrgsmith@yahoo.ca
COMMENT= DVD slideshow maker
-BUILD_DEPENDS= ${LOCALBASE}/lib/gtk-2.0:${PORTSDIR}/x11-toolkits/gtk20 \
- ${LOCALBASE}/bin/sox:${PORTSDIR}/audio/sox \
- ${LOCALBASE}/bin/intltool-extract:${PORTSDIR}/textproc/intltool
-RUN_DEPENDS= ${LOCALBASE}/bin/ffmpeg:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS= libsox.so:${PORTSDIR}/audio/sox \
+ libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
GNU_CONFIGURE= yes
-USES= gmake pkgconfig
+USES= gmake pkgconfig pathfix
+USE_GNOME= gtk20 intltool intlhack libxslt
INSTALLS_ICONS= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
-NO_STAGE= yes
-
OPTIONS_DEFINE= NLS
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+OPTIONS_SUB= yes
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
.include <bsd.port.mk>
diff --git a/multimedia/imagination/files/patch-configure b/multimedia/imagination/files/patch-configure
new file mode 100644
index 000000000000..277c8dbbdd86
--- /dev/null
+++ b/multimedia/imagination/files/patch-configure
@@ -0,0 +1,11 @@
+--- ./configure.orig 2011-03-06 20:06:44.000000000 +0000
++++ ./configure 2014-03-14 15:08:46.000000000 +0000
+@@ -13029,7 +13029,7 @@
+
+ fi
+ fi
+- USE_NLS=yes
++ #USE_NLS=yes
+
+
+ gt_cv_have_gettext=no
diff --git a/multimedia/imagination/files/patch-use-plugins.h b/multimedia/imagination/files/patch-use-plugins.h
new file mode 100644
index 000000000000..2afb0d4c8bb4
--- /dev/null
+++ b/multimedia/imagination/files/patch-use-plugins.h
@@ -0,0 +1,11 @@
+--- src/support.h.orig 2014-02-11 08:51:06.175251265 +0100
++++ src/support.h 2014-02-11 08:51:14.270248604 +0100
+@@ -20,7 +20,7 @@
+ #ifndef __IMAGINATION_SUPPORT_H
+ #define __IMAGINATION_SUPPORT_H
+
+-#define PLUGINS_INSTALLED 0
++#define PLUGINS_INSTALLED 1
+
+ #ifdef HAVE_CONFIG_H
+ # include <config.h>
diff --git a/multimedia/imagination/pkg-plist b/multimedia/imagination/pkg-plist
index 30b048937633..b7c3c3b24071 100644
--- a/multimedia/imagination/pkg-plist
+++ b/multimedia/imagination/pkg-plist
@@ -29,21 +29,11 @@ lib/imagination/rochade.la
lib/imagination/rochade.so
lib/imagination/wave.la
lib/imagination/wave.so
-%%NLS%%lib/locale/cs/LC_MESSAGES/imagination.mo
-%%NLS%%lib/locale/de/LC_MESSAGES/imagination.mo
-%%NLS%%lib/locale/en_GB/LC_MESSAGES/imagination.mo
-%%NLS%%lib/locale/fr/LC_MESSAGES/imagination.mo
-%%NLS%%lib/locale/it/LC_MESSAGES/imagination.mo
-%%NLS%%lib/locale/pt_BR/LC_MESSAGES/imagination.mo
-%%NLS%%lib/locale/sv/LC_MESSAGES/imagination.mo
-%%NLS%%lib/locale/zh_CN/LC_MESSAGES/imagination.mo
-%%NLS%%lib/locale/zh_TW/LC_MESSAGES/imagination.mo
share/applications/imagination.desktop
share/icons/hicolor/16x16/apps/imagination.png
share/icons/hicolor/24x24/apps/imagination.png
share/icons/hicolor/48x48/apps/imagination.png
share/icons/hicolor/scalable/apps/imagination.svg
-share/icons/hicolor/icon-theme.cache
%%DATADIR%%/pixmaps/imagination-1.gif
%%DATADIR%%/pixmaps/imagination-1.png
%%DATADIR%%/pixmaps/imagination-10.gif
@@ -195,25 +185,15 @@ share/icons/hicolor/icon-theme.cache
%%DATADIR%%/pixmaps/imagination-pos-7.png
%%DATADIR%%/pixmaps/imagination-pos-8.png
%%DATADIR%%/pixmaps/imagination-text.png
+%%NLS%%share/locale/cs/LC_MESSAGES/imagination.mo
+%%NLS%%share/locale/de/LC_MESSAGES/imagination.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/imagination.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/imagination.mo
+%%NLS%%share/locale/it/LC_MESSAGES/imagination.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/imagination.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/imagination.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/imagination.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/imagination.mo
@dirrmtry %%DATADIR%%/pixmaps
@dirrmtry %%DATADIR%%
-%%NLS%%@dirrm lib/locale/zh_TW/LC_MESSAGES
-%%NLS%%@dirrm lib/locale/zh_TW
-%%NLS%%@dirrm lib/locale/zh_CN/LC_MESSAGES
-%%NLS%%@dirrm lib/locale/zh_CN
-%%NLS%%@dirrm lib/locale/sv/LC_MESSAGES
-%%NLS%%@dirrm lib/locale/sv
-%%NLS%%@dirrm lib/locale/pt_BR/LC_MESSAGES
-%%NLS%%@dirrm lib/locale/pt_BR
-%%NLS%%@dirrm lib/locale/it/LC_MESSAGES
-%%NLS%%@dirrm lib/locale/it
-%%NLS%%@dirrm lib/locale/fr/LC_MESSAGES
-%%NLS%%@dirrm lib/locale/fr
-%%NLS%%@dirrm lib/locale/en_GB/LC_MESSAGES
-%%NLS%%@dirrm lib/locale/en_GB
-%%NLS%%@dirrm lib/locale/de/LC_MESSAGES
-%%NLS%%@dirrm lib/locale/de
-%%NLS%%@dirrm lib/locale/cs/LC_MESSAGES
-%%NLS%%@dirrm lib/locale/cs
-@dirrmtry lib/locale
@dirrm lib/imagination