aboutsummaryrefslogtreecommitdiff
path: root/multimedia/k9copy/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-26 00:05:59 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-26 00:05:59 +0000
commit0b9668650e60249714f149fb4a7376741b26442f (patch)
tree844e70cec37c2c77d80dca2db220289e8d217002 /multimedia/k9copy/Makefile
parent9c52b396dc822e227af535a8dd8bc26737fac379 (diff)
Notes
Diffstat (limited to 'multimedia/k9copy/Makefile')
-rw-r--r--multimedia/k9copy/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/multimedia/k9copy/Makefile b/multimedia/k9copy/Makefile
new file mode 100644
index 000000000000..7492ee94b220
--- /dev/null
+++ b/multimedia/k9copy/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: k9copy
+# Date created: 19 Dec 2005
+# Whom: Alexander V. Ribchansky <triosoft@triosoft.com.ua>
+#
+# $FreeBSD$
+
+PORTNAME= k9copy
+PORTVERSION= 1.0.1
+CATEGORIES= multimedia kde
+MASTER_SITES= http://k9copy.free.fr/
+
+MAINTAINER= triosoft@triosoft.com.ua
+COMMENT= A DVD-9 to DVD-5 shrinking application for KDE
+
+LIB_DEPENDS= dvdread.3:${PORTSDIR}/multimedia/libdvdread
+RUN_DEPENDS= growisofs:${PORTSDIR}/sysutils/dvd+rw-tools \
+ dvdauthor:${PORTSDIR}/multimedia/dvdauthor
+
+USE_KDELIBS_VER=3
+USE_REINPLACE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}b
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,-O2,,g ; \
+ s,-lpthread,${PTHREAD_LIBS},g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e \
+ 's,$$(LIB_KDEUI),$$(LIB_KDEUI) $$(LIBPTHREAD) -lcam,g' \
+ ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.mk>