aboutsummaryrefslogtreecommitdiff
path: root/multimedia/kodi-addon-pvr-hts
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2020-07-17 06:42:47 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2020-07-17 06:42:47 +0000
commit88700ad75af90b7ed391a06e691b9ddb2a8f9c97 (patch)
tree2664b633584e964fb7fd65718dbcdf0f01d333e3 /multimedia/kodi-addon-pvr-hts
parent7a69f997cc43f929de47a67ee72c39c8f00225f4 (diff)
downloadports-88700ad75af90b7ed391a06e691b9ddb2a8f9c97.tar.gz
ports-88700ad75af90b7ed391a06e691b9ddb2a8f9c97.zip
Notes
Diffstat (limited to 'multimedia/kodi-addon-pvr-hts')
-rw-r--r--multimedia/kodi-addon-pvr-hts/Makefile5
-rw-r--r--multimedia/kodi-addon-pvr-hts/distinfo6
-rw-r--r--multimedia/kodi-addon-pvr-hts/files/patch-src_tvheadend_entity_Event.h30
-rw-r--r--multimedia/kodi-addon-pvr-hts/pkg-plist5
4 files changed, 38 insertions, 8 deletions
diff --git a/multimedia/kodi-addon-pvr-hts/Makefile b/multimedia/kodi-addon-pvr-hts/Makefile
index fc6631a1a924..d48df9c4c16b 100644
--- a/multimedia/kodi-addon-pvr-hts/Makefile
+++ b/multimedia/kodi-addon-pvr-hts/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= kodi-addon-pvr-hts
-PORTVERSION= 3.4.27
+PORTVERSION= 4.4.21
CATEGORIES= multimedia
MAINTAINER= decke@FreeBSD.org
@@ -10,7 +10,7 @@ COMMENT= Tvheadend PVR addon for Kodi
LICENSE= GPLv2+
-BUILD_DEPENDS= ${LOCALBASE}/lib/kodi/KodiConfig.cmake:multimedia/kodi
+BUILD_DEPENDS= ${LOCALBASE}/include/kodi/libXBMC_addon.h:multimedia/kodi
LIB_DEPENDS= libp8-platform.so:devel/p8-platform \
libkodiplatform.so:devel/kodi-platform
RUN_DEPENDS= kodi:multimedia/kodi
@@ -20,5 +20,6 @@ USES= cmake:noninja
USE_GITHUB= yes
GH_ACCOUNT= kodi-pvr
GH_PROJECT= pvr.hts
+GH_TAGNAME= ${PORTVERSION}-Leia
.include <bsd.port.mk>
diff --git a/multimedia/kodi-addon-pvr-hts/distinfo b/multimedia/kodi-addon-pvr-hts/distinfo
index bbad7678e706..7ff0b90ee868 100644
--- a/multimedia/kodi-addon-pvr-hts/distinfo
+++ b/multimedia/kodi-addon-pvr-hts/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1518117892
-SHA256 (kodi-pvr-pvr.hts-3.4.27_GH0.tar.gz) = 4fb24496622762ea8c894368bdababd2104c5f70978b901b983974ef389b83e1
-SIZE (kodi-pvr-pvr.hts-3.4.27_GH0.tar.gz) = 203508
+TIMESTAMP = 1594907952
+SHA256 (kodi-pvr-pvr.hts-4.4.21-4.4.21-Leia_GH0.tar.gz) = 6958b91ca616554e4c068bc303c66388e9a2c3a68b5979d8918b4e0d7b6bb95c
+SIZE (kodi-pvr-pvr.hts-4.4.21-4.4.21-Leia_GH0.tar.gz) = 162110
diff --git a/multimedia/kodi-addon-pvr-hts/files/patch-src_tvheadend_entity_Event.h b/multimedia/kodi-addon-pvr-hts/files/patch-src_tvheadend_entity_Event.h
new file mode 100644
index 000000000000..ec6116eff2d3
--- /dev/null
+++ b/multimedia/kodi-addon-pvr-hts/files/patch-src_tvheadend_entity_Event.h
@@ -0,0 +1,30 @@
+[ 74%] Building CXX object CMakeFiles/pvr.hts.dir/src/tvheadend/entity/RecordingBase.cpp.o
+/usr/bin/c++ -DADDON_GLOBAL_VERSION_GUI_USED -DADDON_GLOBAL_VERSION_MAIN_USED -DADDON_INSTANCE_VERSION_PVR_USED -DBUILD_KODI_ADDON -DUSE_DEMUX -Dpvr_hts_EXPORTS -I/usr/local/include -I/usr/local/include/kodi -I/usr/local/include/p8-platform -I/usr/home/decke/dev/ports/multimedia/kodi-addon-pvr-hts/work/pvr.hts-4.4.2-Leia/lib -std=c++11 -O2 -pipe -fstack-protector -fno-strict-aliasing -fPIC -D_LINUX -DTARGET_POSIX -DTARGET_FREEBSD -DHAVE_SSE=1 -DHAVE_SSE2=1 -DHAVE_SSE3=1 -DHAVE_SSSE3=1 -DHAVE_SSE4_1=1 -DHAVE_SSE4_2=1 -o CMakeFiles/pvr.hts.dir/src/tvheadend/entity/RecordingBase.cpp.o -c /usr/home/decke/dev/ports/multimedia/kodi-addon-pvr-hts/work/pvr.hts-4.4.2-Leia/src/tvheadend/entity/RecordingBase.cpp
+--- CMakeFiles/pvr.hts.dir/src/tvheadend/entity/Event.cpp.o ---
+In file included from /usr/home/decke/dev/ports/multimedia/kodi-addon-pvr-hts/work/pvr.hts-4.4.2-Leia/src/tvheadend/entity/Event.cpp:22:
+/usr/home/decke/dev/ports/multimedia/kodi-addon-pvr-hts/work/pvr.hts-4.4.2-Leia/src/tvheadend/entity/Event.h:105:7: error: unknown type name 'time_t'
+ time_t GetStart() const { return m_start; }
+ ^
+/usr/home/decke/dev/ports/multimedia/kodi-addon-pvr-hts/work/pvr.hts-4.4.2-Leia/src/tvheadend/entity/Event.h:106:21: error: unknown type name 'time_t'
+ void SetStart(time_t start) { m_start = start; }
+ ^
+/usr/home/decke/dev/ports/multimedia/kodi-addon-pvr-hts/work/pvr.hts-4.4.2-Leia/src/tvheadend/entity/Event.h:108:7: error: unknown type name 'time_t'
+ time_t GetStop() const { return m_stop; }
+ ^
+/usr/home/decke/dev/ports/multimedia/kodi-addon-pvr-hts/work/pvr.hts-4.4.2-Leia/src/tvheadend/entity/Event.h:109:20: error: unknown type name 'time_t'
+ void SetStop(time_t stop) { m_stop = stop; }
+ ^
+/usr/home/decke/dev/ports/multimedia/kodi-addon-pvr-hts/work/pvr.hts-4.4.2-Leia/src/tvheadend/entity/Event.h:117:7: error: unknown type name 'time_t'
+ time_t GetAired() const { return m_aired; }
+
+Submitted by: Bernhard Froehlich <decke@FreeBSD.org>
+--- src/tvheadend/entity/Event.h.orig 2018-10-27 09:20:29 UTC
++++ src/tvheadend/entity/Event.h
+@@ -22,6 +22,7 @@
+ */
+
+ #include "Entity.h"
++#include <sys/types.h>
+ #include <map>
+ #include <vector>
+ #include <cstdint>
diff --git a/multimedia/kodi-addon-pvr-hts/pkg-plist b/multimedia/kodi-addon-pvr-hts/pkg-plist
index 6116dafda37c..c586ed199a7a 100644
--- a/multimedia/kodi-addon-pvr-hts/pkg-plist
+++ b/multimedia/kodi-addon-pvr-hts/pkg-plist
@@ -1,8 +1,7 @@
lib/kodi/addons/pvr.hts/pvr.hts.so
-lib/kodi/addons/pvr.hts/pvr.hts.so.17.6
-lib/kodi/addons/pvr.hts/pvr.hts.so.3.4.27
+lib/kodi/addons/pvr.hts/pvr.hts.so.18.7
+lib/kodi/addons/pvr.hts/pvr.hts.so.4.4.21
share/kodi/addons/pvr.hts/addon.xml
-share/kodi/addons/pvr.hts/addon.xml.in
share/kodi/addons/pvr.hts/changelog.txt
share/kodi/addons/pvr.hts/icon.png
share/kodi/addons/pvr.hts/resources/language/resource.language.af_za/strings.po