aboutsummaryrefslogtreecommitdiff
path: root/multimedia/kodi-addon-pvr.hts
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2021-03-01 08:26:23 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2021-03-01 08:26:23 +0000
commit7a814aa15a9240b2b622db6c91ee318097e30024 (patch)
tree9af19b35b2a5519163522db24d45f858449b1d5a /multimedia/kodi-addon-pvr.hts
parentf7766d8b8eafbc7bbe5ce8f75f86877f20499821 (diff)
downloadports-7a814aa15a9240b2b622db6c91ee318097e30024.tar.gz
ports-7a814aa15a9240b2b622db6c91ee318097e30024.zip
Notes
Diffstat (limited to 'multimedia/kodi-addon-pvr.hts')
-rw-r--r--multimedia/kodi-addon-pvr.hts/Makefile22
-rw-r--r--multimedia/kodi-addon-pvr.hts/distinfo3
-rw-r--r--multimedia/kodi-addon-pvr.hts/files/patch-src_tvheadend_entity_Event.h32
-rw-r--r--multimedia/kodi-addon-pvr.hts/pkg-descr3
4 files changed, 60 insertions, 0 deletions
diff --git a/multimedia/kodi-addon-pvr.hts/Makefile b/multimedia/kodi-addon-pvr.hts/Makefile
new file mode 100644
index 000000000000..02e5b398c51a
--- /dev/null
+++ b/multimedia/kodi-addon-pvr.hts/Makefile
@@ -0,0 +1,22 @@
+# Created by: Bernhard Froehlich <decke@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pvr.hts
+DISTVERSION= 8.2.2
+DISTVERSIONSUFFIX= -Matrix
+PORTREVISION= 1
+CATEGORIES= multimedia
+
+MAINTAINER= decke@FreeBSD.org
+COMMENT= Tvheadend PVR addon for Kodi
+
+LICENSE= GPLv2+
+
+LIB_DEPENDS= libpugixml.so:textproc/pugixml
+
+USES= cmake:noninja compiler:c++17-lang kodi
+
+USE_GITHUB= yes
+GH_ACCOUNT= kodi-pvr
+
+.include <bsd.port.mk>
diff --git a/multimedia/kodi-addon-pvr.hts/distinfo b/multimedia/kodi-addon-pvr.hts/distinfo
new file mode 100644
index 000000000000..344d52234295
--- /dev/null
+++ b/multimedia/kodi-addon-pvr.hts/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1611048574
+SHA256 (kodi-pvr-pvr.hts-8.2.2-Matrix_GH0.tar.gz) = ec291b5717c19dfd639131d195c64043746043d4f85189accaf29e9b1547fbba
+SIZE (kodi-pvr-pvr.hts-8.2.2-Matrix_GH0.tar.gz) = 181445
diff --git a/multimedia/kodi-addon-pvr.hts/files/patch-src_tvheadend_entity_Event.h b/multimedia/kodi-addon-pvr.hts/files/patch-src_tvheadend_entity_Event.h
new file mode 100644
index 000000000000..15d1cdc6171e
--- /dev/null
+++ b/multimedia/kodi-addon-pvr.hts/files/patch-src_tvheadend_entity_Event.h
@@ -0,0 +1,32 @@
+[ 74%] Building CXX object CMakeFiles/pvr.hts.dir/src/tvheadend/entity/RecordingBase.cpp.o
+/usr/bin/c++ -DADDON_GLOBAL_VERSION_GUI_USED -DADDON_GLOBAL_VERSION_MAIN_USED -DADDON_INSTANCE_VERSION_PVR_USED -DBUILD_KODI_ADDON -DUSE_DEMUX -Dpvr_hts_EXPORTS -I/usr/local/include -I/usr/local/include/kodi -I/usr/local/include/p8-platform -I/usr/home/decke/dev/ports/multimedia/kodi-addon-pvr-hts/work/pvr.hts-4.4.2-Leia/lib -std=c++11 -O2 -pipe -fstack-protector -fno-strict-aliasing -fPIC -D_LINUX -DTARGET_POSIX -DTARGET_FREEBSD -DHAVE_SSE=1 -DHAVE_SSE2=1 -DHAVE_SSE3=1 -DHAVE_SSSE3=1 -DHAVE_SSE4_1=1 -DHAVE_SSE4_2=1 -o CMakeFiles/pvr.hts.dir/src/tvheadend/entity/RecordingBase.cpp.o -c /usr/home/decke/dev/ports/multimedia/kodi-addon-pvr-hts/work/pvr.hts-4.4.2-Leia/src/tvheadend/entity/RecordingBase.cpp
+--- CMakeFiles/pvr.hts.dir/src/tvheadend/entity/Event.cpp.o ---
+In file included from /usr/home/decke/dev/ports/multimedia/kodi-addon-pvr-hts/work/pvr.hts-4.4.2-Leia/src/tvheadend/entity/Event.cpp:22:
+/usr/home/decke/dev/ports/multimedia/kodi-addon-pvr-hts/work/pvr.hts-4.4.2-Leia/src/tvheadend/entity/Event.h:105:7: error: unknown type name 'time_t'
+ time_t GetStart() const { return m_start; }
+ ^
+/usr/home/decke/dev/ports/multimedia/kodi-addon-pvr-hts/work/pvr.hts-4.4.2-Leia/src/tvheadend/entity/Event.h:106:21: error: unknown type name 'time_t'
+ void SetStart(time_t start) { m_start = start; }
+ ^
+/usr/home/decke/dev/ports/multimedia/kodi-addon-pvr-hts/work/pvr.hts-4.4.2-Leia/src/tvheadend/entity/Event.h:108:7: error: unknown type name 'time_t'
+ time_t GetStop() const { return m_stop; }
+ ^
+/usr/home/decke/dev/ports/multimedia/kodi-addon-pvr-hts/work/pvr.hts-4.4.2-Leia/src/tvheadend/entity/Event.h:109:20: error: unknown type name 'time_t'
+ void SetStop(time_t stop) { m_stop = stop; }
+ ^
+/usr/home/decke/dev/ports/multimedia/kodi-addon-pvr-hts/work/pvr.hts-4.4.2-Leia/src/tvheadend/entity/Event.h:117:7: error: unknown type name 'time_t'
+ time_t GetAired() const { return m_aired; }
+
+Submitted by: Bernhard Froehlich <decke@FreeBSD.org>
+[ 74%] Building CXX object CMakeFiles/pvr.hts.dir/src/tvheadend/entity/RecordingBase.cpp.o
+/usr/bin/c++ -DADDON_GLOBAL_VERSION_GUI_USED -DADDON_GLOBAL_VERSION_MAIN_USED -DADDON_INSTANCE_VERSION_PVR_USED -DBUILD_KODI_ADDON -DUSE_DEMUX -Dpvr_hts_EXPORTS -I/usr/local/include -I/usr/local/include/kodi -I/usr/local/include/p8-platform -I/usr/home/decke/dev/ports/multimedia/kodi-addon-pvr-hts/work/pvr.hts-4.4.2-Leia/lib -std=c++11 -O2 -pipe -fstack-protector -fno-strict-aliasing -fPIC -D_LINUX -DTARGET_POSIX -DTARGET_FREEBSD -DHAVE_SSE=1 -DHAVE_SSE2=1 -DHAVE_SSE3=1 -DHAVE_SSSE3=1 -DHAVE_SSE4_1=1 -DHAVE_SSE4_2=1 -o CMakeFiles/pvr.hts.dir/src/tvheadend/entity/RecordingBase.cpp.o -c /usr/home/decke/dev/ports/multimedia/kodi-addon-pvr-hts/work/pvr.hts-4.4.2-Leia/src/tvheadend/entity/RecordingBase.cpp
+--- src/tvheadend/entity/Event.h.orig 2020-12-03 21:26:09 UTC
++++ src/tvheadend/entity/Event.h
+@@ -10,6 +10,7 @@
+
+ #include "Entity.h"
+
++#include <sys/types.h>
+ #include <cstdint>
+ #include <map>
+ #include <string>
diff --git a/multimedia/kodi-addon-pvr.hts/pkg-descr b/multimedia/kodi-addon-pvr.hts/pkg-descr
new file mode 100644
index 000000000000..941944b2906d
--- /dev/null
+++ b/multimedia/kodi-addon-pvr.hts/pkg-descr
@@ -0,0 +1,3 @@
+This is a Kodi PVR addon for connecting to a tvheadend backend.
+
+WWW: https://github.com/kodi-pvr/pvr.hts