aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libbdplus
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2021-01-01 16:10:08 +0000
committerKurt Jaeger <pi@FreeBSD.org>2021-01-01 16:10:08 +0000
commit2ebea84c2409d67b11d51dc1243aed313e9dbe05 (patch)
tree168bab7bd33f1d81e4d0923a00f112b1c0206cb6 /multimedia/libbdplus
parent9d4f3646ae718df7177c2eb88aa4b8e392b6e499 (diff)
downloadports-2ebea84c2409d67b11d51dc1243aed313e9dbe05.tar.gz
ports-2ebea84c2409d67b11d51dc1243aed313e9dbe05.zip
Notes
Diffstat (limited to 'multimedia/libbdplus')
-rw-r--r--multimedia/libbdplus/Makefile16
-rw-r--r--multimedia/libbdplus/files/patch-configure.ac13
2 files changed, 21 insertions, 8 deletions
diff --git a/multimedia/libbdplus/Makefile b/multimedia/libbdplus/Makefile
index 6f2af5c51ed1..f9dee8a5393c 100644
--- a/multimedia/libbdplus/Makefile
+++ b/multimedia/libbdplus/Makefile
@@ -2,24 +2,24 @@
# $FreeBSD$
PORTNAME= libbdplus
-PORTVERSION= 0.1.2
+DISTVERSION= 0.1.2
+PORTREVISION= 1
CATEGORIES= multimedia
-MASTER_SITES= ftp://ftp.videolan.org/pub/videolan/${PORTNAME}/${PORTVERSION}/ \
- http://blu.opsec.eu/
+MASTER_SITES= https://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION}/
MAINTAINER= ports@FreeBSD.org
COMMENT= BD+ System research implementation
LICENSE= LGPL21
-LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
+LIB_DEPENDS= libaacs.so:multimedia/libaacs \
+ libgcrypt.so:security/libgcrypt \
libgpg-error.so:security/libgpg-error
+USES= autoreconf libtool pkgconfig tar:bzip2
USE_LDCONFIG= yes
-USES= autoreconf tar:bzip2 pkgconfig libtool
-CONFIGURE_ARGS= --without-libaacs
-
-.include "${.CURDIR}/../libbluray/Makefile.include"
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-optimizations
.include <bsd.port.mk>
diff --git a/multimedia/libbdplus/files/patch-configure.ac b/multimedia/libbdplus/files/patch-configure.ac
new file mode 100644
index 000000000000..a7d2271e073e
--- /dev/null
+++ b/multimedia/libbdplus/files/patch-configure.ac
@@ -0,0 +1,13 @@
+--- configure.ac.orig 2020-11-09 02:33:57 UTC
++++ configure.ac
+@@ -168,10 +168,6 @@ CC_CHECK_CFLAGS_APPEND([-Wall -Wdisabled-optimization
+ [-Wredundant-decls -Wcast-qual -Wwrite-strings -Wtype-limits -Wundef ]dnl
+ [-Wmissing-prototypes -Wshadow])
+
+-CC_CHECK_CFLAGS_APPEND([-Werror=implicit-function-declaration ]dnl
+- [-Werror-implicit-function-declaration],
+- [break;])
+-
+ CC_CHECK_WERROR
+ AS_IF([test "x$enable_werror" = "xyes"], [
+ CFLAGS="${CFLAGS} $cc_cv_werror"