aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libdv
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2006-12-15 13:29:55 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2006-12-15 13:29:55 +0000
commitbf8d6821972a0ad863846d8de60ed9979c21eab4 (patch)
tree5659873c238a9964f6068ff246c6edfe487de264 /multimedia/libdv
parent1aa27e0a632768c41f261353039f29c1aba5e5f9 (diff)
downloadports-bf8d6821972a0ad863846d8de60ed9979c21eab4.tar.gz
ports-bf8d6821972a0ad863846d8de60ed9979c21eab4.zip
Respect PTHREAD_LIBS.
Notes
Notes: svn path=/head/; revision=179854
Diffstat (limited to 'multimedia/libdv')
-rw-r--r--multimedia/libdv/Makefile4
-rw-r--r--multimedia/libdv/files/patch-configure11
2 files changed, 15 insertions, 0 deletions
diff --git a/multimedia/libdv/Makefile b/multimedia/libdv/Makefile
index 8d0e82611d45..fe8acad91efc 100644
--- a/multimedia/libdv/Makefile
+++ b/multimedia/libdv/Makefile
@@ -88,6 +88,10 @@ post-patch:
@${REINPLACE_CMD} -E -e 's|(@REQUIRES_NOPKGCONFIG@)|-L${LOCALBASE}/include \1|' \
${WRKSRC}/libdv.pc.in
+pre-configure:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' \
+ ${WRKSRC}/configure
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/multimedia/libdv/files/patch-configure b/multimedia/libdv/files/patch-configure
new file mode 100644
index 000000000000..15393bab6bee
--- /dev/null
+++ b/multimedia/libdv/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Tue Nov 30 12:23:44 2004
++++ configure Sun Dec 10 04:22:48 2006
+@@ -20393,8 +20393,6 @@
+ # FreeBSD and OpenBSD have neither -lpthread nor integrated pthreads in libc.
+ # Instead -pthread is used to the compiler/linker to get pthreads working right.
+ if test x$OS_ARCH = xFreeBSD -o x$OS_ARCH = xOpenBSD; then
+- CFLAGS="$CFLAGS -pthread"
+- CXXFLAGS="$CXXFLAGS -pthread"
+ fi
+
+