aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libdvbpsi/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2008-02-28 00:40:55 +0000
committerMichael Johnson <ahze@FreeBSD.org>2008-02-28 00:40:55 +0000
commit9867427822c2aa0b4f4539214c913f8171269c43 (patch)
tree3bca03b18c340c5dbde87023d2c0d2e233a37b83 /multimedia/libdvbpsi/Makefile
parent69a6952cb217b44d746701e8cafd4346f3f4b813 (diff)
downloadports-9867427822c2aa0b4f4539214c913f8171269c43.tar.gz
ports-9867427822c2aa0b4f4539214c913f8171269c43.zip
Notes
Diffstat (limited to 'multimedia/libdvbpsi/Makefile')
-rw-r--r--multimedia/libdvbpsi/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/multimedia/libdvbpsi/Makefile b/multimedia/libdvbpsi/Makefile
index 59cd83a92185..06dfe9e59cdc 100644
--- a/multimedia/libdvbpsi/Makefile
+++ b/multimedia/libdvbpsi/Makefile
@@ -7,24 +7,32 @@
#
PORTNAME= libdvbpsi
-PORTVERSION= 0.1.5
-PORTREVISION= 1
+PORTVERSION= 0.1.6
CATEGORIES= multimedia
MASTER_SITES= http://download.videolan.org/pub/videolan/libdvbpsi/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION}
-DISTNAME= ${PORTNAME}4-${PORTVERSION}
+DISTNAME= ${PORTNAME}5-${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
COMMENT= A library for MPEG TS and DVB PSI tables decoding and generation
+USE_DOS2UNIX= yes
+USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --enable-release
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS= --enable-debug
+.else
+CONFIGURE_ARGS= --enable-release
+.endif
USE_LDCONFIG= yes
post-patch:
@${REINPLACE_CMD} -e 's|-Wall|$${CFLAGS}|g ; \
s|-O6||g' ${WRKSRC}/configure
+regression-test:
+ @(cd ${WRKSRC}/misc && ./test_dr)
+
.include <bsd.port.mk>