aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libdvbpsi/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-04-04 01:32:05 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-04-04 01:32:05 +0000
commitf09bedf830ca743e16d4de097ec5951c69afc576 (patch)
treef119a4026e1f96e539cfeec6becfeeeab2447bd8 /multimedia/libdvbpsi/Makefile
parent7377d958bf5286ae4404d95b5b042453c1c566c0 (diff)
downloadports-f09bedf830ca743e16d4de097ec5951c69afc576.tar.gz
ports-f09bedf830ca743e16d4de097ec5951c69afc576.zip
o Repo copy move special case. Background and methodology follows:
- In the past, this port was incorrectly added to multimedia category even though it already existed in graphics category. Therefore, it was removed. - Now, this port is being moved to multimedia category since it should reside there. However, we cannot do the usual repo copy since there are repo histories in both categories. - What to do? 1) 'cvs checkout' both the graphics and the multimedia versions of the port. 2) 'cp' copy the files from the graphics version to the multimedia one. 3) 'cvs commit' the copied version from graphics with a long commit message explaining the situation o Appropriately update dependency references from graphics to multimedia category Port creator: ijlao Date created: Aug 8, 2002
Notes
Notes: svn path=/head/; revision=78073
Diffstat (limited to 'multimedia/libdvbpsi/Makefile')
-rw-r--r--multimedia/libdvbpsi/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/multimedia/libdvbpsi/Makefile b/multimedia/libdvbpsi/Makefile
new file mode 100644
index 000000000000..745b400292e1
--- /dev/null
+++ b/multimedia/libdvbpsi/Makefile
@@ -0,0 +1,21 @@
+# ex:ts=8
+# Ports collection makefile for: libdvbpsi
+# Date created: Aug 8, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdvbpsi
+PORTVERSION= 0.1.2
+CATEGORIES= multimedia
+MASTER_SITES= http://www.videolan.org/pub/videolan/libdvbpsi/${PORTVERSION}/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A library for MPEG TS and DVB PSI tables decoding and generation
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-release
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>