aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libdvdcss
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-11-27 20:25:07 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-11-27 20:25:07 +0000
commitefa3c5a59a58e973b3cfd056a729035078ea2cba (patch)
treedd982728ac8babd85ecba20b6f78a849ba93f6af /multimedia/libdvdcss
parent4931d8baa1898bc3cd6f0e0844bfb94c0bfeeda6 (diff)
downloadports-efa3c5a59a58e973b3cfd056a729035078ea2cba.tar.gz
ports-efa3c5a59a58e973b3cfd056a729035078ea2cba.zip
Notes
Diffstat (limited to 'multimedia/libdvdcss')
-rw-r--r--multimedia/libdvdcss/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/multimedia/libdvdcss/Makefile b/multimedia/libdvdcss/Makefile
index 942626e07f75..9b4d5616b2c0 100644
--- a/multimedia/libdvdcss/Makefile
+++ b/multimedia/libdvdcss/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libdvdcss
PORTVERSION= 1.2.9
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://download.videolan.org/pub/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
@@ -23,7 +24,31 @@ USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
+.ifndef(NOPORTDOCS)
+BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+
+PORTDOCS= *
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/src/ioctl.c
+# should we disable doc building?
+.ifdef(NOPORTDOCS)
+ @${REINPLACE_CMD} -E \
+ -e 's|^([[:space:]]*SUBDIRS[[:space:]]*=.*)doc|\1|' \
+ ${BUILD_WRKSRC}/Makefile.in
+.else
+# we do not want the latex documents... too many dependencies just
+# to get something in ps we already have get as html
+ @${REINPLACE_CMD} -E \
+ -e 's|^([[:space:]]*all:[[:space:]]*.*)stamp-latex|\1|' \
+ ${BUILD_WRKSRC}/doc/Makefile.in
+.endif
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${INSTALL_WRKSRC}/doc/html/* ${DOCSDIR}
+.endif
.include <bsd.port.mk>