aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libdvdnav
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2012-01-17 14:35:18 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2012-01-17 14:35:18 +0000
commita6a77bf4294bdcf786389dc6e51e5509d7094265 (patch)
tree356b0ef2ccd7c23e99ab52fd69755ad976e9eb1c /multimedia/libdvdnav
parentdbfad2c362c834bfaa5d2430c5dcb296f2c0d843 (diff)
downloadports-a6a77bf4294bdcf786389dc6e51e5509d7094265.tar.gz
ports-a6a77bf4294bdcf786389dc6e51e5509d7094265.zip
- Update libdvdread and libdvdnav to 4.2.0 and bump dependent ports' revisions
- libdvdread: allow package building with libdvdcss if WITH_DVDCSS is set [1] - libdvdread/libdvdnav: fix endianness handling [2] Submitted by: olgeni [1], richo <richo@psych0tik.net> [2] (via mail to ports@) PR: ports/162197 [1]
Notes
Notes: svn path=/head/; revision=289371
Diffstat (limited to 'multimedia/libdvdnav')
-rw-r--r--multimedia/libdvdnav/Makefile16
-rw-r--r--multimedia/libdvdnav/distinfo4
-rw-r--r--multimedia/libdvdnav/files/patch-configure236
-rw-r--r--multimedia/libdvdnav/pkg-descr2
-rw-r--r--multimedia/libdvdnav/pkg-plist4
5 files changed, 43 insertions, 19 deletions
diff --git a/multimedia/libdvdnav/Makefile b/multimedia/libdvdnav/Makefile
index d8f646939a7b..fe32531a2d44 100644
--- a/multimedia/libdvdnav/Makefile
+++ b/multimedia/libdvdnav/Makefile
@@ -6,26 +6,20 @@
#
PORTNAME= libdvdnav
-PORTVERSION= 4.1.4.r1219
+PORTVERSION= 4.2.0
CATEGORIES= multimedia
# Svn repository URL : svn://svn.mplayerhq.hu/dvdnav/trunk/libdvdnav
-MASTER_SITES= http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
- http://www1.mplayerhq.hu/MPlayer/releases/dvdnav/ \
- http://www2.mplayerhq.hu/MPlayer/releases/dvdnav/ \
- http://www3.mplayerhq.hu/MPlayer/releases/dvdnav/ \
- http://www4.mplayerhq.hu/MPlayer/releases/dvdnav/ \
- http://www5.mplayerhq.hu/MPlayer/releases/dvdnav/ \
- ftp://ftp1.mplayerhq.hu/MPlayer/releases/dvdnav/ \
- ftp://ftp2.mplayerhq.hu/MPlayer/releases/dvdnav/ \
+MASTER_SITES= http://dvdnav.mplayerhq.hu/releases/ \
+ http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
LOCAL/martymac
MAINTAINER= martymac@FreeBSD.org
COMMENT= MPlayer version of the libdvdnav project
-LIB_DEPENDS= dvdread.4:${PORTSDIR}/multimedia/libdvdread
-
LICENSE= GPLv2
+LIB_DEPENDS= dvdread.4:${PORTSDIR}/multimedia/libdvdread
+
USE_BZIP2= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure2
diff --git a/multimedia/libdvdnav/distinfo b/multimedia/libdvdnav/distinfo
index f4765f3edef1..2f6a6fadbead 100644
--- a/multimedia/libdvdnav/distinfo
+++ b/multimedia/libdvdnav/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libdvdnav-4.1.4.r1219.tar.bz2) = 4b7ce48e9942396f2f38f89ef5988cb1b514449a163d457a950aa216a4f321c6
-SIZE (libdvdnav-4.1.4.r1219.tar.bz2) = 111248
+SHA256 (libdvdnav-4.2.0.tar.bz2) = 8c971b08276c89ddcecd26fc44204460fd250dc57346f03476d3077188c47550
+SIZE (libdvdnav-4.2.0.tar.bz2) = 111575
diff --git a/multimedia/libdvdnav/files/patch-configure2 b/multimedia/libdvdnav/files/patch-configure2
index ba3a3da1cb93..41cc86591280 100644
--- a/multimedia/libdvdnav/files/patch-configure2
+++ b/multimedia/libdvdnav/files/patch-configure2
@@ -1,5 +1,5 @@
---- configure2.orig 2010-09-06 11:37:21.000000000 +0000
-+++ configure2 2010-09-07 12:58:47.440053134 +0000
+--- configure2.orig 2011-10-07 22:20:59.000000000 +0200
++++ configure2 2011-12-12 19:00:42.610336614 +0100
@@ -26,6 +26,7 @@
echo " --help print this message"
echo " --prefix=PREFIX install in PREFIX [$PREFIX]"
@@ -29,7 +29,24 @@
test -z "$shlibdir" && shlibdir=$PREFIX/lib
test -z "$incdir" && incdir=$PREFIX/include/dvdnav
-@@ -127,6 +131,7 @@
+@@ -123,10 +127,24 @@
+ ;;
+ esac
+
++echo -n "Checking if we're big-endian... "
++bigendian=no
++TMPD=`mktemp -d temp.XXXX`
++TMPC=$TMPD/endian.c
++TMPO=$TMPD/endian.o
++cat > $TMPC <<EOF
++unsigned int endian = 'B' << 24 | 'I' << 16 | 'G' << 8 | 'E';
++EOF
++$cc $optimizations $cflags -c -o $TMPO $TMPC
++od -A n -t x1 $TMPO | grep -q '42 *49 *47 *45' && bigendian=yes
++rm -rf $TMPD
++echo "$bigendian"
++
+ cat > config.mak << EOF
# Automatically generated by configure, do not edit
PREFIX=$PREFIX
libdir=$libdir
@@ -37,3 +54,16 @@
shlibdir=$shlibdir
incdir=$incdir
THREADLIB=$threadlib
+@@ -153,6 +171,12 @@
+ /* Automatically generated by configure, do not edit */
+ #include "version.h"
+ EOF
++if test "$bigendian" = "yes"
++then
++ echo "#define WORDS_BIGENDIAN" >> config.h
++else
++ echo "#undef WORDS_BIGENDIAN" >> config.h
++fi
+
+ # build tree in object directory if source path is different from current one
+ if test "$source_path_used" != "no"; then
diff --git a/multimedia/libdvdnav/pkg-descr b/multimedia/libdvdnav/pkg-descr
index 34c2ba95c64e..bd4e8398da49 100644
--- a/multimedia/libdvdnav/pkg-descr
+++ b/multimedia/libdvdnav/pkg-descr
@@ -1,3 +1,3 @@
Mplayer version of the libdvdnav project.
-WWW: http://www.mplayerhq.hu/MPlayer/releases/dvdnav
+WWW: http://dvdnav.mplayerhq.hu
diff --git a/multimedia/libdvdnav/pkg-plist b/multimedia/libdvdnav/pkg-plist
index 07376804933e..4ea23a65a989 100644
--- a/multimedia/libdvdnav/pkg-plist
+++ b/multimedia/libdvdnav/pkg-plist
@@ -5,10 +5,10 @@ include/dvdnav/dvdnav_events.h
lib/libdvdnav.a
lib/libdvdnav.so
lib/libdvdnav.so.4
-lib/libdvdnav.so.4.1.4
+lib/libdvdnav.so.4.2.0
lib/libdvdnavmini.so
lib/libdvdnavmini.so.4
-lib/libdvdnavmini.so.4.1.4
+lib/libdvdnavmini.so.4.2.0
libdata/pkgconfig/dvdnav.pc
libdata/pkgconfig/dvdnavmini.pc
@dirrm include/dvdnav