aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libdvdread
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2009-04-27 17:54:33 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2009-04-27 17:54:33 +0000
commit0bd2f6ce4c74566a5d23ceff8e63e8e8a82d9a98 (patch)
treeb778532b446ffef8b6104f060f961d52c2e092a6 /multimedia/libdvdread
parent2f3fa0d7bc6bd24081ca59303d667c66b965455a (diff)
downloadports-0bd2f6ce4c74566a5d23ceff8e63e8e8a82d9a98.tar.gz
ports-0bd2f6ce4c74566a5d23ceff8e63e8e8a82d9a98.zip
Restore functionaity to read encrypted DVDs.
PR: ports/134016 Approved by: linimon (mentor)
Notes
Notes: svn path=/head/; revision=232868
Diffstat (limited to 'multimedia/libdvdread')
-rw-r--r--multimedia/libdvdread/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/multimedia/libdvdread/Makefile b/multimedia/libdvdread/Makefile
index 18fccbd9e7a6..ed0df20bad44 100644
--- a/multimedia/libdvdread/Makefile
+++ b/multimedia/libdvdread/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libdvdread
PORTVERSION= 4.1.3
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/dvdnav/ \
http://www2.mplayerhq.hu/MPlayer/releases/dvdnav/ \
@@ -19,6 +20,10 @@ MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/dvdnav/ \
MAINTAINER= ganael.laplanche@martymac.com
COMMENT= MPlayer version of the libdvdread project
+.if !defined(PACKAGE_BUILDING)
+LIB_DEPENDS= dvdcss.${DVDCSS_LIBVERSION}:${PORTSDIR}/multimedia/libdvdcss
+.endif
+
USE_BZIP2= yes
CFLAGS+= "-I${LOCALBASE}/include"
LDFLAGS+= "-L${LOCALBASE}/lib"
@@ -36,8 +41,13 @@ CONFIGURE_ARGS= --prefix="${PREFIX}" \
USE_GMAKE= yes
USE_LDCONFIG= yes
+# DVDCSS version hardcoded in src/dvd_input.c (dlopen'ed)
+DVDCSS_LIBVERSION= 3
+
post-patch:
@${REINPLACE_CMD} -e 's|-ldl ||g' \
${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -E -e 's|(libdvdcss.so)\.2|\1.${DVDCSS_LIBVERSION}|' \
+ ${WRKSRC}/src/dvd_input.c
.include <bsd.port.mk>