aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libdvdread
diff options
context:
space:
mode:
authorJeremy Chadwick <koitsu@FreeBSD.org>2007-04-05 06:03:23 +0000
committerJeremy Chadwick <koitsu@FreeBSD.org>2007-04-05 06:03:23 +0000
commit1e44513898ab8e0a97280fa2d23263766ef802b1 (patch)
tree688e1319d72808589b85fb866f27d0757b170860 /multimedia/libdvdread
parent4648fe11769f62d945328c879370c80bd79bd1b4 (diff)
downloadports-1e44513898ab8e0a97280fa2d23263766ef802b1.tar.gz
ports-1e44513898ab8e0a97280fa2d23263766ef802b1.zip
* libdvdread - PORTREVISION increment
* libdvdread - add patch for including <stdlib.h> in dvdread/ifo_types.h * Others - LIB_DEPENDS changes (require libdvdread.so.5) * Others - PORTREVISION increment for those dependent on libdvdread Approved by: philip
Notes
Notes: svn path=/head/; revision=189250
Diffstat (limited to 'multimedia/libdvdread')
-rw-r--r--multimedia/libdvdread/Makefile2
-rw-r--r--multimedia/libdvdread/files/patch-dvdread-ifo_types.h15
2 files changed, 16 insertions, 1 deletions
diff --git a/multimedia/libdvdread/Makefile b/multimedia/libdvdread/Makefile
index 1d50f16bb878..aa603e59db76 100644
--- a/multimedia/libdvdread/Makefile
+++ b/multimedia/libdvdread/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libdvdread
PORTVERSION= 0.9.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= http://www.dtek.chalmers.se/groups/dvd/dist/
diff --git a/multimedia/libdvdread/files/patch-dvdread-ifo_types.h b/multimedia/libdvdread/files/patch-dvdread-ifo_types.h
new file mode 100644
index 000000000000..3ac3b5737be9
--- /dev/null
+++ b/multimedia/libdvdread/files/patch-dvdread-ifo_types.h
@@ -0,0 +1,15 @@
+--- dvdread/ifo_types.h.orig Thu Mar 2 17:25:43 2006
++++ dvdread/ifo_types.h Wed Apr 4 20:07:32 2007
+@@ -29,7 +29,11 @@
+ #endif
+ #else
+ #if !defined(UINT8_MAX) || !defined(UINT16_MAX) || !defined(INT32_MAX)
+-#error "Must include <inttypes.h> or <stdint.h> before any libdvdread header."
++#if !defined(_SYS_STDINT_H_) || !defined(_INTTYPES_H_)
++#include <stdint.h>
++#else
++#error "UINT8_MAX, UINT16_MAX, or INT32_MAX are missing from <stdint.h> or <inttypes.h>."
++#endif
+ #endif
+ #endif
+