aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libdvdread
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2020-03-27 11:23:42 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2020-03-27 11:23:42 +0000
commit3e1e618952fa936f730e4734161f8d67e4c0d9ff (patch)
tree61e324829550480270b9dfb44bf6435290f6f6d7 /multimedia/libdvdread
parente25425942b0c7392a8ca0e8b0cee44cee5bae6b2 (diff)
downloadports-3e1e618952fa936f730e4734161f8d67e4c0d9ff.tar.gz
ports-3e1e618952fa936f730e4734161f8d67e4c0d9ff.zip
Update multimedia/libdvdread and multimedia/libdvdnav to 6.1.0
Changelogs are available here: https://code.videolan.org/videolan/libdvdread/-/blob/master/NEWS https://code.videolan.org/videolan/libdvdnav/-/blob/master/ChangeLog Also, bump dependent ports' revisions and mark sysutils/dvdbackup as BROKEN [1] Approved by: ehaupt [1]
Notes
Notes: svn path=/head/; revision=529240
Diffstat (limited to 'multimedia/libdvdread')
-rw-r--r--multimedia/libdvdread/Makefile2
-rw-r--r--multimedia/libdvdread/distinfo6
-rw-r--r--multimedia/libdvdread/files/patch-src-dvd_reader.c22
-rw-r--r--multimedia/libdvdread/files/patch-src-dvdread-ifo_types.h4
-rw-r--r--multimedia/libdvdread/pkg-plist2
5 files changed, 17 insertions, 19 deletions
diff --git a/multimedia/libdvdread/Makefile b/multimedia/libdvdread/Makefile
index 73b257446bbd..137cb6b34284 100644
--- a/multimedia/libdvdread/Makefile
+++ b/multimedia/libdvdread/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libdvdread
-PORTVERSION= 6.0.2
+PORTVERSION= 6.1.0
CATEGORIES= multimedia
MASTER_SITES= http://download.videolan.org/pub/videolan/libdvdread/${PORTVERSION}/ \
http://dvdnav.mplayerhq.hu/releases/ \
diff --git a/multimedia/libdvdread/distinfo b/multimedia/libdvdread/distinfo
index 16f899de2bca..acd75218e8f5 100644
--- a/multimedia/libdvdread/distinfo
+++ b/multimedia/libdvdread/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1571085572
-SHA256 (libdvdread-6.0.2.tar.bz2) = f91401af213b219cdde24b46c50a57f29301feb7f965678f1d7ed4632cc6feb0
-SIZE (libdvdread-6.0.2.tar.bz2) = 405298
+TIMESTAMP = 1584981910
+SHA256 (libdvdread-6.1.0.tar.bz2) = 501bbd7d1e7d5f2d2a0ff8d0a6ac2fbd7e5e7e0e80ef82fef818f43a30b4750c
+SIZE (libdvdread-6.1.0.tar.bz2) = 391316
diff --git a/multimedia/libdvdread/files/patch-src-dvd_reader.c b/multimedia/libdvdread/files/patch-src-dvd_reader.c
index 603782febd8d..3bca4c7dd538 100644
--- a/multimedia/libdvdread/files/patch-src-dvd_reader.c
+++ b/multimedia/libdvdread/files/patch-src-dvd_reader.c
@@ -3,7 +3,7 @@ Use statfs() instead of getfsfile() to get device name from a mount point.
(getfsfile() requires an entry in the fstab file which is often not the case
for removable media)
---- src/dvd_reader.c.orig 2018-01-17 21:35:39 UTC
+--- src/dvd_reader.c.orig 2020-03-04 18:57:19 UTC
+++ src/dvd_reader.c
@@ -64,7 +64,7 @@ static inline int _private_gettimeofday( struct timeva
# include <sys/ucred.h>
@@ -14,36 +14,34 @@ for removable media)
#elif defined(__linux__)
# include <mntent.h>
# include <paths.h>
-@@ -420,7 +420,7 @@ static dvd_reader_t *DVDOpenCommon( const char *ppath,
+@@ -435,7 +435,7 @@ static dvd_reader_t *DVDOpenCommon( void *priv,
+ return ctx;
} else if( S_ISDIR( fileinfo.st_mode ) ) {
- dvd_reader_t *auth_drive = 0;
#if defined(SYS_BSD)
- struct fstab* fe;
+ struct statfs fs;
#elif defined(__sun) || defined(__linux__)
FILE *mntfile;
#endif
-@@ -511,14 +511,16 @@ static dvd_reader_t *DVDOpenCommon( const char *ppath,
+@@ -525,13 +525,15 @@ static dvd_reader_t *DVDOpenCommon( void *priv,
}
}
#elif defined(SYS_BSD)
- if( ( fe = getfsfile( path_copy ) ) ) {
- dev_name = bsd_block2char( fe->fs_spec );
-- fprintf( stderr,
-- "libdvdread: Attempting to use device %s"
-- " mounted on %s for CSS authentication\n",
+- Log3(ctx, "Attempting to use device %s"
+- " mounted on %s for CSS authentication",
- dev_name,
- fe->fs_file );
-- auth_drive = DVDOpenImageFile( dev_name, NULL, NULL, have_css );
+- ctx->rd = DVDOpenImageFile( ctx, dev_name, NULL, have_css );
+ if( statfs( path_copy, &fs ) == 0 ) {
+ if( !strcmp( path_copy, fs.f_mntonname ) ) {
+ dev_name = bsd_block2char( fs.f_mntfromname );
-+ fprintf( stderr,
-+ "libdvdread: Attempting to use device %s"
-+ " mounted on %s for CSS authentication\n",
++ Log3(ctx, "Attempting to use device %s"
++ " mounted on %s for CSS authentication",
+ dev_name,
+ fs.f_mntonname );
-+ auth_drive = DVDOpenImageFile( dev_name, NULL, NULL, have_css );
++ ctx->rd = DVDOpenImageFile( ctx, dev_name, NULL, have_css );
+ }
}
#elif defined(__sun)
diff --git a/multimedia/libdvdread/files/patch-src-dvdread-ifo_types.h b/multimedia/libdvdread/files/patch-src-dvdread-ifo_types.h
index 1ba380740197..4a60adca2dc8 100644
--- a/multimedia/libdvdread/files/patch-src-dvdread-ifo_types.h
+++ b/multimedia/libdvdread/files/patch-src-dvdread-ifo_types.h
@@ -1,5 +1,5 @@
---- src/dvdread/ifo_types.h.orig 2015-06-27 19:35:59.043370000 +0200
-+++ src/dvdread/ifo_types.h 2015-06-27 19:37:10.885577000 +0200
+--- src/dvdread/ifo_types.h.orig 2020-03-04 18:57:19 UTC
++++ src/dvdread/ifo_types.h
@@ -32,7 +32,7 @@
#if defined(__GNUC__)
diff --git a/multimedia/libdvdread/pkg-plist b/multimedia/libdvdread/pkg-plist
index f6a4f2f3ebb5..f6bcab6d807e 100644
--- a/multimedia/libdvdread/pkg-plist
+++ b/multimedia/libdvdread/pkg-plist
@@ -11,5 +11,5 @@ include/dvdread/version.h
lib/libdvdread.a
lib/libdvdread.so
lib/libdvdread.so.7
-lib/libdvdread.so.7.0.0
+lib/libdvdread.so.7.1.0
libdata/pkgconfig/dvdread.pc