aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libopenshot
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-01-07 17:47:18 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-01-07 17:47:18 +0000
commit52c85878cec344967d0d6644030520e209e35572 (patch)
tree530e4d2a17a94b24a047f8be4b3b81b9187be323 /multimedia/libopenshot
parent6b56c042431b91682de9931f4a4d8845978f2c0a (diff)
downloadports-52c85878cec344967d0d6644030520e209e35572.tar.gz
ports-52c85878cec344967d0d6644030520e209e35572.zip
multimedia/libopenshot: update to 0.2.3.595
PR: 242930 Submitted by: tatsuki_makino@hotmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=522347
Diffstat (limited to 'multimedia/libopenshot')
-rw-r--r--multimedia/libopenshot/Makefile19
-rw-r--r--multimedia/libopenshot/distinfo6
-rw-r--r--multimedia/libopenshot/files/patch-src_CMakeLists.txt12
-rw-r--r--multimedia/libopenshot/files/patch-src_FFmpegReader.cpp2
-rw-r--r--multimedia/libopenshot/files/patch-src_FFmpegWriter.cpp10
-rw-r--r--multimedia/libopenshot/pkg-message12
6 files changed, 42 insertions, 19 deletions
diff --git a/multimedia/libopenshot/Makefile b/multimedia/libopenshot/Makefile
index 7f424b234336..f58dc3e86260 100644
--- a/multimedia/libopenshot/Makefile
+++ b/multimedia/libopenshot/Makefile
@@ -2,8 +2,8 @@
PORTNAME= libopenshot
DISTVERSIONPREFIX= v
-DISTVERSION= 0.2.3-490
-DISTVERSIONSUFFIX= -gc271352
+DISTVERSION= 0.2.3-595
+DISTVERSIONSUFFIX= -ga1158ee
CATEGORIES= multimedia
MAINTAINER= tatsuki_makino@hotmail.com
@@ -17,7 +17,6 @@ BUILD_DEPENDS= swig3.0:devel/swig30 \
${LOCALBASE}/include/zmq.hpp:net/cppzmq
LIB_DEPENDS= libopenshot-audio.so:audio/libopenshot-audio \
libjsoncpp.so:devel/jsoncpp \
- libomp.so:devel/openmp \
libzmq.so:net/libzmq4
USES= cmake compiler:c++11-lang pkgconfig python:3.5+ qt:5
@@ -30,13 +29,25 @@ USE_QT= core gui network multimedia widgets qmake_build buildtools_build
CMAKE_ON= USE_SYSTEM_JSONCPP DISABLE_BUNDLED_JSONCPP\
DISABLE_TESTS\
CMAKE_DISABLE_FIND_PACKAGE_Doxygen\
- CMAKE_DISABLE_FIND_PACKAGE_ImageMagick\
CMAKE_DISABLE_FIND_PACKAGE_RESVG\
CMAKE_DISABLE_FIND_PACKAGE_Ruby
+CMAKE_ARGS= -DCMAKE_DISABLE_FIND_PACKAGE_ImageMagick:BOOL=ON
OPTIONS_DEFAULT= FFMPEG
+OPTIONS_RADIO= IMAGEMAGICK
+OPTIONS_RADIO_IMAGEMAGICK= IMAGEMAGICK6 IMAGEMAGICK7
OPTIONS_SINGLE= LIBAVCODEC
OPTIONS_SINGLE_LIBAVCODEC= FFMPEG LIBAV
FFMPEG_LIB_DEPENDS= libavformat.so:multimedia/ffmpeg
+IMAGEMAGICK6_DESC= with ImageMagick6
+IMAGEMAGICK6_LIB_DEPENDS= libMagick++-6.so:graphics/ImageMagick6
+IMAGEMAGICK6_CMAKE_ON= -DCMAKE_DISABLE_FIND_PACKAGE_ImageMagick:BOOL=NO
+IMAGEMAGICK7_DESC= with ImageMagick7
+IMAGEMAGICK7_LIB_DEPENDS= libMagick++-7.so:graphics/ImageMagick7
+IMAGEMAGICK7_CMAKE_ON= -DCMAKE_DISABLE_FIND_PACKAGE_ImageMagick:BOOL=NO
LIBAV_LIB_DEPENDS= libavformat.so:multimedia/libav
+.if !exists(/usr/lib/libomp.so)
+LIB_DEPENDS+= libomp.so:devel/openmp
+.endif
+
.include <bsd.port.mk>
diff --git a/multimedia/libopenshot/distinfo b/multimedia/libopenshot/distinfo
index 409a586a564c..ae03beb1037a 100644
--- a/multimedia/libopenshot/distinfo
+++ b/multimedia/libopenshot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1573527600
-SHA256 (OpenShot-libopenshot-v0.2.3-490-gc271352_GH0.tar.gz) = f996b0f36311306e51eabebdc1dc11ee82986c3a98a0d631b9cfbba64b908965
-SIZE (OpenShot-libopenshot-v0.2.3-490-gc271352_GH0.tar.gz) = 10290775
+TIMESTAMP = 1577502000
+SHA256 (OpenShot-libopenshot-v0.2.3-595-ga1158ee_GH0.tar.gz) = b924dea93cfe4cf067ea1beba76ad1c57a385531b92d221de5e4da35111213e7
+SIZE (OpenShot-libopenshot-v0.2.3-595-ga1158ee_GH0.tar.gz) = 10290486
diff --git a/multimedia/libopenshot/files/patch-src_CMakeLists.txt b/multimedia/libopenshot/files/patch-src_CMakeLists.txt
index f2adad39bc6e..7dd19fb609db 100644
--- a/multimedia/libopenshot/files/patch-src_CMakeLists.txt
+++ b/multimedia/libopenshot/files/patch-src_CMakeLists.txt
@@ -1,6 +1,6 @@
---- src/CMakeLists.txt.orig 2019-11-04 12:14:04 UTC
+--- src/CMakeLists.txt.orig 2019-12-19 13:04:31 UTC
+++ src/CMakeLists.txt
-@@ -340,6 +340,11 @@ if (TARGET cppzmq)
+@@ -358,6 +358,11 @@ if (TARGET cppzmq)
endif()
@@ -10,9 +10,9 @@
+endif(NOT EXECINFO_LIBRARY)
+
############### LINK LIBRARY #################
- SET ( REQUIRED_LIBRARIES
- ${LIBOPENSHOT_AUDIO_LIBRARIES}
-@@ -386,9 +391,11 @@ target_compile_definitions(openshot-example PRIVATE
+ # Link remaining dependency libraries
+ target_link_libraries(openshot PUBLIC
+@@ -396,9 +401,11 @@ target_compile_definitions(openshot-example PRIVATE
# Link test executable to the new library
target_link_libraries(openshot-example openshot)
@@ -24,7 +24,7 @@
############### PLAYER EXECUTABLE ################
# Create test executable
-@@ -396,6 +403,7 @@ add_executable(openshot-player Qt/demo/main.cpp)
+@@ -406,6 +413,7 @@ add_executable(openshot-player Qt/demo/main.cpp)
# Link test executable to the new library
target_link_libraries(openshot-player openshot)
diff --git a/multimedia/libopenshot/files/patch-src_FFmpegReader.cpp b/multimedia/libopenshot/files/patch-src_FFmpegReader.cpp
index 650f36969df9..3f60e6541b9c 100644
--- a/multimedia/libopenshot/files/patch-src_FFmpegReader.cpp
+++ b/multimedia/libopenshot/files/patch-src_FFmpegReader.cpp
@@ -1,4 +1,4 @@
---- src/FFmpegReader.cpp.orig 2019-11-04 12:14:04 UTC
+--- src/FFmpegReader.cpp.orig 2019-12-19 13:04:31 UTC
+++ src/FFmpegReader.cpp
@@ -162,7 +162,7 @@ static enum AVPixelFormat get_hw_dec_format(AVCodecCon
diff --git a/multimedia/libopenshot/files/patch-src_FFmpegWriter.cpp b/multimedia/libopenshot/files/patch-src_FFmpegWriter.cpp
index bbe6f5efeffe..dbfd81caeac2 100644
--- a/multimedia/libopenshot/files/patch-src_FFmpegWriter.cpp
+++ b/multimedia/libopenshot/files/patch-src_FFmpegWriter.cpp
@@ -1,6 +1,6 @@
---- src/FFmpegWriter.cpp.orig 2019-11-04 12:14:04 UTC
+--- src/FFmpegWriter.cpp.orig 2019-12-19 13:04:31 UTC
+++ src/FFmpegWriter.cpp
-@@ -172,7 +172,7 @@ void FFmpegWriter::SetVideoOptions(bool has_video, str
+@@ -172,7 +172,7 @@ void FFmpegWriter::SetVideoOptions(bool has_video, std
AVCodec *new_codec;
// Check if the codec selected is a hardware accelerated codec
#if IS_FFMPEG_3_2
@@ -9,7 +9,7 @@
if (strstr(codec.c_str(), "_vaapi") != NULL) {
new_codec = avcodec_find_encoder_by_name(codec.c_str());
hw_en_on = 1;
-@@ -220,9 +220,9 @@ void FFmpegWriter::SetVideoOptions(bool has_video, str
+@@ -220,9 +220,9 @@ void FFmpegWriter::SetVideoOptions(bool has_video, std
hw_en_on = 0;
hw_en_supported = 0;
}
@@ -30,7 +30,7 @@
if (hw_en_on && hw_en_supported) {
if (hw_device_ctx) {
av_buffer_unref(&hw_device_ctx);
-@@ -1351,7 +1351,7 @@ void FFmpegWriter::open_video(AVFormatContext *oc, AVS
+@@ -1352,7 +1352,7 @@ void FFmpegWriter::open_video(AVFormatContext *oc, AVS
adapter_num = openshot::Settings::Instance()->HW_EN_DEVICE_SET;
fprintf(stderr, "\n\nEncodiing Device Nr: %d\n", adapter_num);
if (adapter_num < 3 && adapter_num >=0) {
@@ -39,7 +39,7 @@
snprintf(adapter,sizeof(adapter),"/dev/dri/renderD%d", adapter_num+128);
// Maybe 127 is better because the first card would be 1?!
adapter_ptr = adapter;
-@@ -1359,17 +1359,21 @@ void FFmpegWriter::open_video(AVFormatContext *oc, AVS
+@@ -1360,17 +1360,21 @@ void FFmpegWriter::open_video(AVFormatContext *oc, AVS
adapter_ptr = NULL;
#elif defined(__APPLE__)
adapter_ptr = NULL;
diff --git a/multimedia/libopenshot/pkg-message b/multimedia/libopenshot/pkg-message
new file mode 100644
index 000000000000..f47d91cb3066
--- /dev/null
+++ b/multimedia/libopenshot/pkg-message
@@ -0,0 +1,12 @@
+[
+{
+ type: install
+ message: <<EOM
+If OpenMP causes a problem, define the environment variable OMP_THREAD_LIMIT, set it to 1, and then run the program.
+It loses performance, but increases stability.
+
+An example
+env OMP_THREAD_LIMIT=1 openshot-qt
+EOM
+}
+]