aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libopenshot
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-02-17 02:32:04 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-02-17 02:32:04 +0000
commit78e3a2f5898c1ab9596b92b9a6b0ad8201a459e6 (patch)
tree7ed631b2a10f15fb3bc3a6403d5657882ff51e3b /multimedia/libopenshot
parentf60a7bee5f02969e9e632ba2a5eaa946088739ea (diff)
downloadports-78e3a2f5898c1ab9596b92b9a6b0ad8201a459e6.tar.gz
ports-78e3a2f5898c1ab9596b92b9a6b0ad8201a459e6.zip
multimedia/libopenshot: Update 0.2.3-595 -> 0.2.4-29
PR: 244063 Submitted by: Tatsuki Makino <tatsuki_makino@hotmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=526335
Diffstat (limited to 'multimedia/libopenshot')
-rw-r--r--multimedia/libopenshot/Makefile11
-rw-r--r--multimedia/libopenshot/distinfo6
-rw-r--r--multimedia/libopenshot/files/patch-src_CMakeLists.txt30
-rw-r--r--multimedia/libopenshot/files/patch-src_FFmpegReader.cpp6
-rw-r--r--multimedia/libopenshot/pkg-plist4
5 files changed, 20 insertions, 37 deletions
diff --git a/multimedia/libopenshot/Makefile b/multimedia/libopenshot/Makefile
index 1fd71f052368..1f582749f801 100644
--- a/multimedia/libopenshot/Makefile
+++ b/multimedia/libopenshot/Makefile
@@ -2,10 +2,10 @@
PORTNAME= libopenshot
DISTVERSIONPREFIX= v
-DISTVERSION= 0.2.3-595
-PORTREVISION= 2
-DISTVERSIONSUFFIX= -ga1158ee
+DISTVERSION= 0.2.4-29
+DISTVERSIONSUFFIX= -g9bb5d93
CATEGORIES= multimedia
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= tatsuki_makino@hotmail.com
COMMENT= OpenShot Video Library
@@ -24,7 +24,7 @@ USES= cmake compiler:c++11-lang pkgconfig python:3.5+ qt:5
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= OpenShot
-USE_PYTHON= noflavors
+USE_PYTHON= flavors
USE_QT= core gui network multimedia widgets qmake_build buildtools_build
CMAKE_ON= USE_SYSTEM_JSONCPP DISABLE_BUNDLED_JSONCPP\
@@ -32,6 +32,7 @@ CMAKE_ON= USE_SYSTEM_JSONCPP DISABLE_BUNDLED_JSONCPP\
CMAKE_DISABLE_FIND_PACKAGE_Doxygen\
CMAKE_DISABLE_FIND_PACKAGE_RESVG\
CMAKE_DISABLE_FIND_PACKAGE_Ruby
+CMAKE_OFF= ENABLE_COVERAGE
CMAKE_ARGS= -DCMAKE_DISABLE_FIND_PACKAGE_ImageMagick:BOOL=ON
OPTIONS_DEFAULT= FFMPEG
OPTIONS_RADIO= IMAGEMAGICK
@@ -48,7 +49,7 @@ IMAGEMAGICK7_CMAKE_ON= -DCMAKE_DISABLE_FIND_PACKAGE_ImageMagick:BOOL=NO
LIBAV_LIB_DEPENDS= libavformat.so:multimedia/libav
.if !exists(/usr/lib/libomp.so)
-LIB_DEPENDS+= libomp.so:devel/openmp
+IGNORE= openmp of base system is required
.endif
.include <bsd.port.mk>
diff --git a/multimedia/libopenshot/distinfo b/multimedia/libopenshot/distinfo
index ae03beb1037a..98f2f00da1d5 100644
--- a/multimedia/libopenshot/distinfo
+++ b/multimedia/libopenshot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1577502000
-SHA256 (OpenShot-libopenshot-v0.2.3-595-ga1158ee_GH0.tar.gz) = b924dea93cfe4cf067ea1beba76ad1c57a385531b92d221de5e4da35111213e7
-SIZE (OpenShot-libopenshot-v0.2.3-595-ga1158ee_GH0.tar.gz) = 10290486
+TIMESTAMP = 1581390000
+SHA256 (OpenShot-libopenshot-v0.2.4-29-g9bb5d93_GH0.tar.gz) = 5858d87556858c54de75144a40eee0f7e5e52d66d8968b7f15e36d6c1dc3242d
+SIZE (OpenShot-libopenshot-v0.2.4-29-g9bb5d93_GH0.tar.gz) = 10296027
diff --git a/multimedia/libopenshot/files/patch-src_CMakeLists.txt b/multimedia/libopenshot/files/patch-src_CMakeLists.txt
index 7dd19fb609db..f290d45c7598 100644
--- a/multimedia/libopenshot/files/patch-src_CMakeLists.txt
+++ b/multimedia/libopenshot/files/patch-src_CMakeLists.txt
@@ -1,34 +1,16 @@
---- src/CMakeLists.txt.orig 2019-12-19 13:04:31 UTC
+--- src/CMakeLists.txt.orig 2020-02-10 17:52:00 UTC
+++ src/CMakeLists.txt
-@@ -358,6 +358,11 @@ if (TARGET cppzmq)
+@@ -364,7 +364,13 @@ if (TARGET RESVG::resvg)
+ set(CMAKE_SWIG_FLAGS "-DUSE_RESVG=1")
endif()
-
+find_library(EXECINFO_LIBRARY NAMES execinfo)
+if(NOT EXECINFO_LIBRARY)
+ message(FATAL_ERROR "${EXECINFO_LIBRARY}")
+endif(NOT EXECINFO_LIBRARY)
-+
############### LINK LIBRARY #################
++target_link_libraries(openshot PUBLIC ${EXECINFO_LIBRARY})
++
# Link remaining dependency libraries
target_link_libraries(openshot PUBLIC
-@@ -396,9 +401,11 @@ target_compile_definitions(openshot-example PRIVATE
-
- # Link test executable to the new library
- target_link_libraries(openshot-example openshot)
-+target_link_libraries(openshot-example ${EXECINFO_LIBRARY})
-
- add_executable(openshot-html-test examples/ExampleHtml.cpp)
- target_link_libraries(openshot-html-test openshot Qt5::Gui)
-+target_link_libraries(openshot-html-test ${EXECINFO_LIBRARY})
-
- ############### PLAYER EXECUTABLE ################
- # Create test executable
-@@ -406,6 +413,7 @@ add_executable(openshot-player Qt/demo/main.cpp)
-
- # Link test executable to the new library
- target_link_libraries(openshot-player openshot)
-+target_link_libraries(openshot-player ${EXECINFO_LIBRARY})
-
- ############### TEST BLACKMAGIC CAPTURE APP ################
- IF (BLACKMAGIC_FOUND)
+ ${LIBOPENSHOT_AUDIO_LIBRARIES}
diff --git a/multimedia/libopenshot/files/patch-src_FFmpegReader.cpp b/multimedia/libopenshot/files/patch-src_FFmpegReader.cpp
index 3f60e6541b9c..2ba92d216480 100644
--- a/multimedia/libopenshot/files/patch-src_FFmpegReader.cpp
+++ b/multimedia/libopenshot/files/patch-src_FFmpegReader.cpp
@@ -1,4 +1,4 @@
---- src/FFmpegReader.cpp.orig 2019-12-19 13:04:31 UTC
+--- src/FFmpegReader.cpp.orig 2020-02-10 17:52:00 UTC
+++ src/FFmpegReader.cpp
@@ -162,7 +162,7 @@ static enum AVPixelFormat get_hw_dec_format(AVCodecCon
@@ -9,7 +9,7 @@
// Linux pix formats
case AV_PIX_FMT_VAAPI:
hw_de_av_pix_fmt_global = AV_PIX_FMT_VAAPI;
-@@ -315,7 +315,7 @@ void FFmpegReader::Open() {
+@@ -318,7 +318,7 @@ void FFmpegReader::Open() {
pCodecCtx->get_format = get_hw_dec_format;
if (adapter_num < 3 && adapter_num >=0) {
@@ -18,7 +18,7 @@
snprintf(adapter,sizeof(adapter),"/dev/dri/renderD%d", adapter_num+128);
adapter_ptr = adapter;
i_decoder_hw = openshot::Settings::Instance()->HARDWARE_DECODER;
-@@ -378,11 +378,13 @@ void FFmpegReader::Open() {
+@@ -381,11 +381,13 @@ void FFmpegReader::Open() {
}
// Check if it is there and writable
diff --git a/multimedia/libopenshot/pkg-plist b/multimedia/libopenshot/pkg-plist
index d71517401351..a3ed8e67d1af 100644
--- a/multimedia/libopenshot/pkg-plist
+++ b/multimedia/libopenshot/pkg-plist
@@ -73,7 +73,7 @@ include/libopenshot/effects/Saturation.h
include/libopenshot/effects/Shift.h
include/libopenshot/effects/Wave.h
lib/libopenshot.so
-lib/libopenshot.so.0.2.3
-lib/libopenshot.so.17
+lib/libopenshot.so.0.2.4
+lib/libopenshot.so.18
%%PYTHON_SITELIBDIR%%/_openshot.so
%%PYTHON_SITELIBDIR%%/openshot.py