aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libquvi-scripts09/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-09-29 19:51:27 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-09-29 19:51:27 +0000
commitd51730140d1b4303b65cd47f673b958e459123b9 (patch)
tree1367b3cb5cdf103bface290d779e002bc917525b /multimedia/libquvi-scripts09/Makefile
parent997a85523e5ea991fa3cecb6d77421dbb1497f25 (diff)
downloadports-d51730140d1b4303b65cd47f673b958e459123b9.tar.gz
ports-d51730140d1b4303b65cd47f673b958e459123b9.zip
Add libquvi 0.9.4, libquvi-scripts 0.9.20131130 and quvi 0.9.5.
svn cp from the 0.4.x versions since it not backwards compatible. Sunpoet@ has agreed to also maintain these ports. Obtained from: GNOME dev repo Submitted by: Gustau Perez
Notes
Notes: svn path=/head/; revision=369551
Diffstat (limited to 'multimedia/libquvi-scripts09/Makefile')
-rw-r--r--multimedia/libquvi-scripts09/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/multimedia/libquvi-scripts09/Makefile b/multimedia/libquvi-scripts09/Makefile
new file mode 100644
index 000000000000..f29fbe5f3056
--- /dev/null
+++ b/multimedia/libquvi-scripts09/Makefile
@@ -0,0 +1,35 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libquvi-scripts
+PORTVERSION= 0.9
+CATEGORIES= multimedia devel
+MASTER_SITES= SF/quvi/${PORTVERSION}/${PORTNAME}/ \
+ GOOGLE_CODE
+PKGNAMESUFFIX= 09
+DISTNAME= ${PORTNAME}-${PORTVERSION}.${QUVI_VER}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Embedded lua scripts for libquvi and utility scripts
+
+LICENSE= AGPLv3
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.${QUVI_VER}
+
+OPTIONS_DEFINE= NSFW
+OPTIONS_SUB= yes
+NSFW_DESC= Enable adult website support
+
+USES= lua:run pathfix tar:xz
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-suffix=09
+
+QUVI_VER= 20131130
+
+PLIST_SUB+= VERSION="0.9.${QUVI_VER}"
+
+PROJECTHOST= quvi
+
+NSFW_CONFIGURE_WITH= nsfw
+
+.include <bsd.port.mk>