aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libtuner
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-10-01 10:06:38 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-10-01 10:06:38 +0000
commite9a418c64f620a57c658748ede6e91236db751ae (patch)
tree03173b2358caf90c31d28f8d78548c027fc1ab77 /multimedia/libtuner
parent95517590bd32e4a3a1ac9bce3cb1877633abf073 (diff)
downloadports-e9a418c64f620a57c658748ede6e91236db751ae.tar.gz
ports-e9a418c64f620a57c658748ede6e91236db751ae.zip
libtuner provides userspace drivers and support routines for
a variety of TV and radio tuner ICs. These ICs are usually attached to a peripheral bus (such as an I2C bus) embedded on a tuner card, and "stub" device nodes for the ICs will be exported by a card-specific driver. PR: 127668 Submitted by: Jason Harmening <jason dot harmening at gmail dot com>
Notes
Notes: svn path=/head/; revision=221080
Diffstat (limited to 'multimedia/libtuner')
-rw-r--r--multimedia/libtuner/Makefile20
-rw-r--r--multimedia/libtuner/distinfo3
-rw-r--r--multimedia/libtuner/pkg-descr5
-rw-r--r--multimedia/libtuner/pkg-plist23
4 files changed, 51 insertions, 0 deletions
diff --git a/multimedia/libtuner/Makefile b/multimedia/libtuner/Makefile
new file mode 100644
index 000000000000..334be09b0c0f
--- /dev/null
+++ b/multimedia/libtuner/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: libtuner
+# Date created: 7 September 2008
+# Whom: jah
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtuner
+PORTVERSION= 1.0.1
+CATEGORIES= multimedia
+MASTER_SITES= ftp://corona.homeunix.net/ports/libtuner/
+EXTRACT_ONLY= libtuner-${PORTVERSION}.tar.gz
+
+MAINTAINER= jason.harmening@gmail.com
+COMMENT= Userspace drivers for various TV/radio tuner ICs
+
+MAKE_ARGS+= LIBTUNER_MAJOR=1 LIBTUNER_MINOR=0 LIBTUNER_REV=1 INSTALLDIR=${PREFIX}
+USE_LDCONFIG= ${PREFIX}/lib/libtuner
+
+.include <bsd.port.mk>
diff --git a/multimedia/libtuner/distinfo b/multimedia/libtuner/distinfo
new file mode 100644
index 000000000000..526d6ce3bb59
--- /dev/null
+++ b/multimedia/libtuner/distinfo
@@ -0,0 +1,3 @@
+MD5 (libtuner-1.0.1.tar.gz) = 39ca0ddc39bddfe30fd4065cf9526c83
+SHA256 (libtuner-1.0.1.tar.gz) = c40e20e1df1c65bc75cffec30525dec7768feaaa767123f2990ac41aa9d663ae
+SIZE (libtuner-1.0.1.tar.gz) = 14987
diff --git a/multimedia/libtuner/pkg-descr b/multimedia/libtuner/pkg-descr
new file mode 100644
index 000000000000..e6d17ea47f1e
--- /dev/null
+++ b/multimedia/libtuner/pkg-descr
@@ -0,0 +1,5 @@
+libtuner provides userspace drivers and support routines for
+a variety of TV and radio tuner ICs. These ICs are usually
+attached to a peripheral bus (such as an I2C bus) embedded
+on a tuner card, and "stub" device nodes for the ICs will
+be exported by a card-specific driver.
diff --git a/multimedia/libtuner/pkg-plist b/multimedia/libtuner/pkg-plist
new file mode 100644
index 000000000000..b21e0b0829b8
--- /dev/null
+++ b/multimedia/libtuner/pkg-plist
@@ -0,0 +1,23 @@
+lib/libtuner/libtuner.so
+lib/libtuner/libtuner.so.1
+lib/libtuner/libtuner.so.1.0
+lib/libtuner/libtuner.so.1.0.1
+include/libtuner/avb_driver.h
+include/libtuner/cx22702.h
+include/libtuner/dtt75105.h
+include/libtuner/dtt7579.h
+include/libtuner/dtt7612.h
+include/libtuner/dvb_driver.h
+include/libtuner/fmd1216me.h
+include/libtuner/lg3303.h
+include/libtuner/lgh064f.h
+include/libtuner/or51132.h
+include/libtuner/pll_driver.h
+include/libtuner/tda9887.h
+include/libtuner/tuner_config.h
+include/libtuner/tuner_device.h
+include/libtuner/tuner_devnode_device.h
+include/libtuner/tuner_driver.h
+include/libtuner/tuner_firmware.h
+@dirrm lib/libtuner
+@dirrm include/libtuner