aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libv4l
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-08-15 15:48:05 +0000
committerThomas Zander <riggs@FreeBSD.org>2015-08-15 15:48:05 +0000
commit4eeb65820b2ec01ca9809a006c22d1694e01c3b9 (patch)
tree51cfca187dba2aeca987c0896dbb3c23feaf4a11 /multimedia/libv4l
parente4e5871355660e7f12d316ded68c13e1fbebf0f8 (diff)
downloadports-4eeb65820b2ec01ca9809a006c22d1694e01c3b9.tar.gz
ports-4eeb65820b2ec01ca9809a006c22d1694e01c3b9.zip
- Don't always depend on devel/argp-standalone - it is used only by v4l-utils
- Bump PORTREVISION - Pet portlint PR: 202280 Submitted by: s3erios@gmail.com
Notes
Notes: svn path=/head/; revision=394324
Diffstat (limited to 'multimedia/libv4l')
-rw-r--r--multimedia/libv4l/Makefile11
-rw-r--r--multimedia/libv4l/files/extra-patch-configure78
2 files changed, 84 insertions, 5 deletions
diff --git a/multimedia/libv4l/Makefile b/multimedia/libv4l/Makefile
index 27465bea8749..fecb25ba68b2 100644
--- a/multimedia/libv4l/Makefile
+++ b/multimedia/libv4l/Makefile
@@ -4,7 +4,7 @@
PORTNAME?= libv4l
PORTVERSION= 1.6.3
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= multimedia
MASTER_SITES= http://linuxtv.org/downloads/v4l-utils/:master \
LOCAL/kwm:local
@@ -24,7 +24,6 @@ WRKSRC= ${WRKDIR}/v4l-utils-${PORTVERSION}
.if ${LIBV4L_SLAVE} != compat
BUILD_DEPENDS+= v4l_compat>=${PORTVERSION}:${PORTSDIR}/multimedia/v4l_compat
-LIB_DEPENDS+= libargp.so:${PORTSDIR}/devel/argp-standalone
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -38,12 +37,14 @@ INSTALL_TARGET= install-strip
. if ${LIBV4L_SLAVE} == utils
BUILD_DEPENDS+= libv4l>=${PORTVERSION}:${PORTSDIR}/multimedia/libv4l
-LIB_DEPENDS+= libv4l2.so:${PORTSDIR}/multimedia/libv4l
-# Disabling building libv4l in the utils slave is too much hackery
+LIB_DEPENDS+= libargp.so:${PORTSDIR}/devel/argp-standalone \
+ libv4l2.so:${PORTSDIR}/multimedia/libv4l
+# Disabling building libv4l in the utils slave is too much hackery
# Lets wait for subpackages
-CONFIGURE_ARGS+=--enable-v4l-utils
+CONFIGURE_ARGS+=--enable-v4l-utils
. else
CONFIGURE_ARGS+=--disable-v4l-utils --enable-libv4l
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-configure
. endif
.endif
diff --git a/multimedia/libv4l/files/extra-patch-configure b/multimedia/libv4l/files/extra-patch-configure
new file mode 100644
index 000000000000..b7ad34c75b03
--- /dev/null
+++ b/multimedia/libv4l/files/extra-patch-configure
@@ -0,0 +1,78 @@
+--- configure.orig 2015-08-12 21:40:16 UTC
++++ configure
+@@ -18563,75 +18563,6 @@ fi
+
+ LIBS=$dl_saved_libs
+
+-ac_fn_c_check_header_mongrel "$LINENO" "argp.h" "ac_cv_header_argp_h" "$ac_includes_default"
+-if test "x$ac_cv_header_argp_h" = xyes; then :
+-
+-else
+- as_fn_error $? "Cannot continue: argp.h not found" "$LINENO" 5
+-fi
+-
+-
+-argp_saved_libs=$LIBS
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing argp_parse" >&5
+-$as_echo_n "checking for library containing argp_parse... " >&6; }
+-if ${ac_cv_search_argp_parse+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- ac_func_search_save_LIBS=$LIBS
+-cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+-/* end confdefs.h. */
+-
+-/* Override any GCC internal prototype to avoid an error.
+- Use char because int might match the return type of a GCC
+- builtin and then its argument prototype would still apply. */
+-#ifdef __cplusplus
+-extern "C"
+-#endif
+-char argp_parse ();
+-int
+-main ()
+-{
+-return argp_parse ();
+- ;
+- return 0;
+-}
+-_ACEOF
+-for ac_lib in '' argp; do
+- if test -z "$ac_lib"; then
+- ac_res="none required"
+- else
+- ac_res=-l$ac_lib
+- LIBS="-l$ac_lib $ac_func_search_save_LIBS"
+- fi
+- if ac_fn_c_try_link "$LINENO"; then :
+- ac_cv_search_argp_parse=$ac_res
+-fi
+-rm -f core conftest.err conftest.$ac_objext \
+- conftest$ac_exeext
+- if ${ac_cv_search_argp_parse+:} false; then :
+- break
+-fi
+-done
+-if ${ac_cv_search_argp_parse+:} false; then :
+-
+-else
+- ac_cv_search_argp_parse=no
+-fi
+-rm conftest.$ac_ext
+-LIBS=$ac_func_search_save_LIBS
+-fi
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_search_argp_parse" >&5
+-$as_echo "$ac_cv_search_argp_parse" >&6; }
+-ac_res=$ac_cv_search_argp_parse
+-if test "$ac_res" != no; then :
+- test "$ac_res" = "none required" || LIBS="$ac_res $LIBS"
+- test "$ac_cv_search_argp_parse" = "none required" || ARGP_LIBS=$ac_cv_search_argp_parse
+-else
+- as_fn_error $? "unable to find the argp_parse() function" "$LINENO" 5
+-fi
+-
+-
+-LIBS=$argp_saved_libs
+
+ ac_fn_c_check_header_mongrel "$LINENO" "linux/i2c-dev.h" "ac_cv_header_linux_i2c_dev_h" "$ac_includes_default"
+ if test "x$ac_cv_header_linux_i2c_dev_h" = xyes; then :