aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libv4l
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2014-09-06 15:44:09 +0000
committerJuergen Lock <nox@FreeBSD.org>2014-09-06 15:44:09 +0000
commit8169e0cd2793b0afbbc589caee6d7285d6f366d8 (patch)
tree5080282a0cfbbca54777ce8c921a84cdfafc2481 /multimedia/libv4l
parentf72cbe7ef4fe2fe7d1a6cf89f101e06fa817a2d0 (diff)
downloadports-8169e0cd2793b0afbbc589caee6d7285d6f366d8.tar.gz
ports-8169e0cd2793b0afbbc589caee6d7285d6f366d8.zip
- Integrate libv4l with webcamd regarding Webcam quirks.
- Bump PORTREVISION. Submitted by: hselasky (maintainer)
Notes
Notes: svn path=/head/; revision=367444
Diffstat (limited to 'multimedia/libv4l')
-rw-r--r--multimedia/libv4l/Makefile2
-rw-r--r--multimedia/libv4l/files/patch-libv4lconvert_control_libv4lcontrol.c25
2 files changed, 26 insertions, 1 deletions
diff --git a/multimedia/libv4l/Makefile b/multimedia/libv4l/Makefile
index 83ba7a8cff1f..f2b73c661743 100644
--- a/multimedia/libv4l/Makefile
+++ b/multimedia/libv4l/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libv4l
PORTVERSION= 0.8.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= http://linuxtv.org/downloads/v4l-utils/
DISTNAME= v4l-utils-${PORTVERSION}
diff --git a/multimedia/libv4l/files/patch-libv4lconvert_control_libv4lcontrol.c b/multimedia/libv4l/files/patch-libv4lconvert_control_libv4lcontrol.c
index 10e2ad4ad0c0..35eeec85f6b8 100644
--- a/multimedia/libv4l/files/patch-libv4lconvert_control_libv4lcontrol.c
+++ b/multimedia/libv4l/files/patch-libv4lconvert_control_libv4lcontrol.c
@@ -1,5 +1,30 @@
--- libv4lconvert/control/libv4lcontrol.c.orig 2012-05-02 21:17:37.000000000 +0200
+++ libv4lconvert/control/libv4lcontrol.c 2012-05-06 08:52:42.000000000 +0200
+@@ -345,6 +345,16 @@
+ unsigned short *vendor_id, unsigned short *product_id,
+ int *speed)
+ {
++#ifdef __FreeBSD__
++#define WEBCAMD_IOCTL_GET_USB_VENDOR_ID _IOR('q', 250, unsigned short)
++#define WEBCAMD_IOCTL_GET_USB_PRODUCT_ID _IOR('q', 251, unsigned short)
++#define WEBCAMD_IOCTL_GET_USB_SPEED _IOR('q', 252, unsigned int)
++ if (ioctl(data->fd, WEBCAMD_IOCTL_GET_USB_VENDOR_ID, vendor_id) == 0 &&
++ ioctl(data->fd, WEBCAMD_IOCTL_GET_USB_PRODUCT_ID, product_id) == 0 &&
++ ioctl(data->fd, WEBCAMD_IOCTL_GET_USB_SPEED, speed) == 0)
++ return (1);
++ return (0);
++#else
+ FILE *f;
+ int i, minor;
+ struct stat st;
+@@ -434,6 +444,7 @@
+ return 0; /* Should never happen */
+
+ return 1;
++#endif
+ }
+
+ /*
@@ -456,7 +456,12 @@
while (isspace(*start)) start++;
n = strlen(start);