aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libx264
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-09-23 13:14:10 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-09-23 13:14:10 +0000
commite7577aa20fe5708d310ee45e91f96b71242902b4 (patch)
treeaf62327f760dc3cd377e778434cfbac418260fe6 /multimedia/libx264
parentc50fea9186669942eda67e49df9d788d6c5a071f (diff)
multimedia/x264: add OPENCL option, enabled by default
Before OpenCL can be used for lookahead install at least one implementation: devel/freeocl, devel/pocl, lang/beignet or lang/clover. $ x264 --fullhelp | fgrep opencl --opencl Enable use of OpenCL --opencl-clbin <string> Specify path of compiled OpenCL kernel cache --opencl-device <integer> Specify OpenCL device ordinal where the options also work in other apps e.g., $ ffmpeg -i <input-file> -codec:v libx264 -x264opts opencl:opencl-device=1 <output-file> $ mpv --ovc libx264 --ovcopts-add x264opts=opencl:opencl-device=1 -o <output-file> <input-file> Differential Revision: https://reviews.freebsd.org/D7958 Approved by: koobs (maintainer)
Notes
Notes: svn path=/head/; revision=422671
Diffstat (limited to 'multimedia/libx264')
-rw-r--r--multimedia/libx264/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/multimedia/libx264/Makefile b/multimedia/libx264/Makefile
index 4fe9a02fbf0b..357b55ef2613 100644
--- a/multimedia/libx264/Makefile
+++ b/multimedia/libx264/Makefile
@@ -3,7 +3,7 @@
#
# Updating notes: see multimedia/x264/Makefile.
-PORTREVISION= 2
+PORTREVISION= 3
PKGNAMEPREFIX= lib
COMMENT= H.264/MPEG-4 AVC Video Encoding (Library)
MASTERDIR= ${.CURDIR}/../x264
@@ -13,12 +13,17 @@ LIB_DEPENDS= #
USES= pathfix
-OPTIONS_DEFINE= HI10P
+OPTIONS_DEFINE= HI10P OPENCL
+OPTIONS_DEFAULT= OPENCL
OPTIONS_EXCLUDE= FFMS GPAC LAVF LSMASH SWSCALE
HI10P_DESC= Enable High 10 Profile 10-bit encoding
HI10P_CONFIGURE_ON= --bit-depth=10
+OPENCL_DESC= Heterogeneous computing via OpenCL
+OPENCL_BUILD_DEPENDS= ${LOCALBASE}/include/CL/opencl.h:devel/opencl
+OPENCL_CONFIGURE_OFF= --disable-opencl
+
CONFIGURE_ARGS= \
--enable-static \
--enable-shared \