aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libxine
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-02-10 19:20:06 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-02-10 19:20:06 +0000
commitc8a803c80b1098bab0b56d03833a69bcf8d8c220 (patch)
tree7ae67cdd93205b5a16aa334b719b280845f3d6c7 /multimedia/libxine
parentc32a4b37ed9a4beb3b00f9e15e6d38bbdec01aff (diff)
downloadports-c8a803c80b1098bab0b56d03833a69bcf8d8c220.tar.gz
ports-c8a803c80b1098bab0b56d03833a69bcf8d8c220.zip
multimedia/libxine: fix linking against openssl
This fixes the build on DragonflyBSD (and likely openssl from ports): [...] tls/tls_openssl.c:183: error: undefined reference to 'ERR_get_error' tls/tls_openssl.c:183: error: undefined reference to 'ERR_error_string' tls/tls_openssl.c:199: error: undefined reference to 'ERR_get_error' [...] Reported by: tuxillo@quantumachine.net
Notes
Notes: svn path=/head/; revision=564897
Diffstat (limited to 'multimedia/libxine')
-rw-r--r--multimedia/libxine/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 5ab4cc0a31f7..426d3e687a23 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -124,7 +124,7 @@ NLS_CONFIGURE_ENABLE= nls
NFS_LIB_DEPENDS= libnfs.so:net/libnfs
NFS_CONFIGURE_ENABLE= nfs
OPENSSL_CONFIGURE_ON= --enable-tls
-OPENSSL_CONFIGURE_ENV= OPENSSL_LIBS="-L${OPENSSLLIB} -lssl" \
+OPENSSL_CONFIGURE_ENV= OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl" \
OPENSSL_CFLAGS="-I${OPENSSLINC}"
OPENSSL_USES= ssl
PIXBUF_CONFIGURE_ENABLE= gdkpixbuf