aboutsummaryrefslogtreecommitdiff
path: root/multimedia/lives
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-09-30 19:24:30 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-09-30 19:24:30 +0000
commit1ee4da6dd1d50ed85cd3a614fc8a30b02f3ccf66 (patch)
tree8b44219153a720f367633c8fe248933750735b7d /multimedia/lives
parent7cb0f3c9b4ec333deb7e94ba00c6dc2d3b9c6220 (diff)
downloadports-1ee4da6dd1d50ed85cd3a614fc8a30b02f3ccf66.tar.gz
ports-1ee4da6dd1d50ed85cd3a614fc8a30b02f3ccf66.zip
Let USES=localbase add -L${LOCALBASE}/lib to LIBS instead of LDFLAGS.
USES=localbase:ldflags can be used to set LDFLAGS. Normally LDFLAGS appears too early on the command line causing some ports to link with their own libraries in LOCALBASE (if installed) instead of WRKSRC. Also make use of _USES_POST so -L${LOCALBASE}/lib is added as late as possible after anything a port Makefile might set. Use _USES_POST instead of .include in libedit.mk and libarchive.mk so things like 'USES=libedit localbase:ldflags' work correctly. Fix some issues with LIBS in some ports. Switch ports that don't support LIBS to localbase:ldflags. PR: 212987 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=423014
Diffstat (limited to 'multimedia/lives')
-rw-r--r--multimedia/lives/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index 98200dfd656c..3f02fe5e640c 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -58,8 +58,6 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS= --disable-ldvgrab
INSTALL_TARGET= install-strip
-CPPFLAGS+= -fPIC
-
DOC_FILES= AUTHORS BUGS ChangeLog FEATURES GETTING.STARTED README \
OMC/lives-OMC.txt RFX/LiVES-Perl.odt RFX/rfxbuilder.odt \
RFX/RFX.spec docs/clip_format.txt \
@@ -79,6 +77,8 @@ NLS_USES= gettext-tools
NLS_CONFIGURE_OFF= --disable-nls
post-patch:
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} \
+ 's/^LIBS = $$/&@LIBS@/'
@${REINPLACE_CMD} -e 's| install-docDATA||g; s|-$$(VERSION)||g' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|: install-data-local |: |g; s|-ldl||' \