aboutsummaryrefslogtreecommitdiff
path: root/multimedia/lives
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-09-12 18:32:18 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-09-12 18:32:18 +0000
commitbe039ed15bd51b4e0a4799e4ef8deead9d573a24 (patch)
treebdfa707d29f3447f1cecb7c08a92f31ee0663c79 /multimedia/lives
parentd2849d0cce4520a5853d80d0d4565b9243d56e54 (diff)
downloadports-be039ed15bd51b4e0a4799e4ef8deead9d573a24.tar.gz
ports-be039ed15bd51b4e0a4799e4ef8deead9d573a24.zip
- Update to version 2.8.0
- Register proxy dependencies found by stage-qa Changelog: Correct blank frame fix from 2.6.8 (add one to last frame). Fix coding error when centering windows. Correctly parse the path variables for frei0r, libvisual and ladspa. Set nicer defaults for RGBDelay effect.
Notes
Notes: svn path=/head/; revision=421950
Diffstat (limited to 'multimedia/lives')
-rw-r--r--multimedia/lives/Makefile19
-rw-r--r--multimedia/lives/distinfo6
-rw-r--r--multimedia/lives/files/patch-lives-plugins_weed-plugins_toonz.cpp12
-rw-r--r--multimedia/lives/pkg-plist2
4 files changed, 16 insertions, 23 deletions
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index 04d58c0fe7c5..98200dfd656c 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lives
-PORTVERSION= 2.6.3
+PORTVERSION= 2.8.0
CATEGORIES= multimedia
MASTER_SITES= SF
@@ -15,15 +15,19 @@ BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:multimedia/v4l_compat \
${LOCALBASE}/bin/analyseplugin:audio/ladspa
LIB_DEPENDS= libasound.so:audio/alsa-lib \
libjack.so:audio/jack \
+ libogg.so:audio/libogg \
libpulse.so:audio/pulseaudio \
liboil-0.3.so:devel/liboil \
libprojectM.so:graphics/libprojectm \
libvisual-0.4.so:graphics/libvisual04 \
libopencv_calib3d.so:graphics/opencv \
+ libopencv_core.so:graphics/opencv-core \
+ libpng16.so:graphics/png \
libfftw3.so:math/fftw3 \
libfftw3f.so:math/fftw3-float \
libavcodec.so:multimedia/ffmpeg \
libdv.so:multimedia/libdv \
+ libtheora.so:multimedia/libtheora \
libmjpegutils.so:multimedia/mjpegtools \
libschroedinger-1.0.so:multimedia/schroedinger
RUN_DEPENDS= ${LOCALBASE}/bin/analyseplugin:audio/ladspa \
@@ -39,13 +43,16 @@ RUN_DEPENDS= ${LOCALBASE}/bin/analyseplugin:audio/ladspa \
x264:multimedia/x264 \
cdrecord:sysutils/cdrtools
-USES= compiler:c++11-lib ghostscript:run libtool localbase pathfix perl5 \
- pkgconfig python shebangfix tar:bzip2
+USES= compiler:c++11-lib gettext-runtime ghostscript:run libtool \
+ localbase pathfix perl5 pkgconfig python shebangfix tar:bzip2
SHEBANG_FILES= build-lives-rfx-plugin build-lives-rfx-plugin-multi \
smogrify tools/autolives.pl lives-plugins/plugins/encoders/*_encoder \
lives-plugins/plugins/playback/audiostream/audiostreamer.pl
GNU_CONFIGURE= yes
-USE_GNOME= gtk30 intltool
+USE_XORG= x11
+USE_GL= gl
+USE_SDL= sdl
+USE_GNOME= cairo gdkpixbuf2 gtk30 intltool
USE_LDCONFIG= yes
CONFIGURE_ARGS= --disable-ldvgrab
@@ -59,8 +66,6 @@ DOC_FILES= AUTHORS BUGS ChangeLog FEATURES GETTING.STARTED README \
lives-plugins/marcos-encoders/README.multi_encoder \
weed-docs/weedspec.txt weed-docs/weedevents.txt
-PORT_VERBS= lives LiVES _encoder.py midistart midistop smogrify sendOSC
-
OPTIONS_DEFINE= DOCS DOXYGEN FREI0R MATROSKA NLS
OPTIONS_SUB= yes
@@ -70,7 +75,7 @@ FREI0R_BUILD_DEPENDS= frei0r>0:graphics/frei0r
FREI0R_RUN_DEPENDS= frei0r>0:graphics/frei0r
FREI0R_CONFIGURE_ENV_OFF= ac_cv_header_frei0r_h=no
MATROSKA_RUN_DEPENDS= mkvmerge:multimedia/mkvtoolnix
-NLS_USES= gettext
+NLS_USES= gettext-tools
NLS_CONFIGURE_OFF= --disable-nls
post-patch:
diff --git a/multimedia/lives/distinfo b/multimedia/lives/distinfo
index b95e32a67cdf..6298c40faca6 100644
--- a/multimedia/lives/distinfo
+++ b/multimedia/lives/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1463232875
-SHA256 (lives-2.6.3.tar.bz2) = 495248a51f00925576631821266e1f8acf3eca3b5eb1eaaf350201bfc000b1dc
-SIZE (lives-2.6.3.tar.bz2) = 3888592
+TIMESTAMP = 1473086975
+SHA256 (lives-2.8.0.tar.bz2) = eecea7a7517d944b1dc04b2f7ce51517e96531b04e67f3d34b0f8ef729d19fdc
+SIZE (lives-2.8.0.tar.bz2) = 3888265
diff --git a/multimedia/lives/files/patch-lives-plugins_weed-plugins_toonz.cpp b/multimedia/lives/files/patch-lives-plugins_weed-plugins_toonz.cpp
deleted file mode 100644
index b101543e5702..000000000000
--- a/multimedia/lives/files/patch-lives-plugins_weed-plugins_toonz.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- lives-plugins/weed-plugins/toonz.cpp.orig 2016-05-16 16:01:17 UTC
-+++ lives-plugins/weed-plugins/toonz.cpp
-@@ -38,7 +38,8 @@ Redistribution and use in source and bin
- THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- */
-
--
-+#include <array>
-+#include <random>
-
- #ifdef HAVE_SYSTEM_WEED
- #include <weed/weed.h>
diff --git a/multimedia/lives/pkg-plist b/multimedia/lives/pkg-plist
index 258eaa09b35a..31b3f412e960 100644
--- a/multimedia/lives/pkg-plist
+++ b/multimedia/lives/pkg-plist
@@ -211,7 +211,6 @@ libdata/pkgconfig/libweed-plugin.pc
libdata/pkgconfig/libweed-utils.pc
libdata/pkgconfig/libweed.pc
libdata/pkgconfig/libweed_slice.pc
-share/app-install/icons/lives.png
share/applications/LiVES.desktop
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/BUGS
@@ -227,6 +226,7 @@ share/applications/LiVES.desktop
%%PORTDOCS%%%%DOCSDIR%%/rfxbuilder.odt
%%PORTDOCS%%%%DOCSDIR%%/weedevents.txt
%%PORTDOCS%%%%DOCSDIR%%/weedspec.txt
+share/icons/hicolor/48x48/apps/lives.png
%%DATADIR%%/default.keymap
%%DATADIR%%/icons/audio.png
%%DATADIR%%/icons/fullscreen.png