aboutsummaryrefslogtreecommitdiff
path: root/multimedia/lives
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2020-11-14 10:57:10 +0000
committerKurt Jaeger <pi@FreeBSD.org>2020-11-14 10:57:10 +0000
commitfbdeaa5df2c0fbec4365e4b67d45d8f4eef8f28e (patch)
treeced08134e7b8ebb4905adabfb228afc4dcb62bb4 /multimedia/lives
parent09172abd9300eb508af7dc6272f812bd73a70291 (diff)
downloadports-fbdeaa5df2c0fbec4365e4b67d45d8f4eef8f28e.tar.gz
ports-fbdeaa5df2c0fbec4365e4b67d45d8f4eef8f28e.zip
multimedia/lives: update 2.10.2 -> 3.2.0
- major update - submitter becomes maintainer PR: 246491 Submitted by: vvd@unislabs.com Relnotes: http://lives-video.com/releases/CHANGELOG-3.2.0
Notes
Notes: svn path=/head/; revision=555106
Diffstat (limited to 'multimedia/lives')
-rw-r--r--multimedia/lives/Makefile195
-rw-r--r--multimedia/lives/distinfo6
-rw-r--r--multimedia/lives/files/patch-Makefile.am11
-rw-r--r--multimedia/lives/files/patch-configure.ac53
-rw-r--r--multimedia/lives/files/patch-jack196
-rw-r--r--multimedia/lives/files/patch-lives-plugins_weed-plugins_Makefile.am12
-rw-r--r--multimedia/lives/files/patch-lives-plugins_weed-plugins_gdk_Makefile.am13
-rw-r--r--multimedia/lives/pkg-plist104
8 files changed, 282 insertions, 208 deletions
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index a8c9b7c4d26f..a2a30ae76aa7 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -2,111 +2,166 @@
# $FreeBSD$
PORTNAME= lives
-PORTVERSION= 2.10.2
-PORTREVISION= 7
+DISTVERSION= 3.2.0
+PORTREVISION= 0
CATEGORIES= multimedia
MASTER_SITES= http://lives-video.com/releases/
DISTNAME= LiVES-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= vvd@unislabs.com
COMMENT= Video editing system
-LICENSE= GPLv3+
-LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE= GPLv3+ LGPL3+
+LICENSE_COMB= multi
+LICENSE_FILE_GPLv3+= ${WRKSRC}/COPYING
+LICENSE_FILE_LGPL3+= ${WRKSRC}/COPYING.LGPL
BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto \
- ${LOCALBASE}/bin/analyseplugin:audio/ladspa
-LIB_DEPENDS= libogg.so:audio/libogg \
- liboil-0.3.so:devel/liboil \
- libvisual-0.4.so:graphics/libvisual04 \
- libopencv_calib3d.so:graphics/opencv \
- libopencv_core.so:graphics/opencv-core \
+ analyseplugin:audio/ladspa
+LIB_DEPENDS= liboil-0.3.so:devel/liboil \
libpng.so:graphics/png \
- libfftw3.so:math/fftw3 \
- libfftw3f.so:math/fftw3-float \
libavcodec.so:multimedia/ffmpeg \
- libdv.so:multimedia/libdv \
- libtheora.so:multimedia/libtheora \
- libmjpegutils.so:multimedia/mjpegtools \
- libschroedinger-1.0.so:multimedia/schroedinger
-RUN_DEPENDS= ${LOCALBASE}/bin/analyseplugin:audio/ladspa \
- mpg123:audio/mpg123 \
- sox:audio/sox \
- ogg123:audio/vorbis-tools \
- convert:graphics/ImageMagick6 \
- sswf:graphics/sswf \
- mencoder:multimedia/mencoder \
- mplayer:multimedia/mplayer \
- ogmmerge:multimedia/ogmtools \
- transcode:multimedia/transcode \
- x264:multimedia/x264 \
- cdrecord:sysutils/cdrtools
+ libmjpegutils.so:multimedia/mjpegtools
+RUN_DEPENDS= analyseplugin:audio/ladspa \
+ ffprobe:multimedia/ffmpeg \
+ sox:audio/sox
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= autoreconf compiler:c++11-lib gettext-runtime gettext-tools \
- ghostscript:run gl gnome \
- libtool localbase pathfix perl5 pkgconfig python sdl \
- shebangfix tar:bzip2 xorg
-SHEBANG_FILES= build-lives-rfx-plugin build-lives-rfx-plugin-multi \
- smogrify tools/autolives.pl lives-plugins/plugins/encoders/*_encoder \
+USES= autoreconf compiler:c++11-lib gettext-runtime gettext-tools \ gl gnome libtool localbase pathfix perl5 pkgconfig python \
+ sdl shebangfix xorg
+SHEBANG_FILES= build-lives-rfx-plugin build-lives-rfx-plugin-multi smogrify \
+ tools/autolives.pl lives-plugins/plugins/encoders/*_encoder \
lives-plugins/marcos-encoders/*encoder* \
lives-plugins/plugins/encoders/multi_encoder3 \
lives-plugins/plugins/playback/audiostream/audiostreamer.pl
GNU_CONFIGURE= yes
USE_XORG= x11 xrender
USE_GL= gl glu
-USE_SDL= sdl
+USE_SDL= sdl sdl2
USE_GNOME= cairo gdkpixbuf2 gtk30 intltool
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --disable-ldvgrab
+CONFIGURE_ARGS= --disable-ldvgrab --disable-prctl --disable-system-weed
INSTALL_TARGET= install-strip
-DOC_FILES= AUTHORS BUGS ChangeLog FEATURES GETTING.STARTED README \
+DOC_FILES= AUTHORS COPYING COPYING.LGPL ChangeLog FEATURES GETTING.STARTED NEWS README \
OMC/lives-OMC.txt RFX/LiVES-Perl.odt RFX/rfxbuilder.odt \
- RFX/RFX.spec docs/clip_format.txt \
+ RFX/RFX.spec docs/c++-bindings.odt docs/clip_format.txt \
lives-plugins/marcos-encoders/README.multi_encoder \
weed-docs/weedspec.txt weed-docs/weedevents.txt
-OPTIONS_DEFINE= ALSA DOCS DOXYGEN FREI0R JACK MATROSKA V4L NLS PROJECTM PULSEAUDIO
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= ALSA DOCS DOXYGEN DV FFTW FREI0R JACK LIBEXPLAIN LIBVISUAL \
+ OGG OPENCV OPTIMIZED_CFLAGS NLS PROJECTM PULSEAUDIO \
+ SCHROEDINGER THEORA V4L WAYLAND
+OPTIONS_GROUP= RUNTIME
+OPTIONS_GROUP_RUNTIME= CDDA2WAV GCONF GHOSTSCRIPT LAME MATROSKA MENCODER OGG123 OGM \
+ SSWF X264 XDG_SCREENSAVER XWININFO
+OPTIONS_MULTI= EXT_WIN_CAPTURE MP3 MPLAYERS YOUTUBE_DLX
+OPTIONS_MULTI_EXT_WIN_CAPTURE= WMCTRL XDOTOOL
+OPTIONS_MULTI_MP3= MPG123 MPG321
+OPTIONS_MULTI_MPLAYERS= MPLAYER MPV
+OPTIONS_MULTI_YOUTUBE_DLX= YOUTUBE_DL YOUTUBE_DLC
+OPTIONS_RADIO= IMAGEMAGICK
+OPTIONS_RADIO_IMAGEMAGICK= IMAGEMAGICK6 IMAGEMAGICK7
+OPTIONS_DEFAULT= CDDA2WAV DOCS DV FFTW GCONF GHOSTSCRIPT IMAGEMAGICK7 JACK \
+ LAME MATROSKA MPG123 MPLAYER NLS OGG OGG123 OGM OPENCV \
+ SCHROEDINGER THEORA X264 XDG_SCREENSAVER XDOTOOL XWININFO
+OPTIONS_SUB= yes
-ALSA_CONFIGURE_OFF= --disable-alsa
-ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
-DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
-DOXYGEN_CONFIGURE_OFF= --disable-doxygen
-FREI0R_BUILD_DEPENDS= frei0r>0:graphics/frei0r
-FREI0R_RUN_DEPENDS= frei0r>0:graphics/frei0r
-FREI0R_CONFIGURE_ENV_OFF=ac_cv_header_frei0r_h=no
-JACK_CONFIGURE_OFF= --disable-jack
-JACK_LIB_DEPENDS= libjack.so:audio/jack
-MATROSKA_RUN_DEPENDS= mkvmerge:multimedia/mkvtoolnix
-V4L_BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
-V4L_LIB_DEPENDS= libv4l2.so:multimedia/libv4l
-NLS_USES= gettext-tools
-NLS_CONFIGURE_OFF= --disable-nls
-PROJECTM_DESC= projectM support
-PROJECTM_CONFIGURE_OFF= --disable-projectM
-PROJECTM_LIB_DEPENDS= libprojectM.so:graphics/libprojectm
-PULSEAUDIO_CONFIGURE_OFF=--disable-pulse
-PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+ALSA_CONFIGURE_OFF= --disable-alsa
+ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
+CDDA2WAV_RUN_DEPENDS= cdda2wav:sysutils/cdrtools
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
+DOXYGEN_CONFIGURE_OFF= --disable-doxygen
+DV_CONFIGURE_OFF= --disable-libdv
+DV_LIB_DEPENDS= libdv.so:multimedia/libdv
+DV_RUN_DEPENDS= encodedv:multimedia/libdv
+EXT_WIN_CAPTURE_DESC= Allows external window capture via xdotool or wmctrl
+FFTW_CONFIGURE_OFF= --disable-fftw3f
+FFTW_LIB_DEPENDS= libfftw3.so:math/fftw3 \
+ libfftw3f.so:math/fftw3-float
+FREI0R_BUILD_DEPENDS= frei0r>0:graphics/frei0r
+FREI0R_CONFIGURE_OFF= --disable-frei0r
+FREI0R_RUN_DEPENDS= frei0r>0:graphics/frei0r
+GCONF_USE= GNOME=gconf2
+GHOSTSCRIPT_USES= ghostscript:run
+IMAGEMAGICK6_DESC= ${IMAGEMAGICK_DESC} version 6.x
+IMAGEMAGICK6_RUN_DEPENDS= convert:graphics/ImageMagick6 \
+ composite:graphics/ImageMagick6
+IMAGEMAGICK7_DESC= ${IMAGEMAGICK_DESC} version 7.x
+IMAGEMAGICK7_RUN_DEPENDS= convert:graphics/ImageMagick7 \
+ composite:graphics/ImageMagick7
+JACK_CONFIGURE_OFF= --disable-jack
+JACK_LIB_DEPENDS= libjack.so:audio/jack \
+ libjackserver.so:audio/jack
+LAME_RUN_DEPENDS= lame:audio/lame
+LIBEXPLAIN_CONFIGURE_OFF= --disable-libexplain
+LIBEXPLAIN_DESC= Used to explain Unix and Linux system call errors
+LIBEXPLAIN_LIB_DEPENDS= libexplain.so:devel/libexplain
+LIBVISUAL_CONFIGURE_OFF= --disable-libvisual
+LIBVISUAL_LIB_DEPENDS= libvisual-0.4.so:graphics/libvisual04
+MATROSKA_RUN_DEPENDS= mkvmerge:multimedia/mkvtoolnix
+MENCODER_RUN_DEPENDS= mencoder:multimedia/mencoder
+MENCODER_DESC= Use mencoder as video file and movie encoder
+MP3_DESC= Runtime check order is: mpg321, mpg123, mplayer, mplayer2, mpv
+MPG123_RUN_DEPENDS= mpg123:audio/mpg123
+MPG321_DESC= MP3 decoding support via mpg321
+MPG321_RUN_DEPENDS= mpg321:audio/mpg321
+MPLAYER_RUN_DEPENDS= mplayer:multimedia/mplayer
+MPLAYERS_DESC= Install mplayer/mpv (runtime check)
+MPV_DESC= MPV media player support
+MPV_RUN_DEPENDS= mpv:multimedia/mpv
+NLS_USES= gettext-tools
+OGG_CONFIGURE_OFF= --disable-ogg
+OGG_LIB_DEPENDS= libogg.so:audio/libogg
+OGG123_DESC= Use ogg123 from vorbis-tools
+OGG123_RUN_DEPENDS= ogg123:audio/vorbis-tools
+OGM_DESC= Use ogmtools for manipulating with OGM files
+OGM_RUN_DEPENDS= ogmmerge:multimedia/ogmtools
+OPENCV_CONFIGURE_OFF= --disable-opencv
+OPENCV_LIB_DEPENDS= libopencv_calib3d.so:graphics/opencv \
+ libopencv_core.so:graphics/opencv-core
+SCHROEDINGER_CONFIGURE_OFF= --disable-dirac
+SCHROEDINGER_LIB_DEPENDS= libschroedinger-1.0.so:multimedia/schroedinger
+SSWF_DESC= Use sswf for manipulating with Flash movies
+SSWF_RUN_DEPENDS= sswf:graphics/sswf
+THEORA_CONFIGURE_OFF= --disable-theora
+THEORA_LIB_DEPENDS= libtheora.so:multimedia/libtheora
+OPTIMIZED_CFLAGS_CONFIGURE_ON= --enable-turbo
+PROJECTM_CONFIGURE_OFF= --disable-projectM
+PROJECTM_DESC= projectM support
+PROJECTM_LIB_DEPENDS= libprojectM.so:graphics/libprojectm
+PULSEAUDIO_CONFIGURE_OFF= --disable-pulse
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+RUNTIME_DESC= Runtime detected utilities
+V4L_BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
+V4L_CONFIGURE_OFF= --disable-v4l
+V4L_LIB_DEPENDS= libv4l2.so:multimedia/libv4l
+WAYLAND_CONFIGURE_OFF= --disable-wayland
+WAYLAND_LIB_DEPENDS= libwayland-client.so:graphics/wayland \
+ libwayland-egl.so:graphics/wayland \
+ libwayland-cursor.so:graphics/wayland
+WMCTRL_DESC= Install wmctrl
+WMCTRL_RUN_DEPENDS= wmctrl:x11/wmctrl
+YOUTUBE_DL_DESC= Install youtube-dl
+YOUTUBE_DL_RUN_DEPENDS= youtube-dl:www/youtube_dl
+YOUTUBE_DLC_DESC= Install youtube-dlc
+YOUTUBE_DLC_RUN_DEPENDS= youtube-dlc:www/youtube_dlc
+YOUTUBE_DLX_DESC= Install youtube-dl (runtime check)
+X264_RUN_DEPENDS= x264:multimedia/x264
+XDG_SCREENSAVER_DESC= Used to disable screensaver during playback
+XDG_SCREENSAVER_RUN_DEPENDS= xdg-screensaver:devel/xdg-utils
+XDOTOOL_DESC= Install xdotool
+XDOTOOL_RUN_DEPENDS= xdotool:x11/xdotool
+XWININFO_DESC= Used for external window capture
+XWININFO_RUN_DEPENDS= xwininfo:x11/xwininfo
post-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} \
's/^LIBS = $$/&@LIBS@/'
- @${REINPLACE_CMD} -e 's| install-docDATA||g; s|-$$(VERSION)||g' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|: install-data-local |: |g; s|-ldl||' \
- ${WRKSRC}/lives-plugins/weed-plugins/gdk/Makefile.in \
- ${WRKSRC}/lives-plugins/weed-plugins/Makefile.in
@${REINPLACE_CMD} -e 's|/usr/local/lib/|${LOCALBASE}/lib/|g' \
${WRKSRC}/lives-plugins/weed-plugins/frei0r.c
- @${REINPLACE_CMD} '/cp -rf/ s|data/|data|g; /cp -rf/ s|icons/|icons|g' \
- ${WRKSRC}/lives-plugins/weed-plugins/cairo/Makefile.in \
- ${WRKSRC}/lives-plugins/weed-plugins/Makefile.in
- @${REINPLACE_CMD} '/selectRandom/d' \
- ${WRKSRC}/lives-plugins/weed-plugins/projectM.cpp
@${REINPLACE_CMD} 's|/usr/bin/perl|${perl_CMD}|' \
${WRKSRC}/build-lives-rfx-plugin
diff --git a/multimedia/lives/distinfo b/multimedia/lives/distinfo
index 1a2070933b5d..980c5faaca32 100644
--- a/multimedia/lives/distinfo
+++ b/multimedia/lives/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1547452499
-SHA256 (LiVES-2.10.2.tar.bz2) = 572e6ed613eedb035ceab5f48ba3e7331e40128652af2fbc066fd87594be241c
-SIZE (LiVES-2.10.2.tar.bz2) = 4100348
+TIMESTAMP = 1604882135
+SHA256 (LiVES-3.2.0.tar.gz) = b3ed086d6548d51389e84223e7127818dcc79b2155ed9d73292a0aa3a13b88b5
+SIZE (LiVES-3.2.0.tar.gz) = 6496691
diff --git a/multimedia/lives/files/patch-Makefile.am b/multimedia/lives/files/patch-Makefile.am
deleted file mode 100644
index 1dca074cac5e..000000000000
--- a/multimedia/lives/files/patch-Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.am.orig 2019-04-16 07:43:04 UTC
-+++ Makefile.am
-@@ -35,7 +35,7 @@ endif
- SUBDIRS = $(OSC_SUBDIRS) intl $(WEED_SUBDIRS) src m4 lives-plugins po resources
- PACKAGE_CAPITALISED = LiVES
-
--docdir = "$(prefix)/share/doc/$(PACKAGE)-$(VERSION)"
-+docdir = "$(prefix)/share/doc/$(PACKAGE)"
- sharedir = "$(prefix)/share"
-
- if HAVE_DOXYGEN
diff --git a/multimedia/lives/files/patch-configure.ac b/multimedia/lives/files/patch-configure.ac
deleted file mode 100644
index a5d325da1604..000000000000
--- a/multimedia/lives/files/patch-configure.ac
+++ /dev/null
@@ -1,53 +0,0 @@
---- configure.ac.orig 2019-01-08 13:49:30 UTC
-+++ configure.ac
-@@ -522,12 +522,14 @@
-
- PKG_CHECK_MODULES(OPENCV, opencv >= 2.3.1, HAVE_OPENCV=true, HAVE_OPENCV=false)
-
--if test "HAVE_OPENCV" = "true" ; then
--OPENCV_LIBS_ONLY_L = `pkg-config opencv --libs-only-L`
-+if test "$HAVE_OPENCV" = "true" ; then
-+OPENCV_LIBS_ONLY_L=`$PKG_CONFIG opencv --libs-only-L`
-+OPENCV_LIBS_ONLY_OTHER=`$PKG_CONFIG opencv --libs-only-other`
- fi
-
- AC_SUBST(OPENCV_CFLAGS)
- AC_SUBST(OPENCV_LIBS_ONLY_L)
-+AC_SUBST(OPENCV_LIBS_ONLY_OTHER)
-
- AM_CONDITIONAL(HAVE_OPENCV,$HAVE_OPENCV)
-
-@@ -734,16 +736,23 @@
-
-
- HAVE_ALSA=false
-+AC_ARG_ENABLE(alsa, [ --disable-alsa Disable alsa support.] , disable_alsa=yes)
-+if test "x$disable_alsa" != "xyes" ; then
- dnl check for libasound
- PKG_CHECK_MODULES(ALSA,alsa,HAVE_ALSA=true,HAVE_ALSA=false)
- AC_SUBST(ALSA_CFLAGS)
- AC_SUBST(ALSA_LIBS)
-+else
-+echo not checking for alsa
-+fi
-
- AM_CONDITIONAL(HAVE_ALSA,$HAVE_ALSA)
-
-
- HAVE_PULSE_AUDIO=false
- HAVE_PA_STREAM_BEGIN_WRITE=false
-+AC_ARG_ENABLE(pulse, [ --disable-pulse Disable pulseaudio support.] , disable_pulse=yes)
-+if test "x$disable_pulse" != "xyes" ; then
- dnl check for pulse-audio
- PKG_CHECK_MODULES(PULSE,libpulse >= 0.9.14,HAVE_PULSE_AUDIO=true,HAVE_PULSE_AUDIO=false)
- if test "$HAVE_PULSE_AUDIO" = "true" ; then
-@@ -752,6 +761,9 @@
-
- AC_SUBST(PULSE_CFLAGS)
- AC_SUBST(PULSE_LIBS)
-+else
-+echo not checking for pulse
-+fi
-
- AM_CONDITIONAL(HAVE_PULSE_AUDIO,$HAVE_PULSE_AUDIO)
- AM_CONDITIONAL(HAVE_PA_STREAM_BEGIN_WRITE,$HAVE_PA_STREAM_BEGIN_WRITE)
diff --git a/multimedia/lives/files/patch-jack1 b/multimedia/lives/files/patch-jack1
new file mode 100644
index 000000000000..ceeebfa9373a
--- /dev/null
+++ b/multimedia/lives/files/patch-jack1
@@ -0,0 +1,96 @@
+--- configure.ac.orig
++++ configure.ac
+@@ -240,6 +240,7 @@ AM_CONDITIONAL(HAVE_LINUX_JOYSTICK_H, $HAVE_LINUX_JOYSTICK_H)
+ HAVE_JACK=false
+ HAVE_JACK_SERVER=false
+ HAVE_JACK_TRANSPORT=false
++JACK_V2=false
+
+ AC_ARG_ENABLE(jack, [ --disable-jack Disable jack support.] , disable_jack=yes)
+ AC_ARG_ENABLE(jack-transport, [ --disable-jack-transport Disable jack transport support.] , disable_jack_transport=yes)
+@@ -252,10 +253,23 @@ PKG_CHECK_MODULES(JACK, [jack >= 0.100.0], HAVE_JACK=true, HAVE_JACK=false)
+
+ if test "$HAVE_JACK" = "true" ; then
+
++PKG_CHECK_MODULES(JACK_V2, [jack >= 1.0.0], JACK_V2=true, JACK_V2=false)
++
++if test "$JACK_V2" = "true"; then
+ JACK_SERVER_LIBS=`$PKG_CONFIG --variable=server_libs jack`
+
+ if test "$JACK_SERVER_LIBS" != ""; then
+ HAVE_JACK_SERVER=true
++fi
++
++else
++AC_CHECK_HEADERS(jack/control.h, HAVE_JACK_SERVER=true, HAVE_JACK_SERVER=false)
++if test "$HAVE_JACK_SERVER" = "true"; then
++JACK_SERVER_LIBS=-ljackserver
++fi
++fi
++
++if test "$HAVE_JACK_SERVER" = "true"; then
+ echo jack server libs found
+ else
+ echo jack server libs not found
+@@ -308,6 +322,7 @@ HAVE_JACK_VIDEO=true
+ AM_CONDITIONAL(ENABLE_JACK,$HAVE_JACK)
+ AM_CONDITIONAL(ENABLE_JACK_TRANSPORT,$HAVE_JACK_TRANSPORT)
+ AM_CONDITIONAL(ENABLE_VJACK,$HAVE_JACK_VIDEO)
++AM_CONDITIONAL(JACK_V2,$JACK_V2)
+
+ PKG_CHECK_MODULES(X11,x11,HAVE_X11=true,HAVE_X11=false)
+
+--- src/Makefile.am.orig
++++ src/Makefile.am
+@@ -92,6 +92,10 @@ jack_LDADD = @JACK_LIBS@ @JACK_SERVER_LIBS@
+ if ENABLE_JACK_TRANSPORT
+ jack_CFLAGS += -DENABLE_JACK_TRANSPORT=1
+ endif
++
++if JACK_V2
++jack_CFLAGS += -DJACK_V2=1
++endif
+ endif
+
+ if ENABLE_LIBOIL
+--- src/jack.c.orig
++++ src/jack.c
+@@ -121,6 +121,7 @@ boolean lives_jack_init(void) {
+ return FALSE;
+ }
+
++#ifdef JACK_V2
+ if (!jackctl_server_open(jackserver, driver)) {
+ LIVES_ERROR("Could not create the driver for jack");
+ return FALSE;
+@@ -130,6 +131,12 @@ boolean lives_jack_init(void) {
+ LIVES_ERROR("Could not start the jack server");
+ return FALSE;
+ }
++#else
++ if (!jackctl_server_start(jackserver, driver)) {
++ LIVES_ERROR("Could not create / start the driver for jack");
++ return FALSE;
++ }
++#endif
+ }
+
+ mainw->jack_inited = TRUE;
+@@ -1061,7 +1068,7 @@ int lives_start_ready_callback(jack_transport_state_t state, jack_position_t *po
+ if (!jack_transport_client) return TRUE;
+
+ if (!LIVES_IS_PLAYING && state == JackTransportStopped) {
+- if (prefs->jack_opts && JACK_OPTS_TIMEBASE_CLIENT) {
++ if (prefs->jack_opts & JACK_OPTS_TIMEBASE_CLIENT) {
+ double trtime = (double)jack_transport_get_current_ticks() / TICKS_PER_SECOND_DBL;
+ if (!mainw->multitrack) {
+ #ifndef ENABLE_GIW_3
+@@ -1077,7 +1084,7 @@ int lives_start_ready_callback(jack_transport_state_t state, jack_position_t *po
+
+ if (state != JackTransportStarting) return TRUE;
+
+- if (LIVES_IS_PLAYING && prefs->jack_opts & JACK_OPTS_TIMEBASE_CLIENT) {
++ if (LIVES_IS_PLAYING && (prefs->jack_opts & JACK_OPTS_TIMEBASE_CLIENT)) {
+ // trigger audio resync
+ mainw->scratch = SCRATCH_JUMP;
+ }
diff --git a/multimedia/lives/files/patch-lives-plugins_weed-plugins_Makefile.am b/multimedia/lives/files/patch-lives-plugins_weed-plugins_Makefile.am
deleted file mode 100644
index de60be50c6f2..000000000000
--- a/multimedia/lives/files/patch-lives-plugins_weed-plugins_Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- lives-plugins/weed-plugins/Makefile.am.orig 2019-04-14 20:00:14 UTC
-+++ lives-plugins/weed-plugins/Makefile.am
-@@ -85,7 +85,8 @@ endif
-
- if HAVE_OPENCV
- farneback_analyser_libs = farneback_analyser.la
--farneback_analyser_la_LDFLAGS = $(AM_LDFLAGS) $(OPENCV_LIBS_ONLY_L) -lopencv_core -lopencv_video
-+farneback_analyser_la_LDFLAGS = $(AM_LDFLAGS) $(OPENCV_LIBS_ONLY_L) $(OPENCV_LIBS_ONLY_OTHER) -lopencv_core -lopencv_video
-+farneback_analyser_la_CXXFLAGS = $(OPENCV_CFLAGS)
- farneback_analyser_la_CPPFLAGS = $(AM_CPPFLAGS)
- farneback_analyser_la_SOURCES = farneback_analyser.cpp
-
diff --git a/multimedia/lives/files/patch-lives-plugins_weed-plugins_gdk_Makefile.am b/multimedia/lives/files/patch-lives-plugins_weed-plugins_gdk_Makefile.am
deleted file mode 100644
index 36402bed045c..000000000000
--- a/multimedia/lives/files/patch-lives-plugins_weed-plugins_gdk_Makefile.am
+++ /dev/null
@@ -1,13 +0,0 @@
---- lives-plugins/weed-plugins/gdk/Makefile.am.orig 2019-04-15 10:55:37 UTC
-+++ lives-plugins/weed-plugins/gdk/Makefile.am
-@@ -59,8 +59,8 @@ EXTRA_DIST=data icons
-
- install-data-local:
- mkdir -p "$(DESTDIR)$(fxpluginslibdir)"
-- cp -rf data/ "$(DESTDIR)$(fxpluginslibdir)" && chmod -R a+r "$(DESTDIR)$(fxpluginslibdir)/data/"
-- cp -rf icons/ "$(DESTDIR)$(fxpluginslibdir)" && chmod -R a+r "$(DESTDIR)$(fxpluginslibdir)/icons/"
-+ cp -rf data "$(DESTDIR)$(fxpluginslibdir)" && chmod -R a+r "$(DESTDIR)$(fxpluginslibdir)/data"
-+ cp -rf icons "$(DESTDIR)$(fxpluginslibdir)" && chmod -R a+r "$(DESTDIR)$(fxpluginslibdir)/icons"
- $(MAKE) -i install-data-local-remove-vcs-files
-
- install-data-local-remove-vcs-files:
diff --git a/multimedia/lives/pkg-plist b/multimedia/lives/pkg-plist
index ea29d12ff0e9..6e5b0f140e8e 100644
--- a/multimedia/lives/pkg-plist
+++ b/multimedia/lives/pkg-plist
@@ -3,6 +3,8 @@ bin/build-lives-rfx-plugin
bin/build-lives-rfx-plugin-multi
bin/lives
bin/lives-exe
+bin/lives-midistart
+bin/lives-midistop
bin/lives_avi_encoder
bin/lives_avi_encoder3
bin/lives_dirac_encoder
@@ -19,8 +21,6 @@ bin/lives_ogm_encoder
bin/lives_ogm_encoder3
bin/lives_theora_encoder
bin/lives_theora_encoder3
-bin/midistart
-bin/midistop
bin/sendOSC
bin/smogrify
include/weed/weed-compat.h
@@ -28,6 +28,7 @@ include/weed/weed-effects.h
include/weed/weed-events.h
include/weed/weed-host.h
include/weed/weed-palettes.h
+include/weed/weed-plugin-utils.h
include/weed/weed-plugin.h
include/weed/weed-utils.h
include/weed/weed.h
@@ -39,21 +40,24 @@ lib/libOSC_client.a
lib/libOSC_client.so
lib/libOSC_client.so.0
lib/libOSC_client.so.0.0.0
+lib/libweed-utils.a
lib/libweed-utils.so
lib/libweed-utils.so.0
-lib/libweed-utils.so.0.0.9
+lib/libweed-utils.so.0.1.13
lib/libweed-utils_scripting.so
lib/libweed-utils_scripting.so.0
-lib/libweed-utils_scripting.so.0.0.9
+lib/libweed-utils_scripting.so.0.1.13
+lib/libweed.a
lib/libweed.so
lib/libweed.so.0
-lib/libweed.so.0.0.9
-lib/libweed_slice.so
-lib/libweed_slice.so.0
-lib/libweed_slice.so.0.0.9
-lib/libweed_slice_scripting.so
-lib/libweed_slice_scripting.so.0
-lib/libweed_slice_scripting.so.0.0.9
+lib/libweed.so.0.1.13
+lib/libweed_gslice.a
+lib/libweed_gslice.so
+lib/libweed_gslice.so.0
+lib/libweed_gslice.so.0.1.13
+lib/libweed_gslice_scripting.so
+lib/libweed_gslice_scripting.so.0
+lib/libweed_gslice_scripting.so.0.1.13
lib/lives/plugins/decoders/asf_decoder.so
lib/lives/plugins/decoders/dv_decoder.so
lib/lives/plugins/decoders/flv_decoder.so
@@ -64,6 +68,7 @@ lib/lives/plugins/decoders/zzavformat_decoder.so
lib/lives/plugins/effects/realtime/weed/RGBdelay.so
lib/lives/plugins/effects/realtime/weed/alien_overlay.so
lib/lives/plugins/effects/realtime/weed/alpha_means.so
+lib/lives/plugins/effects/realtime/weed/alpha_to_grey.so
lib/lives/plugins/effects/realtime/weed/alpha_visualizer.so
lib/lives/plugins/effects/realtime/weed/audio_fft.so
lib/lives/plugins/effects/realtime/weed/audio_transition.so
@@ -78,6 +83,11 @@ lib/lives/plugins/effects/realtime/weed/comic.so
lib/lives/plugins/effects/realtime/weed/compositor.so
lib/lives/plugins/effects/realtime/weed/data_processor.so
lib/lives/plugins/effects/realtime/weed/data_unpacker.so
+lib/lives/plugins/effects/realtime/weed/data/fourKlives/songs/examples.txt
+lib/lives/plugins/effects/realtime/weed/data/fourKlives/songs/modulations.txt
+lib/lives/plugins/effects/realtime/weed/data/fourKlives/songs/newlives.txt
+lib/lives/plugins/effects/realtime/weed/data/fourKlives/songs/regrlives.txt
+lib/lives/plugins/effects/realtime/weed/data/fourKlives/songs/roselives.txt
lib/lives/plugins/effects/realtime/weed/deinterlace.so
lib/lives/plugins/effects/realtime/weed/edge.so
lib/lives/plugins/effects/realtime/weed/farneback_analyser.so
@@ -85,18 +95,13 @@ lib/lives/plugins/effects/realtime/weed/fg_bg_removal.so
lib/lives/plugins/effects/realtime/weed/fireTV.so
%%FREI0R%%lib/lives/plugins/effects/realtime/weed/frei0r/frei0r.so
lib/lives/plugins/effects/realtime/weed/fourKlives.so
-lib/lives/plugins/effects/realtime/weed/fourKlives/songs/examples.txt
-lib/lives/plugins/effects/realtime/weed/fourKlives/songs/modulations.txt
-lib/lives/plugins/effects/realtime/weed/fourKlives/songs/newlives.txt
-lib/lives/plugins/effects/realtime/weed/fourKlives/songs/regrlives.txt
-lib/lives/plugins/effects/realtime/weed/fourKlives/songs/roselives.txt
lib/lives/plugins/effects/realtime/weed/gdk_fast_resize.so
lib/lives/plugins/effects/realtime/weed/haar_analyser.so
lib/lives/plugins/effects/realtime/weed/haip.so
lib/lives/plugins/effects/realtime/weed/kaleidoscope.so
lib/lives/plugins/effects/realtime/weed/ladspa.so
lib/lives/plugins/effects/realtime/weed/layout_blends.so
-lib/lives/plugins/effects/realtime/weed/libvisual/libvis.so
+%%LIBVISUAL%%lib/lives/plugins/effects/realtime/weed/libvisual/libvis.so
lib/lives/plugins/effects/realtime/weed/lifeTV.so
lib/lives/plugins/effects/realtime/weed/livetext.so
lib/lives/plugins/effects/realtime/weed/log_sig.so
@@ -155,6 +160,7 @@ lib/lives/plugins/effects/rendered/gen_blank_frames
lib/lives/plugins/effects/rendered/gen_clip_from_image
lib/lives/plugins/effects/rendered/gen_coloured_frames
lib/lives/plugins/effects/rendered/gen_text
+lib/lives/plugins/effects/rendered/gmic
lib/lives/plugins/effects/rendered/hue_change
lib/lives/plugins/effects/rendered/image_overlay
lib/lives/plugins/effects/rendered/jumble
@@ -189,7 +195,6 @@ lib/lives/plugins/effects/rendered/tunnel
lib/lives/plugins/effects/rendered/wave
lib/lives/plugins/encoders/encodedv_encoder
lib/lives/plugins/encoders/ffmpeg_encoder
-lib/lives/plugins/encoders/mencoder_encoder
lib/lives/plugins/encoders/mjpegtools_encoder
lib/lives/plugins/encoders/multi_encoder
lib/lives/plugins/encoders/multi_encoder3
@@ -198,28 +203,28 @@ lib/lives/plugins/encoders/qtutils_encoder
lib/lives/plugins/encoders/sswf_encoder
lib/lives/plugins/encoders/x264_encoder
lib/lives/plugins/playback/audiostream/audiostreamer.pl
-lib/lives/plugins/playback/video/SDL.so
lib/lives/plugins/playback/video/icecast_output.so
lib/lives/plugins/playback/video/libav_stream.so
lib/lives/plugins/playback/video/lives2lives_stream.so
lib/lives/plugins/playback/video/oggstream.so
lib/lives/plugins/playback/video/openGL.so
-lib/lives/plugins/playback/video/vloopback.so
%%V4L%%lib/lives/plugins/playback/video/vloopback2.so
lib/lives/plugins/playback/video/yuv4mpeg_stream.so
libdata/pkgconfig/libweed-compat.pc
libdata/pkgconfig/libweed-plugin.pc
libdata/pkgconfig/libweed-utils.pc
libdata/pkgconfig/libweed.pc
-libdata/pkgconfig/libweed_slice.pc
+libdata/pkgconfig/libweed_gslice.pc
share/app-install/icons/lives.png
share/applications/LiVES.desktop
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/BUGS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/COPYING.LGPL
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/FEATURES
%%PORTDOCS%%%%DOCSDIR%%/GETTING.STARTED
%%PORTDOCS%%%%DOCSDIR%%/LiVES-Perl.odt
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.multi_encoder
%%PORTDOCS%%%%DOCSDIR%%/RFX.spec
@@ -227,6 +232,7 @@ share/applications/LiVES.desktop
%%PORTDOCS%%%%DOCSDIR%%/c++-bindings.odt
%%PORTDOCS%%%%DOCSDIR%%/lives-OMC.txt
%%PORTDOCS%%%%DOCSDIR%%/rfxbuilder.odt
+%%PORTDOCS%%%%DOCSDIR%%/version
%%PORTDOCS%%%%DOCSDIR%%/weedevents.txt
%%PORTDOCS%%%%DOCSDIR%%/weedspec.txt
share/icons/hicolor/128x128/apps/lives.png
@@ -236,30 +242,34 @@ share/icons/hicolor/256x256/apps/lives.png
share/icons/hicolor/32x32/apps/lives.png
share/icons/hicolor/48x48/apps/lives.png
share/icons/hicolor/64x64/apps/lives.png
+%%DATADIR%%/datacons.map
%%DATADIR%%/default.keymap
-%%DATADIR%%/icons/audio.png
-%%DATADIR%%/icons/fullscreen.png
-%%DATADIR%%/icons/loop.png
-%%DATADIR%%/icons/playsel.png
-%%DATADIR%%/icons/pref_decoding.png
-%%DATADIR%%/icons/pref_directory.png
-%%DATADIR%%/icons/pref_effects.png
-%%DATADIR%%/icons/pref_encoding.png
-%%DATADIR%%/icons/pref_gui.png
-%%DATADIR%%/icons/pref_jack.png
-%%DATADIR%%/icons/pref_midi.png
-%%DATADIR%%/icons/pref_misc.png
-%%DATADIR%%/icons/pref_multitrack.png
-%%DATADIR%%/icons/pref_net.png
-%%DATADIR%%/icons/pref_playback.png
-%%DATADIR%%/icons/pref_record.png
-%%DATADIR%%/icons/pref_themes.png
-%%DATADIR%%/icons/pref_warning.png
-%%DATADIR%%/icons/sepwin.png
-%%DATADIR%%/icons/volume_mute.png
-%%DATADIR%%/icons/zoom-in.png
-%%DATADIR%%/icons/zoom-out.png
-%%DATADIR%%/mixxx.map
+%%DATADIR%%/devicemaps/mixxx.map
+%%DATADIR%%/fxdefs.perkey
+%%DATADIR%%/icons/lives-audio.png
+%%DATADIR%%/icons/lives-fullscreen.png
+%%DATADIR%%/icons/lives-locked.png
+%%DATADIR%%/icons/lives-loop.png
+%%DATADIR%%/icons/lives-playsel.png
+%%DATADIR%%/icons/lives-pref_decoding.png
+%%DATADIR%%/icons/lives-pref_directory.png
+%%DATADIR%%/icons/lives-pref_effects.png
+%%DATADIR%%/icons/lives-pref_encoding.png
+%%DATADIR%%/icons/lives-pref_gui.png
+%%DATADIR%%/icons/lives-pref_jack.png
+%%DATADIR%%/icons/lives-pref_midi.png
+%%DATADIR%%/icons/lives-pref_misc.png
+%%DATADIR%%/icons/lives-pref_multitrack.png
+%%DATADIR%%/icons/lives-pref_net.png
+%%DATADIR%%/icons/lives-pref_playback.png
+%%DATADIR%%/icons/lives-pref_record.png
+%%DATADIR%%/icons/lives-pref_themes.png
+%%DATADIR%%/icons/lives-pref_warning.png
+%%DATADIR%%/icons/lives-sepwin.png
+%%DATADIR%%/icons/lives-unlocked.png
+%%DATADIR%%/icons/lives-volume_mute.png
+%%DATADIR%%/icons/lives-zoom-in.png
+%%DATADIR%%/icons/lives-zoom-out.png
%%DATADIR%%/plugins/effects/RFXscripts/blank_frames.script
%%DATADIR%%/plugins/effects/RFXscripts/blur.script
%%DATADIR%%/plugins/effects/RFXscripts/brightness_change.script
@@ -284,6 +294,7 @@ share/icons/hicolor/64x64/apps/lives.png
%%DATADIR%%/plugins/effects/RFXscripts/gen_clip_from_image.script
%%DATADIR%%/plugins/effects/RFXscripts/gen_coloured_frames.script
%%DATADIR%%/plugins/effects/RFXscripts/gen_text.script
+%%DATADIR%%/plugins/effects/RFXscripts/gmic.script
%%DATADIR%%/plugins/effects/RFXscripts/hue_change.script
%%DATADIR%%/plugins/effects/RFXscripts/image_overlay.script
%%DATADIR%%/plugins/effects/RFXscripts/jumble.script
@@ -320,6 +331,7 @@ share/icons/hicolor/64x64/apps/lives.png
%%DATADIR%%/plugins/effects/compound/motion_analyser
%%DATADIR%%/plugins/effects/compound/neural_net
%%DATADIR%%/resources/vidtest.avi
+%%DATADIR%%/stock-icons/livestock-help-info.svg
%%DATADIR%%/themes/camera/frame.jpg
%%DATADIR%%/themes/camera/header.theme
%%DATADIR%%/themes/camera/main.jpg
@@ -376,4 +388,4 @@ share/pixmaps/lives.png
share/pixmaps/lives.xpm
@dir lib/lives/plugins/effects/realtime/weed/data
@dir lib/lives/plugins/effects/realtime/weed/icons
-@dir %%DATADIR%%/devicemaps
+@dir %%DATADIR%%/plugins/effects/compound/icons