aboutsummaryrefslogtreecommitdiff
path: root/multimedia/livestreamer
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2015-01-18 12:10:22 +0000
committerJuergen Lock <nox@FreeBSD.org>2015-01-18 12:10:22 +0000
commit987a304c01940cee2a3243a3feb77eba7dbf2122 (patch)
treed7c617f8aecb168e43ea3db680a1738893ca0ec7 /multimedia/livestreamer
parent31b51c9317354ba0d0be751b8cf677795f951601 (diff)
downloadports-987a304c01940cee2a3243a3feb77eba7dbf2122.tar.gz
ports-987a304c01940cee2a3243a3feb77eba7dbf2122.zip
- Update to 1.11.1 (no functional change but it removes new version
available spam.) PR: 196828 Submitted by: Radim Kolar <hsn@sendmail.cz>
Notes
Notes: svn path=/head/; revision=377325
Diffstat (limited to 'multimedia/livestreamer')
-rw-r--r--multimedia/livestreamer/Makefile2
-rw-r--r--multimedia/livestreamer/distinfo4
-rw-r--r--multimedia/livestreamer/files/patch-bbc6d0e7c1a8b6bf053345e88366cae115baa2d354
3 files changed, 3 insertions, 57 deletions
diff --git a/multimedia/livestreamer/Makefile b/multimedia/livestreamer/Makefile
index 4ca9dbac5f51..2a51a8ed8440 100644
--- a/multimedia/livestreamer/Makefile
+++ b/multimedia/livestreamer/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= livestreamer
-PORTVERSION= 1.11.0
+PORTVERSION= 1.11.1
CATEGORIES= multimedia python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/multimedia/livestreamer/distinfo b/multimedia/livestreamer/distinfo
index 9d1d73b1a6ea..216e2de43aae 100644
--- a/multimedia/livestreamer/distinfo
+++ b/multimedia/livestreamer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (livestreamer-1.11.0.tar.gz) = 5af677ec93ebce229ac235ea6c23aec915deb4aacc8bdb8418c8488fbdd96920
-SIZE (livestreamer-1.11.0.tar.gz) = 421706
+SHA256 (livestreamer-1.11.1.tar.gz) = 84dd83d301518ffcf96f30cbffc0e0598e0756e7ab8e7498d11285d42fe17f9c
+SIZE (livestreamer-1.11.1.tar.gz) = 421719
diff --git a/multimedia/livestreamer/files/patch-bbc6d0e7c1a8b6bf053345e88366cae115baa2d3 b/multimedia/livestreamer/files/patch-bbc6d0e7c1a8b6bf053345e88366cae115baa2d3
deleted file mode 100644
index 62a330ffd5a8..000000000000
--- a/multimedia/livestreamer/files/patch-bbc6d0e7c1a8b6bf053345e88366cae115baa2d3
+++ /dev/null
@@ -1,54 +0,0 @@
-From bbc6d0e7c1a8b6bf053345e88366cae115baa2d3 Mon Sep 17 00:00:00 2001
-From: Christopher Rosell <chrippa@tanuki.se>
-Date: Fri, 12 Dec 2014 00:14:43 +0100
-Subject: [PATCH] plugins.twitch: Update for API change.
-
-Resolves #633.
----
- src/livestreamer/plugins/twitch.py | 17 +++++++++--------
- 1 file changed, 9 insertions(+), 8 deletions(-)
-
-diff --git a/src/livestreamer/plugins/twitch.py b/src/livestreamer/plugins/twitch.py
-index ca0d2bd..0adc872 100644
---- a/src/livestreamer/plugins/twitch.py
-+++ b/src/livestreamer/plugins/twitch.py
-@@ -125,8 +125,8 @@ def time_to_offset(t):
-
-
- class UsherService(object):
-- def _create_url(self, endpoint, asset, **extra_params):
-- url = "http://usher.twitch.tv/{0}/{1}".format(endpoint, asset)
-+ def _create_url(self, endpoint, **extra_params):
-+ url = "http://usher.twitch.tv{0}".format(endpoint)
- params = {
- "player": "twitchweb",
- "p": int(random() * 999999),
-@@ -145,11 +145,12 @@ def _create_url(self, endpoint, asset, **extra_params):
-
- return req.url
-
-- def select(self, channel, **extra_params):
-- return self._create_url("select", channel, **extra_params)
-+ def channel(self, channel, **extra_params):
-+ return self._create_url("/api/channel/hls/{0}.m3u8".format(channel),
-+ **extra_params)
-
-- def vod(self, vod_id, **extra_params):
-- return self._create_url("vod", vod_id, **extra_params)
-+ def video(self, video_id, **extra_params):
-+ return self._create_url("/vod/{0}".format(video_id), **extra_params)
-
-
- class TwitchAPI(object):
-@@ -417,9 +418,9 @@ def _get_hls_streams(self, type="live"):
- self._authenticate()
- sig, token = self._access_token(type)
- if type == "live":
-- url = self.usher.select(self.channel, nauthsig=sig, nauth=token)
-+ url = self.usher.channel(self.channel, sig=sig, token=token)
- elif type == "video":
-- url = self.usher.vod(self.video_id, nauthsig=sig, nauth=token)
-+ url = self.usher.video(self.video_id, nauthsig=sig, nauth=token)
-
- try:
- streams = HLSStream.parse_variant_playlist(self.session, url)