aboutsummaryrefslogtreecommitdiff
path: root/multimedia/livestreamer
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2013-11-29 20:23:39 +0000
committerJuergen Lock <nox@FreeBSD.org>2013-11-29 20:23:39 +0000
commite413222f49e2a80b0d28cb039c258452187e025c (patch)
tree809466cbc7e3e2c2f13bb900604bd9ce982d52f8 /multimedia/livestreamer
parentbfb6c93f196a7dc573bac0c0c2b55a4e00643eb2 (diff)
downloadports-e413222f49e2a80b0d28cb039c258452187e025c.tar.gz
ports-e413222f49e2a80b0d28cb039c258452187e025c.zip
Add multimedia/livestreamer:
Livestreamer is a Command Line Interface that pipes video streams from various services into a video player, such as VLC. The main purpose of Livestreamer is to allow the user to avoid buggy and CPU heavy flash plugins but still be able to enjoy various streamed content. Livestreamer is built upon a plugin system which allows support for new services to be easily added. Currently most of the big streaming services are supported, such as: Dailymotion Livestream Twitch/Justin.tv YouTube Live UStream Example use: $ livestreamer twitch.tv/day9tv best [cli][info] Found matching plugin justintv for URL twitch.tv/day9tv [cli][info] Opening stream: 720p [cli][info] Starting player: vlc WWW: https://github.com/chrippa/livestreamer
Notes
Notes: svn path=/head/; revision=335221
Diffstat (limited to 'multimedia/livestreamer')
-rw-r--r--multimedia/livestreamer/Makefile22
-rw-r--r--multimedia/livestreamer/distinfo2
-rw-r--r--multimedia/livestreamer/pkg-descr23
3 files changed, 47 insertions, 0 deletions
diff --git a/multimedia/livestreamer/Makefile b/multimedia/livestreamer/Makefile
new file mode 100644
index 000000000000..a490802a42f4
--- /dev/null
+++ b/multimedia/livestreamer/Makefile
@@ -0,0 +1,22 @@
+# Created by: Juergen Lock <nox@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= livestreamer
+PORTVERSION= 1.7.0
+CATEGORIES= multimedia python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= multimedia@FreeBSD.org
+COMMENT= Extract web streams and pipe them into video player of choice
+
+LICENSE= BSD
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:${PORTSDIR}/www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}librtmp>=0:${PORTSDIR}/multimedia/py-librtmp
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/multimedia/livestreamer/distinfo b/multimedia/livestreamer/distinfo
new file mode 100644
index 000000000000..17a878ac7bec
--- /dev/null
+++ b/multimedia/livestreamer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (livestreamer-1.7.0.tar.gz) = 5c653cd3883349f97181ec36692983cebcfaf62c864692d365450d4300dc6067
+SIZE (livestreamer-1.7.0.tar.gz) = 86888
diff --git a/multimedia/livestreamer/pkg-descr b/multimedia/livestreamer/pkg-descr
new file mode 100644
index 000000000000..0588c89f92ec
--- /dev/null
+++ b/multimedia/livestreamer/pkg-descr
@@ -0,0 +1,23 @@
+Livestreamer is a Command Line Interface that pipes video streams
+from various services into a video player, such as VLC. The main
+purpose of Livestreamer is to allow the user to avoid buggy and CPU
+heavy flash plugins but still be able to enjoy various streamed
+content.
+
+Livestreamer is built upon a plugin system which allows support for
+new services to be easily added. Currently most of the big streaming
+services are supported, such as:
+ Dailymotion
+ Livestream
+ Twitch/Justin.tv
+ YouTube Live
+ UStream
+
+Example use:
+
+$ livestreamer twitch.tv/day9tv best
+[cli][info] Found matching plugin justintv for URL twitch.tv/day9tv
+[cli][info] Opening stream: 720p
+[cli][info] Starting player: vlc
+
+WWW: https://github.com/chrippa/livestreamer