aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mencoder
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-11-16 17:20:32 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-11-16 17:20:32 +0000
commitfa8b4481076f99ae7a590763211a7f3b7cd637ff (patch)
tree867fe3ce2acf493b73bc50a046b2c8dccd986c4a /multimedia/mencoder
parentd9582fb7f0a53314d1f7bb82ac9aacf47ec5a589 (diff)
downloadports-fa8b4481076f99ae7a590763211a7f3b7cd637ff.tar.gz
ports-fa8b4481076f99ae7a590763211a7f3b7cd637ff.zip
Correct iconv handling
Bump PORTREVISION While on it: - Remove @dirrm(try) from pkg-plists PR: 195065 Submitted by: yuri@rawbw.com Reviewed by: riggs
Notes
Notes: svn path=/head/; revision=372644
Diffstat (limited to 'multimedia/mencoder')
-rw-r--r--multimedia/mencoder/Makefile5
-rw-r--r--multimedia/mencoder/pkg-plist2
2 files changed, 3 insertions, 4 deletions
diff --git a/multimedia/mencoder/Makefile b/multimedia/mencoder/Makefile
index fbf0f40c94bb..31a14d0c7803 100644
--- a/multimedia/mencoder/Makefile
+++ b/multimedia/mencoder/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mencoder
PORTVERSION= ${MPLAYER_PORT_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
COMMENT= Convenient video file and movie encoder
@@ -41,7 +41,7 @@ TOOLFILES= aconvert.sh binary_codecs.sh calcbpp.pl \
subedit.pl subsearch.sh vobshift.py \
w32codec_dl.pl wma2ogg.pl
-USES+= alias shebangfix
+USES+= alias iconv shebangfix
SHEBANG_FILES= TOOLS/calcbpp.pl TOOLS/checktree.sh TOOLS/countquant.pl \
TOOLS/divx2svcd.sh TOOLS/dvd2divxscript.pl TOOLS/mencvcd.sh \
TOOLS/mphelp_check.py TOOLS/plotpsnr.pl TOOLS/psnr-video.sh \
@@ -95,6 +95,7 @@ post-patch:
-e 's|%%LOCALBASE%%|${LOCALBASE}|' \
-e 's|-lbz2|/usr/lib/libbz2.so|' \
-e 's|-lncurses|/usr/lib/libncurses.so|' \
+ -e 's|-liconv|${ICONV_LIB}|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
@${FIND} -E ${WRKSRC} -type f \
-iregex ".*(configure|.sh|Makefile)" -print0 | \
diff --git a/multimedia/mencoder/pkg-plist b/multimedia/mencoder/pkg-plist
index aaa8adb5b249..464bfbccf83c 100644
--- a/multimedia/mencoder/pkg-plist
+++ b/multimedia/mencoder/pkg-plist
@@ -23,5 +23,3 @@ man/man1/mencoder.1.gz
%%DATADIR%%/tools/vobshift.py
%%DATADIR%%/tools/w32codec_dl.pl
%%DATADIR%%/tools/wma2ogg.pl
-@dirrm %%DATADIR%%/tools
-@dirrmtry %%DATADIR%%