aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mkvtoolnix
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2018-12-02 09:35:44 +0000
committerThomas Zander <riggs@FreeBSD.org>2018-12-02 09:35:44 +0000
commit024e1fcdc64da70e695880ccd3d1192274071307 (patch)
tree2bc2df718c749a48eb9d9d61cc8cc5a404bc5208 /multimedia/mkvtoolnix
parent34adfee80536f87d1e68732d1e4406f0d2872aad (diff)
downloadports-024e1fcdc64da70e695880ccd3d1192274071307.tar.gz
ports-024e1fcdc64da70e695880ccd3d1192274071307.zip
Update to upstream version 29.0.0, pet portlint
Notes
Notes: svn path=/head/; revision=486398
Diffstat (limited to 'multimedia/mkvtoolnix')
-rw-r--r--multimedia/mkvtoolnix/Makefile6
-rw-r--r--multimedia/mkvtoolnix/distinfo6
-rw-r--r--multimedia/mkvtoolnix/files/patch-configure17
-rw-r--r--multimedia/mkvtoolnix/files/patch-src_mkvtoolnix-gui_util_sleep__inhibitor.cpp20
4 files changed, 43 insertions, 6 deletions
diff --git a/multimedia/mkvtoolnix/Makefile b/multimedia/mkvtoolnix/Makefile
index a9c5863dc0a5..d2adb75e9577 100644
--- a/multimedia/mkvtoolnix/Makefile
+++ b/multimedia/mkvtoolnix/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mkvtoolnix
-PORTVERSION= 28.2.0
-PORTREVISION= 1
+PORTVERSION= 29.0.0
CATEGORIES= multimedia audio
MASTER_SITES= http://www.bunkus.org/videotools/mkvtoolnix/sources/ \
https://mkvtoolnix.download/sources/
@@ -27,6 +26,7 @@ LIB_DEPENDS= libvorbis.so:audio/libvorbis \
libmatroska.so:multimedia/libmatroska
USES= compiler:c++17-lang iconv localbase pkgconfig tar:xz
+
GNU_CONFIGURE= yes
CONFIGURE_ENV+= ac_cv_path_PO4A=no
CONFIGURE_ARGS= --with-boost=${LOCALBASE} \
@@ -51,7 +51,7 @@ NLS_CONFIGURE_WITH= gettext
QT5_DESC= Build and install GUI application (Qt 5)
QT5_USES= desktop-file-utils qt:5 shared-mime-info
-QT5_USE= QT=buildtools_build,concurrent,core,declarative,gui,multimedia,network,widgets
+QT5_USE= QT=buildtools_build,concurrent,core,dbus,declarative,gui,multimedia,network,widgets
QT5_CONFIGURE_ENABLE= qt
QT5_BUILD_DEPENDS= qmake:devel/qt5-qmake
QT5_LIB_DEPENDS= libcmark.so:textproc/cmark
diff --git a/multimedia/mkvtoolnix/distinfo b/multimedia/mkvtoolnix/distinfo
index c156b4738293..9525e09cb8eb 100644
--- a/multimedia/mkvtoolnix/distinfo
+++ b/multimedia/mkvtoolnix/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1540625436
-SHA256 (mkvtoolnix-28.2.0.tar.xz) = aa54b39790e619b2cfdefdd083c735503834eb05c665cd85f9b5a8383bcc5843
-SIZE (mkvtoolnix-28.2.0.tar.xz) = 6546844
+TIMESTAMP = 1543689447
+SHA256 (mkvtoolnix-29.0.0.tar.xz) = 54eb5f88fe3c9c7b5df77f80b0dfcac7695c19a8226f8ba52be8ad15ba0975d3
+SIZE (mkvtoolnix-29.0.0.tar.xz) = 7051380
diff --git a/multimedia/mkvtoolnix/files/patch-configure b/multimedia/mkvtoolnix/files/patch-configure
new file mode 100644
index 000000000000..725af280651c
--- /dev/null
+++ b/multimedia/mkvtoolnix/files/patch-configure
@@ -0,0 +1,17 @@
+--- configure.orig 2018-12-01 11:15:45 UTC
++++ configure
+@@ -8467,13 +8467,9 @@ fi
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_fmt" >&5
+ $as_echo "$ac_cv_fmt" >&6; }
+
+-if test x"$ac_cv_fmt" = xyes; then
+- FMT_INTERNAL=no
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: Using the internal version of fmt" >&5
++{ $as_echo "$as_me:${as_lineno-$LINENO}: Using the internal version of fmt" >&5
+ $as_echo "$as_me: Using the internal version of fmt" >&6;}
+ FMT_INTERNAL=yes
+-fi
+
+
+
diff --git a/multimedia/mkvtoolnix/files/patch-src_mkvtoolnix-gui_util_sleep__inhibitor.cpp b/multimedia/mkvtoolnix/files/patch-src_mkvtoolnix-gui_util_sleep__inhibitor.cpp
new file mode 100644
index 000000000000..ea58f2e4c8d3
--- /dev/null
+++ b/multimedia/mkvtoolnix/files/patch-src_mkvtoolnix-gui_util_sleep__inhibitor.cpp
@@ -0,0 +1,20 @@
+--- src/mkvtoolnix-gui/util/sleep_inhibitor.cpp.orig 2018-12-01 11:15:36 UTC
++++ src/mkvtoolnix-gui/util/sleep_inhibitor.cpp
+@@ -6,7 +6,7 @@
+ # include "mkvtoolnix-gui/util/sleep_inhibitor/windows.h"
+ #elif defined(SYS_APPLE)
+ # include "mkvtoolnix-gui/util/sleep_inhibitor/macos.h"
+-#elif defined(HAVE_QTDBUS)
++#elif defined(SYS_LINUX)
+ # include "mkvtoolnix-gui/util/sleep_inhibitor/linux_logind.h"
+ #endif
+
+@@ -66,7 +66,7 @@ BasicSleepInhibitor::create() {
+ inhibitor->addInhibitor(std::make_shared<WindowsSleepInhibitor>());
+ #elif defined(SYS_APPLE)
+ inhibitor->addInhibitor(std::make_shared<MacOSSleepInhibitor>());
+-#elif defined(HAVE_QTDBUS)
++#elif defined(SYS_LINUX)
+ inhibitor->addInhibitor(std::make_shared<LogindSleepInhibitor>());
+ #endif
+