aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mkvtoolnix
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2018-11-24 12:00:56 +0000
committerThomas Zander <riggs@FreeBSD.org>2018-11-24 12:00:56 +0000
commit5b1fb0b4437d38903ba2971857373552411cd5c3 (patch)
tree11808da4460dd3bb106c104e4d292a32ab269016 /multimedia/mkvtoolnix
parent8c509fc683b59f6c910b7240e9960cf712f9df32 (diff)
downloadports-5b1fb0b4437d38903ba2971857373552411cd5c3.tar.gz
ports-5b1fb0b4437d38903ba2971857373552411cd5c3.zip
Fix build on GCC-based architectures
PR: 232822 Submitted by: pkubaj@anongoth.pl Reviewed by: riggs, linimon
Notes
Notes: svn path=/head/; revision=485765
Diffstat (limited to 'multimedia/mkvtoolnix')
-rw-r--r--multimedia/mkvtoolnix/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/multimedia/mkvtoolnix/Makefile b/multimedia/mkvtoolnix/Makefile
index 52bb9ac44d31..a9c5863dc0a5 100644
--- a/multimedia/mkvtoolnix/Makefile
+++ b/multimedia/mkvtoolnix/Makefile
@@ -26,7 +26,7 @@ LIB_DEPENDS= libvorbis.so:audio/libvorbis \
libpugixml.so:textproc/pugixml \
libmatroska.so:multimedia/libmatroska
-USES= compiler:c++14-lang iconv localbase pkgconfig tar:xz
+USES= compiler:c++17-lang iconv localbase pkgconfig tar:xz
GNU_CONFIGURE= yes
CONFIGURE_ENV+= ac_cv_path_PO4A=no
CONFIGURE_ARGS= --with-boost=${LOCALBASE} \
@@ -59,6 +59,12 @@ QT5_LIB_DEPENDS= libcmark.so:textproc/cmark
MANTRANS_DESC= Build and install manpage translations
MANTRANS_BUILD_DEPENDS= po4a:textproc/po4a
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} != clang
+USE_CXXSTD= c++17
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/LIBS="-lintl/s,-liconv,$$ICONV_LIBS,' \
${WRKSRC}/configure
@@ -70,4 +76,4 @@ post-configure-NLS-off:
@${REINPLACE_CMD} -e 's|#define HAVE_LIBINTL_H|//#define HAVE_LIBINTL_H|g' ${WRKSRC}/config.h
@${REINPLACE_CMD} -e 's|S["LIBINTL_LIBS"]=|#S["LIBINTL_LIBS"]=|g' ${WRKSRC}/config.status
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>