aboutsummaryrefslogtreecommitdiff
path: root/multimedia/motion/Makefile
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2017-01-30 00:09:53 +0000
committerJason E. Hale <jhale@FreeBSD.org>2017-01-30 00:09:53 +0000
commit0a3f2e2222a1f3f28b8e9f43e6c615b8e5fb4f49 (patch)
tree31354005dc9a684d4b8fe92ff6f71c0051902aba /multimedia/motion/Makefile
parentf421b382a20e51a4e04f5bddc880cff5df5dbe4f (diff)
downloadports-0a3f2e2222a1f3f28b8e9f43e6c615b8e5fb4f49.tar.gz
ports-0a3f2e2222a1f3f28b8e9f43e6c615b8e5fb4f49.zip
- Fix an issue where netcams were not connecting [1]
- When motion was updated to 4.x, it was overlooked that the default search path for the configuration files was changed. This was causing existing configurations to not be read. Fix the port to install default configuration in correct location and add an UPDATING message giving users the proper instructions on where to place their existing conf files. [2] - Create an empty ${ETCDIR}/conf.d directory that can optionally be used to dump camera configs in instead of creating separate lines for each one in motion.conf - Add some missing PORTDOCS and install with the correct mode - Make the VIDEO options OPTIONS_RADIO instead of OPTIONS_SINGLE to allow for netcam only support (suggested in [2]) - Fix bad logic in configure.ac that was causing V4L to not be dectected when the PWCBSD option was enabled PR: 216189 [1] Reported by: Charles P <charlespigott@googlemail.com> Patched by: <anthony@ury.org.uk> Obtained from: upstream PR: 216466 [2] Reported by: <bakhur@inbox.ru>, tdb@ Pointy hat to: jhale MFH: 2017Q1 (blanket)
Notes
Notes: svn path=/head/; revision=432815
Diffstat (limited to 'multimedia/motion/Makefile')
-rw-r--r--multimedia/motion/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/multimedia/motion/Makefile b/multimedia/motion/Makefile
index e7a2de0cc228..23e9fab92e1d 100644
--- a/multimedia/motion/Makefile
+++ b/multimedia/motion/Makefile
@@ -3,7 +3,7 @@
PORTNAME= motion
PORTVERSION= 4.0.1
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONPREFIX= release-
CATEGORIES= multimedia
@@ -31,17 +31,19 @@ SUB_FILES= pkg-message
PLIST_FILES= bin/motion \
man/man1/motion.1.gz \
- "@sample etc/motion.conf.sample"
+ "@sample ${ETCDIR}/motion.conf.sample" \
+ "@dir ${ETCDIR}/conf.d"
PORTDOCS= CHANGELOG CREDITS README.md README.FreeBSD \
- motion_guide.html
+ motion_guide.html mask1.png normal.jpg \
+ outputmotion1.jpg outputnormal1.jpg
PORTEXAMPLES= camera1-dist.conf camera2-dist.conf \
camera3-dist.conf camera4-dist.conf
OPTIONS_DEFINE= DOCS EXAMPLES FFMPEG MYSQL PGSQL SQLITE3
-OPTIONS_SINGLE= VIDEO
-OPTIONS_SINGLE_VIDEO= BKTR PWCBSD
+OPTIONS_RADIO= VIDEO
+OPTIONS_RADIO_VIDEO= BKTR PWCBSD
OPTIONS_DEFAULT= BKTR FFMPEG
-VIDEO_DESC= Video capture driver
+VIDEO_DESC= Video capture driver (Netcam support only if none selected)
BKTR_DESC= BKTR based TV capture cards
BKTR_CONFIGURE_WITH= bktr
@@ -87,12 +89,13 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/motion ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/motion.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${ETCDIR}/conf.d
${INSTALL_DATA} ${WRKSRC}/motion-dist.conf \
- ${STAGEDIR}${PREFIX}/etc/motion.conf.sample
+ ${STAGEDIR}${ETCDIR}/motion.conf.sample
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}