aboutsummaryrefslogtreecommitdiff
path: root/multimedia/motion/Makefile
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-02-01 12:04:33 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-02-01 12:04:33 +0000
commit3869d095645a2d803ed7ee59d9febc17517f8ea7 (patch)
tree9e0181e078ffa699245a15c08726f31f61781b66 /multimedia/motion/Makefile
parent9caa79b21fb4d724c6f17af958aa64ab84fe3ddb (diff)
downloadports-3869d095645a2d803ed7ee59d9febc17517f8ea7.tar.gz
ports-3869d095645a2d803ed7ee59d9febc17517f8ea7.zip
- Bump PORTREVISION
- Use startup script via USE_RC_SUBR - Add pkg-message to inform about startup script - Fix a runtime error using wrong pid file in daemonised process Approved by: thierry (mentor) MFH: 2014Q1
Notes
Notes: svn path=/head/; revision=342125
Diffstat (limited to 'multimedia/motion/Makefile')
-rw-r--r--multimedia/motion/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/multimedia/motion/Makefile b/multimedia/motion/Makefile
index 7e48b2e7c5e5..18b0b543c213 100644
--- a/multimedia/motion/Makefile
+++ b/multimedia/motion/Makefile
@@ -3,7 +3,7 @@
PORTNAME= motion
PORTVERSION= 3.2.12
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20-%20${PORTVERSION:R}/${PORTVERSION}
@@ -25,6 +25,9 @@ PWCBSD_DESC= PWCBSD based Webcams
USES= gmake
USE_AUTOTOOLS= autoconf
+USE_RC_SUBR= ${PORTNAME}
+SUB_FILES= pkg-message
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -89,12 +92,13 @@ post-patch:
# Resolve name collision with jpeg-8
@${REINPLACE_CMD} -e \
's|jpeg_mem_dest|local_jpeg_mem_dest|' ${WRKSRC}/picture.c
+# Fix pidfile path
+ @${REINPLACE_CMD} -e \
+ 's|/run/motion|/run|' ${WRKSRC}/motion-dist.conf.in
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/motion ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/motion.1 ${STAGEDIR}${MANPREFIX}/man/man1
- ${INSTALL_SCRIPT} ${WRKSRC}/motion.init-FreeBSD.sh \
- ${STAGEDIR}${PREFIX}/etc/rc.d/motion
${INSTALL_DATA} ${WRKSRC}/motion-dist.conf \
${STAGEDIR}${PREFIX}/etc/motion.conf.sample
.if !exists(${STAGEDIR}${PREFIX}/etc/motion.conf)