aboutsummaryrefslogtreecommitdiff
path: root/multimedia/motion
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2018-05-15 14:25:39 +0000
committerLars Engels <lme@FreeBSD.org>2018-05-15 14:25:39 +0000
commitf4d968e5130b67eb5f43ddc230e189c487991cc3 (patch)
treef047df99754d656168c7c4fd768c487593321e7f /multimedia/motion
parent6db8e9b62cd9c0fc74532915202ea015ac0ae5b1 (diff)
downloadports-f4d968e5130b67eb5f43ddc230e189c487991cc3.tar.gz
ports-f4d968e5130b67eb5f43ddc230e189c487991cc3.zip
multimedia/motion:
- Add WEBCAMD option and enable by default - Bump PORTREVISION From the initiating PR: The multimedia/pwcbsd port contains an kernel module that appears to no longer work. The multimedia/pwcbsd port distfile has not been updated since 2014 so it is very unlikely to work. The multimedia/pwcbsd port was long ago replaced by the multimedia/webcamd port. The current multimedia/motion port has a PWCBSD option. This sets --with-pwcbsd in the configure step, create a build depend on v4l_compat and creates a run depend on multimedia/pwcbsd, which is then built and installed but not used. The motion application reads from /dev/video* which is now handled by multimedia/webcamd. The patch provided adds an option named WEBCAMD to an existing radio option that contains the PWCBSD option. The WEBCAMD option sets --with-pwcbsd in the configure step, creates the build depend on v4l_compat but does not create a run depend on pwcbsd. It could create a run depend on multimedia/webcamd but I didn't add that. The only affect of --with-pwcbsd in the configure step of the downstream port is to suppress disabling video4linux support and link with v4l_compat library. At some point the downstream should be advised to change the option names in the configure.ac file to reflect the demise of pwcbsd. I left the PWCBSD option in place and unchanged. It may serve no useful purpose so it could be removed. PR: 228102 Submitted by: Curtis Villamizar <curtis@ipv6.occnc.com> MFH: yes
Notes
Notes: svn path=/head/; revision=470020
Diffstat (limited to 'multimedia/motion')
-rw-r--r--multimedia/motion/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/multimedia/motion/Makefile b/multimedia/motion/Makefile
index acf7658d3fab..e9b747b48d49 100644
--- a/multimedia/motion/Makefile
+++ b/multimedia/motion/Makefile
@@ -4,7 +4,7 @@
PORTNAME= motion
PORTVERSION= 4.0.1
DISTVERSIONPREFIX= release-
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= multimedia
MAINTAINER= ports@FreeBSD.org
@@ -41,8 +41,8 @@ PORTEXAMPLES= camera1-dist.conf camera2-dist.conf \
OPTIONS_DEFINE= DOCS EXAMPLES FFMPEG MYSQL PGSQL SQLITE3
OPTIONS_RADIO= VIDEO
-OPTIONS_RADIO_VIDEO= BKTR PWCBSD
-OPTIONS_DEFAULT= BKTR FFMPEG
+OPTIONS_RADIO_VIDEO= BKTR PWCBSD WEBCAMD
+OPTIONS_DEFAULT= WEBCAMD FFMPEG
VIDEO_DESC= Video capture driver (Netcam support only if none selected)
BKTR_DESC= BKTR based TV capture cards
@@ -53,6 +53,11 @@ PWCBSD_BUILD_DEPENDS= v4l_compat>=1.0.20060801:multimedia/v4l_compat
PWCBSD_RUN_DEPENDS= ${KMODDIR}/pwc.ko:multimedia/pwcbsd
PWCBSD_CONFIGURE_WITH= pwcbsd
+WEBCAMD_DESC= Webcams using webcamd
+WEBCAMD_BUILD_DEPENDS= v4l_compat>=1.0.20060801:multimedia/v4l_compat
+# note: all configure --with-pwcbsd does is not shut off v4l support
+WEBCAMD_CONFIGURE_WITH= pwcbsd
+
FFMPEG_LIB_DEPENDS= libavformat.so:multimedia/ffmpeg
FFMPEG_CONFIGURE_ON= --with-ffmpeg=${LOCALBASE}
FFMPEG_CONFIGURE_OFF= --without-ffmpeg